Smart Locks app not working in Smartthings Classic

Hi there, the Smart Locks app isn’t working for me. I added in Smartthings Classic, but after doing so it doesn’t display any of its functionality. It doesn’t display my lock in the ‘Home Solutions’ section of the dashboard and I haven’t find any way to configure it.

Am I missing something?

I have the Yale Assure lock with Bluetooth ZigBee, which I can currently use to lock and unlock the door without issues.


I had a problem with mine not using the default dth. Using a custom dth is not usable with the smart locks feature.

Try to kill your ST Mobile app and restart it. That often helps if the mobile rendering server is having issues. When this happens the Smart Locks app doesn’t show all the features/screens and is lagging behind. You can refresh manually by pulling the screen down.

Also as pointed out to use SmartLocks only two DTH’s currently work:

  1. The stock “Z-Wave Lock” and “ZigBee Lock” device handlers
  2. The latest version of Enhanced Universal Z-Wave Lock device handler:

Thanks guys, unfortunately that didn’t work. I am using ‘ZigBee Lock’ published version.

RBoy I also uninstalled the app and installed it again.

Any other ideas?

Contact ST support, the servers have been having issues for the last 2 days

Hi, have the same problem, have tried everything and stumped. I have a Yale YRD 226 lock with Zigbee. Any help would be fantastic. Load the app but it does not show up in Home Solutions or see my lock. Other apps have no issue with my lock.

tried over the last 4 weeks so can’t be servers