Smart Lighting set level command not working

Please contact support on this.

Thank you,

The fix is coming and it will be to the hub. (later this week)

Thank you Todd, looking forward to that.

Known issue, hope fix is coming soon. For now I’m using “Lighting Director” and it sets dim levels as expected. I actually like this app a lot cause with each app instance you can configure up to 4 different lighting scenarios. I have a couple of these installed and named it accordingly and setup individual rules inside the app. Nice way of grouping similar lighting rules together.

I’m might even stick with this app even after Smart Lighting is fixed.

Same here I.have light set to go on and set level… set level not working.

Any updates here? Still having issues.

I finally updated to V2 and I’m running into this issue as well. My hub is up to date so obviously no patch has been issued. What’s going on?

Between this, losing automated control over my garage doors, and the false promise of “local processing” I’m actually far worse off after “upgrading” than I was before.

This is still not fixed. Getting really frustrating at this point. The problem only seems to happen when setting up rules based on motion sensors. If you have routines or Smart Lighting rules set up based on timing or other switches, the lights correctly dim to the right percentages.

I did figure out a ridiculous workaround last night if you’re really desperate to have this functionality.

Details here: V2 Issue with "turn on and set level" not actually setting dim level (crazy workaround inside!)

Still broken, it’s been over a month now. Is there an ETA for this most basic of functions? Really getting angry at this point.

Can anyone verify that this is fixed since the recent hub upgrade this week? It’s still broken for me.

Still seems to be broken. Huge bummer since I just migrated all of my lighting commands over to this just to find out that it doesn’t work.

You can use Rule Machine instead of Smart Lighting. Rule Machine doesn’t have this problem. So you can have Smart Lighting run locally on a V2 hub, but not work correctly, or Rule Machine, running in the cloud, that does work.

ya problem is I want lights on a dimmed at night when coming out of bedroom going to bathroom. and then turn off after x time… I think the delay of going with the cloud would kill the purpose of this automation… what do others think.

I’m on hub V1, so every automation I have runs in the cloud. They all work almost all of the time. So, this automation should work fine.

thanks trying it now… cannot figure out how to turn the light back off after 2 minutes… I assume I need a second rule … with motion stopped delay 2 minutes?

rule has condition: motion active, rule: motion active, action for true: light on; action for false: delayed turn off after 2 minutes, cancellable. The cancellable timer means that if motion starts again, the light won’t turn off. The light won’t turn off until 2 minutes of no motion at all.

thanks trying it now… would be nice to also have option set dimming to this level delayed cancellable.
so I can set level back to 100 so if someone uses the switch it comes on normally.

Was this every fixed? I am still having a similar issue.

This has never worked for me until this evening. For the first time my lights came on with motion and correctly set the level. I am curious if this was something that was fixed while working on the current issues ST is having.

It looks like it was possibly fixed for me yesterday.

I have some smart lighting rules that previously never worked, lights did turn on and off, but level was never set.

Starting yesterday it seems that they are getting the level set.