Smart light - an unexpected error occured

The concept being used here is a bit new.
It’s a parent/child smartApp.
The parent is Smart Lighting, installed from the Market place.
Within the parent App, clicking “New Lighting Automation”, creates a separate child smartApp with the name being suggestively set for you when the automation configuration is completed.
The child apps can be managed/changed/viewed collectively in the parent app, or can be modified individually by selecting the details view of a “thing”, then selecting the smartApps tab. There you will see the childApp(s) that are using that specific “thing”
To create a new childApp, you open the parent “Smart Lighting” app in your things/smartApps page, then select “New Lighting Automation”.

Mike, not sure I understand you. I go to the marketplace to install “Smart Lights” for the first time. And that is when I get the error message. I am not able to install this app from the Market place. This is happening on all my accounts regardless of V1 or V2 hub.

Yea, two separate issues. I don’t know what’s going on with the initial install problem.
I was trying to clarify how the thing works after you get it installed.

Yeah this is work only when you have your 1st smart light installed, otherwise… up to now, you cant get the first smart light installed…

I just got below response from support team:

I had the same problem this morning. I had two instances of the lighting app originnaly and they both worked. This morning I tried go set up another instance and got the “unexpected error”. Also I noticed the icon changed on the smat apps list next to the lighting app. I found that you need to delete multiple instances and create the children as Mike explained. Since I was originally able to create muliple instances, something clearly changed on the Smartthings side, which is a bit disconcerting.

Yea, it was alluded to here:

I figured this was added specifically to deal with the confusion over “smart lighting” usage…

Just to throw something else in the mix…My Smart Lighting is working, so far, but, if I try to edit or add a lighting automation, I get the “Unexpected Error” on my Android…I also have an IPhone, same thing, except error reads “Failed To Save Page: namePage”. This always happens on the last page when you hit done…

do you have multiple instances of smart lighting installed?

No, 1 Smart Lighting with multiple automations…

@Robert_Robinson

The post @Mike_Maxwell posted is different then your problem. I’d recommend reaching out to support.

Already Did… 20 Charactersssssssssssss

1 Like

As of an hour ago it is now working.

Not really sure they solved the confusing part but it sure confused me for hours until I see your post. There’s nothing to point me to go into smartapps then click on my previous installed smart light to get another instance. Maybe the unexpected errors occurred throwing this whole thing off.

It is working now - back to normal again

Robert,

Did you ever get a resolution on this? I’m having a similar issue: go into Smart Lighting App, add new lighting automation, set up the automation (lights on at sunset off at sunrise), hit next for the automation name screen, edit the automation name (at which point it goes green and says it’s running), hit Done…and I get ‘Failed to save page: namePage’ and the automation does not seem to be working.

The resolution was to be very careful with how you name the automation…No /-&, just letters,

I am having the same issue. I made sure that the name of the automation does not have any special characters, but I see the same error “Failed to save page:namePage”. Anyone else seeing this?

I contacted support and they replied with the fact that I didn’t have a home location setup and because of that, it doesn’t know what sunset is. That made sense. I added my home location (strange enough my Android app doesn’t show anything on google maps, just my current location).

re-created my “Turn light on 30 minutes before sunset” rule and it saved now but it did not execute… I am going to give it one more day to see if I just missed my execution window as I was getting close to sunset-30

This was my first support request and I must say I was impressed with the response time and provided help.

I am having this same issue. I have tried changing the name to only letters, and I have made sure that my location is setup. I still get the error.