Smart Life integration (July 2020)

New integration as of July 15, 2020.

10 Likes

I did some tests and it didn’t work.
It may not be ready. Anyway, that’s great news.

5 Likes

I just flashed all my devices so that they would work with smarttthings. And then I saw this. Well, at least in tasmota, I can disable the leds for plugs in the bedroom. I’m still going to flash my plugs for this.

Does once it starts working, can you please tell me if it works with dimmers and energy metering plugs? I don’t have any now because they all have tasmota.

1 Like

@dare2smile, you might will like this more than the IFTTT integartion… (When it will start to work.)

2 Likes

@Flakie99, this might be your chance with your bulbs… (When it will start to work.)

2 Likes

Thanks, but mine are all on tasmota now. And working really well too :slight_smile:
Had no issues at all for a few weeks now (well except for all my motion sensors are reporting batteries less than 70%, even new sensors and ones with batteries replaced within a couple of days. But thats another story).

1 Like

That might be a tasmota battery calibration issue…

Ah thanks. I should have said but these are all SmartThings motion sensors.
Battery level is dropping on all of them at a fast rate though.

It seems to be working for me, to a point. When adding a device, the only two options are “Lighting and Outlet”. Regardless, I end up with a message, “A network or server error occurred. Try again later.”

However, turns out I didn’t need to add a device. Just choosing Smart Life and authenticating was enough. My Tuya-based devices are showing as things.

But not all of them are showing. In my Smart Life app, I have about 10 lights, a blind, a power-board and a kettle. Only lights are showing in the SmartThings app.

And only four of the lights are showing. I haven’t been able to work out which ones. None of my colour lights is showing, only white ones. But some of the white ones are also not showing.

Also, while I can click on the on/off symbol on the card to turn a light on/off, when I tap elsewhere on the card the app says, “We need to download an add-on to help you get the most from your .” with options to cancel or download. When I tap “download”, after about 3 seconds, a message pops up saying, “Couldn’t download. Contact us for help.”

Not working for me.

It says "compatible but not certified in US.

When adding a device, the 2 options are “Lighting and Outlet”. Then, I end up with a message, “A network or server error occurred. Try again later.”

2 Likes

I got that too. But when I next looked at my list of devices, some of my Smart Life app devices showed up - without me having to do anything. I’m guessing the ST and SA clouds talk to each other, once you link them.

No such luck. I checked the new app, old app, and IDE and no “things” showed up.

I also got the message “A network or server error occurred. Try again later.” but one of my six devices were still added to ST; in the IDE the Device Network ID is “Tuya Inc.|:light|:”
Hopefully we will soon see more devices appearing - but this is very exciting!

1 Like

Yep, mine are all the same ID as this. The generic device name (visible in the device’s detail page) is “c2c-dimmer” for all of these.

The hex number suffix to the network ID matches the “Virtual ID” in the Smart Life app. I wonder if I can add more devices manually by using the virtual ID from the app?

I tried adding a light bulb this way. A new icon shows up in the app, but the status under the icon says “connected” rather than “on” or “off”. The icon appears to be a generic device icon, rather than a light.

When I press on the icon, I get a message about downloading an add-on, but when I select “Download” it fails. But I started getting this add-on message for all devices, so not sure what’s wrong here. Maybe when the add-ons are working, I’ll be able to turn it on/off.

This may not apply, but I posted recently about getting this message on my tablet and not being able to get any further. But when I switched to my phone, I was able to download the add-on and after that it worked on both my phone and my tablet. So for some reason it was requiring a cellular data plan on the device in order to complete the download.

Probably not relevant, but I just thought I’d mention it in case. :sunglasses:

1 Like

Yeah, I wondered about that too. I turned off wifi on my phone (which has a mobile data plan) and tried again, but I got the same result. Every device icon on my home screen does this now, even a Zigbee light that’s paired directly with my ST hub.

In other news, the classic ST app no longer works for me, and instead gives an error on load: “Something’s Wrong/We can’t load your screen right now” and a toast with “You appear to be having issues with your network…” Not sure if the two problems are related.

Somewhere I have a tablet, so I’ll dig that out and see if I get a different result.

1 Like

What device type is listed in the IDE?

It’s “placeholder”, same as all of the other devices added via cloud integration:

1 Like