Smart Hub not loading on Neo QLED 8K after software update version 1503.9


I have a brand new Samsung TV Neo QLED 8K (QE65QN900BTXXC) since beg of January 2023 and it all worked fine until June 15th, 2023, when the Smart Hub suddenly stopped loading at start-up, as well as when pressing the Home button on the remote control.

Booting shows a blue screen with a “dancing” Smart Hub Home icon in the middle, surrounded by stars, for sometime, then an empty blue screen. No message is displayed, and nothing else happens.

All buttons on the smart remote work fine (Netflix, Disney+, Settings, etc.) except the “Home” button which has no effect.

All HDMI sources work fine.

Smart Hub diagnostics show everything is OK (network, DNS, apps, etc.). Smart Hub resets (several times), cold boot, factory reset (several times), changing Samsung accounts, nothing helps.

I called support twice. They first had me do a factory reset, which did not solve the problem.
The second had me do a “flash reset”, which did not solve the problem either.

The software says it is up-to-date : version 1503. Coincidently, the Samsung Support Firmware/Software web site shows a software update version 1503.9 available on June 12, 2023.
I tried to re-install the software update to version 1503.9 from a USB drive, but it would not accept to do it. Because it is already installed, I assume…

Could a malfunctioning firmware update be the source of the problem ?

Any idea before I call support again?

Thanks for your help

Hello again,

Someone gave me a suggestion that solved the problem…

These are the steps I followed:

  1. Hold on the power button from the TV monitor (not from the remote) for 20 seconds.
    If the TV monitor is connected to a remote “One Connect” box, and has no power button, unplug the One Connect box for 20 seconds.

  2. Right after those 20 seconds, then hold on the power button on the remote for another 20 seconds (needs to be quickly after the first 20 seconds). You should hear some kind of “tick” on the TV.

  3. After those 20 seconds, wait like 5 to 10 seconds, and power on the TV monitor / One Connect box.

  4. After doing that, Smart Hub should be working again. You will need to configure everything again.

So, basically, seems this is some kind of Reset to factory but like in a deeper or more complete level that the Reset option from the Settings Menu.

Hope this works for you as well.