SmartThings Community

Smart Home Monitor


(Geko) #41

I have the same problem, the only difference being that I cannot dismiss smoke alarm since last Saturday. It was working in the past, so this is the issue that’s been introduced recently. These perpetual screw-ups are extremely frustrating.


(Jimmy) #42

i’ve found lately that i have to dismiss it and then manually pull down on the page to refresh it (iOS app) to get the red to go away.


(Scott) #43

I left for some meetings this morning - the APP correctly recognized that my iPhone had left the Geofence, and activated “Goodbye” routine this morning. When I got home this afternoon - “I’m Back” triggered correctly, turned off SHM, opened garage door, etc. When I checked SHM after getting into the house - it was showing the green “Everything OK” banner.

Apparently leaving, and returning reset it.


(Adam Davidson) #44

+1 for a delay option in SHM, to give time to enter a code on a keypad, or for presence sensors to update.


(phil) #45

can you send out sms to multiple number in SHM


#46

Yup, just set up people in your Contact Book in the ST mobile app via My Contacts.


(Dan) #47

That is, if you’re lucky enough to have the “My Contacts” feature in your ST mobile app. Unless something has changed recently, ST seems to not be propagating “My Contacts” any longer. You have to use a trick on Android to get it to appear, IIRC. And once you do have “My Contacts”, you lose Hub Offline and Low Battery push notifications. At least I never receive those notifications any longer…

But yes, you can do multiple push or sms notifications in SHM if you have My Contacts. :slight_smile:


(Joern) #48

Looks like not only Low Battery push notification isn’t still working if My Contacts is enabled. I set up a custom rule in SHM without notification for my outdoor Arlo camera but always get a push notification. Opened a support ticket last week, but support wasn’t able to fix by now. They had to forward to the engineering team. I was told by support, My Contacts is a discontinued feature. Support mentioned the SHM custome rule push notification issue could be related to the Contact Book.

Does any of you have the same issue?


(phil) #49

I Guess it is time to create my own security application with webCoRE


(Joern) #50

Is there a way to stop this annoying push notifications from SHM custom rules?


(Dan) #51

Sure. Go into your custom SHM rule, and then go into “Text and Push Notifications”, and remove all entries.

Maybe you’ve already tried that?

Maybe delete the custom rule and then recreate it?

Not sure why you’d want a custom rule if you didn’t want the notifications? Isn’t that usually the point of the custom rules? I use them to tell me if a door has been left open for too long, or when Presence sensors come and go, etc…


(Joern) #52

I tried this all, but w/o luck. I have an arlo cam which is monitoring my porch. And I only want to get notifications in the Home and Away mode, but not at night :frowning:
Unfortunately it’s not possible to say SHM only to send notifications during certain modes. The idea is to stop the SHM push notifications and to realize with “Notify me” or (web)CoRE.


(Dan) #53

SHM definitely allows you to customize the rules to only run for specific MODES. There is a small “More Options” + symbol at the bottom of the page where you select which sensors you want to monitor. In that section you can exclude your “Night” mode and only select Home and Away.


(Joern) #54

Yes you are totally right, there is an option. But if my understanding is correct that would switch the entire rule on and off and not only the push notifications. Please correct me if I’m wrong. I don’t want to get push notifications in night mode, but the porch camera shall record if it detects a motion in night mode.


(Dan) #55

You are correct. So what purpose does the SHM custom rule server for you, other than notifications? I guess you could create 2 custom SHM rules: 1 for notifications (which only occurs for 2 of 3 modes) and 1 for whatever else you need the custom rule to do for all 3 modes.


(Joern) #56

I want to have the porch camera recordings in the Smartthings app without any alarms and without a push notification in night mode. The issue is that I get notifications still there are no entries in “Text and Push Notifications”

I don’t believe it will help me to create more SHM custom rules. Unfortunately Smartthings support doesn’t really help on this. I opened a ticket one week agao and only heard, they have to talk with the engineering team. :frowning: Maybe “My Contacts” is the problem. Do you have this activated?


(Dan) #57

I do have “My Contacts” but I have never tried to “not have a push notification” when using Custom SHM Rules. I’ll take a look at it over the weekend.

have you tried deleting the custom SHM rule and recreating it without ever setting up the Push/Text notifications? Maybe that will work?


(Joern) #58

That would be great if you could try it out.

Yes, I tried to remove and recreate the SHM custom rule, but without any changes. The push notification will be send out to all users in your account. Also the Hub is offline and battery level push notification doesn’t work with the “My Contacts” activated.

Thanks for trying this out! over the weekend!


(Dan) #59

Just ran a quick test and you are absolutely correct! Even without setting up the Text/Push settings, I received a Push Notification.

However, I did find a workaround! Add a new contact to your “Contact Book” with just a bogus phone number (e.g. 999-999-9999). Use this contact for your SHM Custom Rule used for the Cameras. This will suppress the push notifications altogether for this rule.

Then, add another custom rule and use your real Contact(s) for the push/sms notifications. For this rule, use the advanced options to suppress the rule during the Night Mode.


(Joern) #60

Thanks for that. Sounds interesting. I will try it out and will let you know if that works for me.
Good workaround, I believe. Would be great if that would work.