Smart Home Monitor (SHM) edit not working via web console

Smart Home Monitor (SHM) access/edit not working via web console

Works when editing via phone/mobile app.
When clicking from the webconsole from “automations” tab, getting error:
ERROR: Something went wrong. Please try to install the SmartApp again.

Any ideas?
Did delete/recreate it again.
I`m in Europe/Poland.

  • has it worked previously? or did the error pop up recently?
  • have you tried uninstalling/installing STHM?
  • have you contacted ST support (be patient when you do submit a ticket)?

to contact ST support… use the ST app, tap on Menu and select Contact us

Have you ever seen it work? User created SmartApps seem to work OK from that site but the stock apps seem to draw on completely undocumented features and be rather more tied to the mobile apps for their UI so I’ve never really expected them to do much.

I find rather odd. It was a welcome start but seemed to be totally abandoned for a very long time before suddenly being thrust into use when needed to resolve to something.

I recall just once, that I was able to open STHM via web, post creation.
But you are right - when checking other stock apps - nothing to cry about if it is missing from web console. In application it works perfectly.

BTW - Noticed some changes there recently - upon clicking in web console the URL of STHM has more GET variables now.