Smart Home Monitor disappeared from Classic App? (Using ST/ADT hub)

Don’t know if this is going to help anyone or not but one of the sensor’s that would not report in Was defective I got an RMA from Samsung and they are sending me a new unit the other one was a simple factory reset and re-pair.

Considering the sheer volume of products That I have installed more or less all at 1 time the failure rate isn’t fantastic but it isn’t terrible either. Certainly a lot better than Hewlett packard servers.

I am concerned about my ability to use the utilitate sirens and the ring camera lights in sirens from within the ADT Panel. With any luck we will be getting that sorted soon.

Any luck on getting SHM to show up? I’m a former Iris user, and just got my ADT hub set up and don’t see the SHM anywhere in either app, and can’t find a way to trigger lights, and a utilitech siren without having SHM.

Nope. Support from Samsung / Smartthings are basically telling me it isn’t supposed to work at all.

Look at the ADT Tools 2 thread. I need to figure out how to use custom code, but ADT Tools 2 is supposed to give the functions that ADT users lose with the loss of SHM.

I will post up with my progress on it, but I have a bigger issue right now with my security hub…

1 Like

Okay, so I got the ADT Tools 2 installed and configured I think how I want them… I still need to verify I am not having an issue with my hub, but here is what i have…

#1. Read the article about using custom code / smartapps…
http://thingsthataresmart.wiki/index.php?title=Using_Custom_Code#How_To_Publish_Custom_SmartApps_and_Device_Types_to_Yourself_So_You_Can_Use_Them
#2. Read the article about installing and using ADT Tools 2…
http://thingsthataresmart.wiki/index.php?title=ADT_tools_2#One_word_caution

Logged into my account at https://graph.api.smartthings.com/ (using your samsung account credentials).

Clicked on my locations, and then my location name…
Clicked My Smartapps

In a separate window I browsed to find the ADT Tools 2 code, and copied the files to my computer.

Clicked new smartapp, from code, pasted and saved, then published to myself. Repeated for each of the 3 files.

Restarted my Classic app, and voila, ADT Tools 2 was available!

Now I have control over those Utilitech sirens from within my alerts…

2 Likes

Use https://account.smartthings.com and not the link you posted

I have to ask what’s the difference? I posted the link that Samsung gave me when I talked to support

https://account.smartthings.com will redirect you to the appropriate shard (server) where your devices and smartapps/device handlers are installed. the URL you posted doesn’t or at least it didn’t use to. So if you happen to login to that URL and are not redirected and you attempt to install any device handlers or smartapps there - they will not work in the ST app. more on shards in the following link…

in your situation, you were directed to:
Clicked on my locations, and then my location name…
which redirects you to the appropriate shard. but logging into the link I posted will do it automatically.

I am just trying to avoid confusion for some users who might get lost when they try to use the URL you posted. :slight_smile:

1 Like

No problem and please don’t misunderstand my asking questions I’m not doubting anyone here or anything like that I am asking questions because I honestly don’t know and I’m trying to learn. Coming from Iris there is a lot to learn about smart things and in particular ADT smart things. Sits and of a steep learning curve and I need to be up to speed

questions are welcomed here.:slight_smile:

I just worry I’m being a pain in the tail. I’m trying to get a lot done in a very short period of time on a system that is similar enough to Iris but very much different that I’m getting tripped up more than I would honestly like. And honestly it would be a lot more comfortable if I had had more lead time period.

I have the ADT tools 2 installed and configured and all of the function that I wanted from smart home monitor has been restored. Plus I have functions that I couldn’t even find there so I am very happy.

2 Likes

Keep in mind that you’re miles ahead of 90% of SmartThings customers.

While it is impossible to know the exact number, it is a certainty that the overwhelming majority of SmartThings users never login to the “IDE”.

I believe that the address “https://account.SmartThings.com” (and all the “graph.api” variations) are not published in any of the official consumer facing SmartThings documentation.

Thanks,

While I am no developer, I am a Linux user, so I am not afraid of getting in, reading, asking questions, and trying things out. And I am starting to dig more into development to mostly scrape rust off of my aging brain, so I have recently opened a github of my own, and started through hammering away at some html5 and perl stuff. I know perl isn’t anyones favorite anymore, but it’s one of the languages I used a LONG time ago when I did that kind of work…

Coming over from Iris to Smartthings is a bit like upgrading from say if older Ubuntu Linux had init based on System V and iptables firewalls, and going to CentOS 7, with systemd, oh, and SELinux in enforcing mode… Not an impossible task, but certainly a learning curve.

The short lead time before Iris goes away entirely is another of the driving factors. I could probably catch this with a few months of casually strolling through the forum, quietly watching and experimenting on my own, but I need to be covered. I am after all protecting my family, and my home…

Hopefully folks have noticed that as I figure things out, I try my best with the time and skill given, to share my findings and document any procedures I can come up with to help out the greater community.

I am going to keep that https://account.SmartThings.com bookmarked as that will certainly help out. The method I showed earlier was what I gleaned, and it worked, but seems like a longer path to the same thing.

1 Like

Folks, I have found it, sort of. Let me explain…

Yesterday as we were moving about the house, I was keeping the alarm in armed, stay mode. We weren’t going in and out, and honestly, the neighbors that are the main problem were. We have a renter in a home next door with a teenage kid, since they moved in there has been a spike in property crime in the neighborhood. Not sure if it is the kid, or his friends, or even directly related, but certainly enough of a coincidence to keep me concerned.

As I moved about the house, my wife opened the door to the home office, one of the rooms with the Iris sensor, and not configured for my Home Security alerting as it is not ADT, and the alarm went off. I was able to disarm the alarm and tried it again, this time in the workshop door from the house, again same thing, alarm blaring, lights on etc…

I removed the Iris sensors but kept getting text messages from Smart Home Monitor RE: intrustion detection into Office door, or Workshop door.

I drilled into the push notifications in my history panel, and sure enough, it took me to SHM.

So that begs the question. How do I now fully disable SHM / keep it from trying to arm / disarm instead of ADT Home Security? I am now using ADT Tools 2 that gives me more at least obvious options compared to SHM.

If you try the classic app, under my home and then things. Select one of iris contact sensors, then select Smart Apps (top right corner), are you able to see the smart home monitor rule that is causing the alarm to sound? If so, you should be able to delete the rule here.

I don’t recall seeing that there before I pulled the sensors out of the system… Will have to re pair them again tonight and try…

I’m pretty sure it’s a hangover as it were, from when SHM was visible from the classic app…

I am soooo very close to having the system at the point I want it, but I will update my other thread…

It might be worth logging into the IDE and see if you can locate the shm rule causing the problem there. I remember seeing the rules there as well.

1 Like

I’m willing to dig. But I am very inexperienced with the IDE, can you recommend where I would be able to look?

Once you have logged in, under the menu (top right) select locations, next screen click on your home name.

Look for Installed smart apps, click on list smart apps.

There you should see under solutions, smart home monitor rules.

No soap… That’s where I was looking I just thought maybe, just maybe there was somewhere else…