Smart Alarm Updates

@geko could you please tell me how to get to the web ui

Are you referring to removing the settings in SHM?If so that is easy all you do it open SHM and click the gear to configure and remove all the settings you have and click remove at the end of each category

  1. Security
  2. Smoke
  3. Leaks
  4. Custom commands.
    Then got to Marketplace and install SA if that is what you plan on doing…

Also you will have same problems if you are using presence sensors as they are unreliable. If you purchased the keypad do a search and the install info is available. Once that is all installed and SA is setup you can use SHM just to see status. Plus another community member has created a app and device type to show status and disable siren if alarm goes off.

I use 360 and key fobs with Smart Alarm. I use nobody’s home app along with presence sensors to change to home and away which engages the security. And it works flawlessly.

Well I tried 360 and found if I was at a neighbor’s house my home would be disarmed so the geo fencing is way to large an area. If your house is on a big piece of property no problem, but houses close together then you have a problem. I had keyfobs also, but found them to be a pain as if I went out for a bike ride or walk I had to have it to disarm or arm. So my wife and I decided the IRIS keypad was the solution as we had that in our original home. Now we arm and disarm with the IRIS. Bruce helped me with a Rule and a device type that is run on Rule machine that when my alarm is armed and we walk into the home the light in the hall near the IRIS keypad flashes warning us that we have 30 seconds to disarm the alarm. it works without a hitch every time.

1 Like

Could you please provide me with a link to the Iris device handler and rule configuration. Thanks.

Top Post has both the device handler and the app. I am not sure if the one posted saying X3400 has the fingerprint for the IRIS Lowe’s version, but if not it is posted down in another post.

If not look at post somewhere near #514 just do a search for IRIS Keypad.

The rule is from Rule machine and Here is the link Rule Machine rule

It is the post where Bruce says he found another way and includes a link to a device type. You will have to read all the posts above he explains how to add the rule etc. You have a bunch of research now.

Arm Stay does not arm any interior zones (good) but also does not arm any exterior zones that have a delay on them (bad). This happens regardless if the delay for an exterior zone is set to be ignored in Stay mode or not. The only way to arm all zones is to set away, open Smart Alarm in ‘Smart Apps’, Select ‘Alarm is ARMED STAY’, Select ‘Next’ without changing any options, select ‘Done’. Then when you go back into ‘Alarm is ARMED STAY’ it displays all zones as armed that should be.

I have also tried waiting 45 seconds (even up to 5 minutes) after I arm ‘Stay’ to see if there is some kind of weird grace period but that’s not the case either. Looks like a bug.

I don’t have any such problem, but I don’t know if it matters but I arm from a keypad don’t use any presence sensors or fobs.

Funny - I was just talking to support about this. They told me the problem has been noted and a ticket has been created

The more I have been working with the ST system the more I see problems that some people have and and others don’t. I use my alarm every day and don’t have any problems since I arm using my IRIS keypad and disarm using my iris keypad. When I arm home from the keypad I get a 30 second warning, and to prove it is armed I open a door that has a delay and it says disarming in 30 seconds. If I don’t enter the code in the keypad the alarm goes off so the zone was armed.

1 Like

So your alarm still goes off when a contact sensor opens when in ARM STAY mode, and with delays enabled on that door and turned on in the app?

Support was able to reproduce the issue I had

The issue I described is in ARM - STAY mode not ARM - AWAY.

Can you provide your steps to reproduce so I can compare with my issue? Did support give you any idea of their next steps?

I just found that, with delays turned off in stay mode, I would never get alarms on any doors with delays turned on. Workaround is to keep delays enabled in stay mode, or to take the delay off that sensor entirely (no delay in away mode either).

I was told a problem ticket has been opened for engineering, was not given an ETA to fix.

I currently keep getting an error when I go to Alarm options I need getting a “Sorry, but there was an unexpected error.” I have an Aeon Labs Siren. Is this the area I would set my alarm option? Has anyone experienced this before?

@geko Can you acknowledge the bug I posted?

Please refer to the README file:

Please note that this app is provided here as is and is no longer supported. Smart Alarm users are advised to switch to Smart Home Monitor (SHM), the native home security application developed and supported by SmartThings.

do what?! after screwing with SHM i pitched it for SA. your dumping it?

Unfortunaltely, I have neither bandwidth nor incentive to support Smart Alarm. If all you need is casual monitoring, SHM will do just fine. If you need reliable, bullet-proof security system, SmartThings won’t cut it anyway.

For what it’s worth @geko, I still use your SA and it works very well in comparison to SHM. Have had no problems in the past 3 months knock on wood.

I have made various code mods to the application to fix small things here and there, but I definitely do wish there was more updates to it.

I have the feeling you’ve switched platforms @geko, where did you go?

1 Like