Smart Alarm is here

This is fantastic. Well done.

This is great! Is there any way to have manually-entered SmartApps show up in the SmartThings dashboard? For example, I’d love for Smart Alarm to actually show up under the Safety & Security pane for easier access. Right now I have to go to Things -> Find a siren or sensor -> Gear Button -> Smart Apps -> Smart Alarm.

I would love this. I am currently using SimpliSafe for my alarm system. I would love to be able to consolidate everything to SmartThings in the future. However, a backup data connection (cellular) would be nice for redundancy.

Some here have mentioned the idea of adding a cellular connection to your router via a 3G/4G USB stick but I have not tried it.

Ive had really good luck with this router on Verizon 4g

Looks great, thanks! However, I have a newbie question. I installed the SmartApp per the instructions and published it. However, when I load the mobile Smartthings client on my phone, I do not see the app anywhere. I pressed the round “+” symbol on the Dashboard, but the “My Apps” tab/option is no where to be found. I’m using Android O/S on a Samsung Galaxy S5. Any assistance would be appreciated.

Thanks!

log out of the app and log back in. It’s a “feature” - like shaking for names.

Thanks again! I figured it out shortly after I posted the message. One last question… now that I have it set up and added all of my sensors (including a siren), for some reason, nothing happens if any of my zones are ‘tripped.’ I receive proper notifications that all zones are armed when I change my status to “Away.” But, when any door contacts or motion sensors are triggered… nothing. I’m scratching my head over here.

Also, not sure if this is related, but I do not get the “Panic” or “Reset” buttons on my mobile client either.

Try disabling entry/exit delays.

I will try that, thanks. And, for anyone interested, it appears that buttons are not an official feature as of yet and not currently supported. Looks like they work (for the most part) on IOS devices, but not on my particular Android device. :frowning:

@geko - great work. I’ve been using this App for a week now and I like the concept. One issue I’m having is that the zones are not arming properly when I change the modes in ST.
For example, if I switch the mode to “Night” and look at the Alarm Panel Status, it shows the “Alarm is now Armed” however, all of the Zones are “disarmed” even though they are exterior sensors. If I go back through the “Configure Smart Alarm” screens (not changing anything) the zones switch to their correct “armed” states.
What this means practically is I can’t rely on this App to protect my home as the zones aren’t being armed properly. Any ideas why?

I believe it’s a side effect of ST’s “eventual consistency” data model. What it means is that when an application saves its state there is a certain time window when reading it back may return stale data. The data will eventually become consistent, but it may take several seconds. Unfortunately, this is a “feature” of the ST server implementation and cannot be easily solved in the app.

Is there a way that the ST app would open when the alarm is tripped so I can quickly turn it off, maybe pop up a disarm button on my phone?

3 Likes

@geko - does this mean the zones actually are armed the App is just not updating correctly?

@geko did you get my email? I sent one to geko@statusbits.com

@fostered This may well not be your issue, but it was something that initially tricked me: For all of my zones I set the “Enable zone bypass” setting to “On” for all of my zones, thinking “Yes, I would like to enable this zone to be bypassed.”

What this setting does, though, is actually make the zone be bypassed. Like, now. So, all of my zones were initially bypassed and wouldn’t arm. The antidote was to go into the Quick Bypass screen and un-bypass all the relevant zones.

Just a thought.

@schmedlock - thanks for the idea but I have them checked to “off”.

Great Application!
A question… If i have two smart things users for the same hub (and I am using smart things and cell phone for detecting presence), is there a way that the two users would see the same configuration of Smart Alarm (the same way we do for example for the applications that are published “for everybody”?

Currently i installed the app in the 2 users and they see different sets of properties (that can be inconsistent).

Thanks,

Luiz

I setup SmartAlarm and it worked fine, until I configured it with an EntryDelay. Once I did that, it would not trigger an alarm again, even if the system was not disarmed as expected within the 45 second delay expiration.

Somewhere I found mention of running Unschedule() prior to running RunIn(). I modified my SmartAlarm code to call UnSchedule() before each Runin() statement and now it seems to be working as expected ( also decreased my EntryDelay time from 45 seconds to 10 seconds as that is all I need for my door lock to send the disarm command).

Hopefully this helps someone else that may also be experiencing this issue.

...
Unschedule(activateAlarm)  //Added to fix issue with RunIn() not executing
runIn(state.entryDelay, activateAlarm)
....
unschedule(panelReset)  //Added to fix issue with RunIn() not executing
runIn(state.exitDelay, panelReset)
...
unschedule(panelReset)  //Added to fix issue with RunIn() not executing
runIn(180, panelReset)
...
1 Like

Smart Alarm has disappeared in my iOS ST app interface. I can’t find it anywhere but I can tell it’s still there from mode changes. Any ideas?