Slow dashboard and incorrect device states


(Jody) #1

I am using a nexus 5 and Android Lolipop. I have a decent internet connection and my latency is sitting at 49 ms. My wireless coverage is great and I am having no other issues than with the smart things app. It takes over a minute for the dashboard to load, and when it does; it’s filled with incomplete or missing device states. My temps are all dashes, lights are showing on while off and vice versa. I can view the activity feed and when I return the device will have some of its information populated, but this is always hit or miss. Also, I don’t want to have to view my activity feed for each and every device. I have opened a ticket and will wait for support to direct me to reboot the hub.

@Tyler is this a known issue?


(Gary D) #2

I’m curious… When you see this on the mobile app, are the states showing properly on the device pages on ide.smartthings.com?

(Just wondering if it’s a mobile app issue, or a wider ST cloud issue)

Gary


(Jody) #3

Are you talking about a virtual device in the ide? I have not checked that. The current data is visible under the device’s page at https://graph.api.smartthings.com/device/show/. I can see the proper current state there. If I look at the devices activity feed in the mobile app, then return to the device, it magically starts working.


#4

I haven’t seen similar reports this morning and I’m not able to replicate on my end. I’ll check out the ticket.

I don’t expect rebooting the hub to help in this case, though I’d try the following things:

  1. Force close our app
  2. Switch from WiFi to cellular, or vice versa
  3. Reboot your phone

(Jody) #5

Force closing the app fixed it. That is the solution I have used in the past when this happened. It seems to be happening more frequently as of late. My dashboard is still taking over a minute to even load. At least the states are correct now.


#6

The long load times have been fixed in an upcoming release.

It’s likely you’ll see a minor version bump/bug fix update then our big rewrite update a few weeks after that.


(Jody) #7

I have seen the video and it is quite impressive. Thanks for the quick response.


(Geko) #8

In my experience, refreshing things view (by pulling it down) on iPhone always takes more than 5 seconds, sometimes 10 - 15 seconds. Occasionally the spinning wheel never stops until I kill the app. On few occasions the app crashed on exit. I can send you crash logs, if ti helps.

Hope the upcoming release addresses these issues.


(Korban Hadley) #9

Yes I love that feature on my iPad. However there is not a pull down refresh feature on the android.


(Mike Northrup) #10

I’ve been having the same issues as geko. I’ve had to kill the app almost daily over the past month. I hope the update fixes this issue.


#11

Agreed. This is a major headache. I am experiencing it too. The app needs to be more responsive to status changes.

@Tyler, when should we expect this “big rewrite?”


(Geko) #12

He’s already said “a few weeks after that”. What a few weeks mean? I’d guess “a couple of months” :smile:


(Jody) #13

This issue is now happening multiple times a day.

I open the app and my devices that are supposed to report a value all show dashes. My devices like motion detectors and lights are stuck on whatever the last value posted before the app stopped responding. The only fix is to force close the ST app, sign out, sign in. There is nearly a minute long refresh once I am back in the app. Once back in the app things appear to be working again. I have done this at least 4 times today.

@tyler Is ST doing any sort of throttling that would cause the mobile app to lose connection with your servers? The most recent update seems to have added a significant delay to loading the app. Every time I return to the main screen I have to wait anywhere from 30 seconds to a minute for the wheel to stop spinning.


(Jon Allsebrook) #14

Struggling here too on Android. Long load times, app thinking I have 44 new devices on load (that blue icon next to the plus on the dashboard). Have most recent updates.


(Natejgreene) #15

Having the same issue on the dashboard.

Lights, Motion and Smart Home Monitor are are showing the incorrect status. And it is not consistent. 1 load it will be fine and the next load it will be incorrect. Seems like some type of caching issue?

Interestingly… clicking in on the dashboard is also showing motion on all of my sensors. There has been no motion. If I go under the “Recently” tab it confirms no motion. The Things themselves also confirm no motion.

Running Android 2.0.0.202611 with a v1 hub.

Edit: Sorry for resurrecting an old thread… Saw it was Feb, And I guess I am still not used to 2016. :stuck_out_tongue_winking_eye:


#16

I was going to start a new thread but saw this one. It’s been a year and this is still an issue. I don’t remember the dashboard acting up like this on the previous android version.


(Claire Mullaney) #17

I also just started having the same problem with the Dashboard on my android phone. The information under Door & Locks is showing a door unlocked when it is in fact locked, and also showing lights On when they are Off. If I go to MyHome (Things) and check the status of the locks and lights the data displayed is correct (doors are showed as Locked and the lights are Off). I am used to looking the Dashboard for a quick update on the status of things so this is frustrating. I have, closed the app and reopened it and also logged out but this does not fix the problem.


(Rick Blalock) #18

I am also having the exact same issue. You’re not alone. I will send an email to support.


(Xinconanconan) #19

Just switched from iphone to android and found this issue on the android app. Amazingly found this thread already opened from 2015 and still not fixed.