Six modules were listed as unavailble but still functioned on schedule

I have 20 SmartThings devices, first ones are about 9 month old. I have 35 years of experience with home control in my house, mostly X-10.

I had an unusual problem occur which I eventually “FIXED” with the tedious software commands to remove devices and reinstall. I hope someone has seen such a problem and can tell me what went wrong and perhaps how to prevent a recurrence.

To save listing all my devices in this message and confusing people I converted my device spreadsheet to a JPG which I placed on my website:

Key column to examine is Status. The abbreviation, “Fixd” is on the six modules that had a problem.

On or slightly before November 12, after months of being reliable and stable the Android SmartThings Phone Interface claimed 6 of my 20 devices were “Unavailable” and they had a Red Dot next to their name. This is on the, “My Home” screen where each device has an on/off toggle button, which didn’t work. But wait! On the, “Automation” screen where you have separate On and Off routines they worked fine. There’s more. All the programed events worked fine, which is why I did not know about the problems for a few days. This can’t be hardware! Six unrelated devices partially failed at once.

I waited awhile, expecting they may fix themselves like the infamous Time Zone crash awhile back. My events kept working normally. I looked at the Community Website expecting to find notices of similar problems, but no one was complaining of the same problem. In the past people have complained that the typical “fix” is remove and re-install the devices. People don’t like that answer since all the screen taps can take quite a while.

You can see from the list the six devices are unrelated: Zigbee, Z_WAVE, Modules, Wall Switches, Magnetic switches (which I use for contact closure), Samsung, GE, Leviton, Echolink. Other identical devices were unaffected.

Finally I bit the bullet and started with my living room light since if I needed to power the module off it was easy to unplug, unlike a wall switch. My choice of the first repair was poor, I forgot the Living Room Dimmer has three interactive routines: On, Off, Dim and “On” is actually dim to 100%, It took 30 minutes to uninstall it from the APP and enter it back in. At that point it was no longer UNAVAILABLE, RED DOT was gone, Toggle button worked, but now the routines didn’t. I edited the routines to add the device back in. Next module, the Weed Whacker Charger, was only 15 minutes. I did 2 devices a day in case the changes caused a problem (they didn’t) and left me with 6 devices INOP. Last and hardest were the Echolinks, I had difficulty with the Exclusion process that requires you open the case, remove the battery, install the battery, replace the case TWICE. Now all of them are working.

Final problem was Alexa could not turn the Fixd devices off or on. That fixed itself after two days!

One report in this category for devices being unavailable (completely, not like mine) mentioned turning off Device Health. Could that cause my symptoms? Should I do that?

Though everything is working any advice for the future would be appreciated.

Leo Taylor

P.S. Special thanks to the wonderful person I read on this forum who said under the cover of an Echolink there is a input terminal strip. The HCS I co-designed in 1984 has 16 inputs and 8 outputs right on the controller! The rain detector I use (simple contact closure and good for below zero F) was connected to my old HCS without any interface module needed.

You, like many of us with SmartThings, are a victim of ongoing instability with ST; especially since the release of hub firmware 24.11 and 24.20.

More than likely you’ve done nothing wrong. Welcome to the club…

Sorry for being sarcastic, but my patience is running quite thin with ST right now.

Hi John,

I understand your frustration since I’ve seen several updates go astray.
I’m not that concerned in part because my wife died in 2009 and I’m the only one affected when I arrive home at night and the house is dark!
BTW: When I met my wife in 1991 her condo had two X-10 controlled lights with a Radio Shack controller. I knew she wouldn’t be startled in my house when lights go on and off by themselves!

1 Like

my experience with DeviceHealth seems to indicate that is has no effect on actual operation of that device. The dot seems to indicate if there was no activity, status or battery update in the preceding 1-2 hours. I did turn it off after many months of looking at the dots. You can get similar yet more detailed information from smart-app “Simple Device Viewer” .

Now upon searching for the meaning, the smartthings page indicates “Device Health is not supported by Hub v1.” which is what I use. Yet the dots appeared as little as 3-4 months ago in my last test. Maybe the experience is different for hub v2 or higher .

Wow - a woman that uses X10, what would that be like? Cue the dream sequence - oh no her control scheme collides with mine 50% of the time! Obviously her schedule must prevail…

Hi Eric,

I married a techie in 1992. I was actually concerned having lights in my house go on , off, and dim mysteriously since that once spooked guests! My wife was used to that kind of thing.

When I found she owned more computers than I, I knew I should marry her. We were very happy together. She died in 2009 (I’m now 70). I’m sitting at one of the twin computer desks we bought together, our cat occasionally sits in her chair.

SmartThings are still working fine. I received another incident report today but i don’t use 3rd party software.