Sinope Zigbee Thermostat (Edge Driver): Outside Temperature?

Same model.

@jamer007: Does the Display feels like works for Canadian Weather (Environnement Canada)? Even if I check it, the temperature is always the same (actually it’s 2°C, but feels like -2°C based on Accuweather).

Also, I don’t know if you mentioned it somewhere, but the parameter to the API is the Latitude,Longitude of the city.

Regards.

Dear @jamer007 and everyone,

Any new developments on this? Have many people been able to get this driver working? After updating the firmware of my TH1300ZB, I began receiving power meter information from the @jamer007 driver! However, I still cannot receive data from AccuWeather. I know that my Edge Bridge server is working because I’m using it for other things in SmartThings. But I haven’t seen any attempts from this driver to reach the Edge Bridge.

I was also in the same situation. Driver was fine, but still could not get the temp or the time. So I gave up, and just bought the $90 Sinope Neviweb gateway device. Sucks to have yet another hub in the house, but once i paired the zigbee thermostat to the gateway, it worked as designed.

The only problem I know have, is that I can link the Neviweb gateway a a “linked service” successfully in Smartthings, but the it says “no devices”. So I can’t control teh thermostat via any Smartthings automations or routines. Oh well.

I have too many devices connected and operating in SmartThings that interact with my thermostats to accept bringing them to the neviweb gateway device. Clearly, this is not an option for me. I have faith in @jamer007 :sweat_smile:

1 Like

Hi, unfortunately no the feel likes is not provided by Environnement Canada, so even if you select feels like it will not find any data and fallback to the real temperature.

Hi @jsdecarie, sorry for my late answer,
for the accuWeather source type, because i haven’t an accuWeather paid account i kind of found a workaround, I’ve recreated an API that is able to fetch the weather from accu weather website and serve it like the real accu weather API, it is working on my side, but seeing your comment my clone API is maybe not replicating well the real api. Do you have a paid AccuWeather account? you can reach me by PM, we could maybe work together to fix this issue :slight_smile:

I faced the same issue, with the zigbee gateway from sinope i am not able to get the device in smartthings :confused:

On my side it was working fine with the first version of the driver (Before C and F and accuweather changes). Now I cannot get the outside temperature working on my TH1300ZB. (Using Canadian Weather API(Jamer007)

Tried using logcat, not a lot of info showing.

Any way to get access to the old driver. @jamer007

I do not have a paid subscription, but I’m pretty sure it is not required to get current weather information from AccuWeather.

But it will be my pleasure to help you if it can helpful !

Looks like there was update from ST. I can now save settings. Still don’t have the outside temperature available which I loved.

Side note, I purchased some MYSA floor thermostats and the integration is great! I have not really played around with them yet. Wished they looked a tad bit better but everything is done via the app.

@jsdecarie how did you update the firmware?

When I set the Secondary Display to “Display set temperature”, it shows the outside temp, and vice versa.

No errors in logcat.

2024-05-06T01:26:52.733945238Z INFO Zigbee Thermostat Jamer007 <ZigbeeDevice: 94a6899d-48b0-4c7b-b593-f0e58235f39e [0xFD7C] (Ensuite Thermostat)> received lifecycle event: infoChanged
2024-05-06T01:26:52.738382664Z TRACE Zigbee Thermostat Jamer007 Found DeviceLifecycleDispatcher handler in zigbee-thermostat → Sinope Thermostat Handler
2024-05-06T01:26:52.745377076Z INFO Zigbee Thermostat Jamer007 <ZigbeeDevice: 94a6899d-48b0-4c7b-b593-f0e58235f39e [0xFD7C] (Ensuite Thermostat)> sending Zigbee message: < ZigbeeMessageTx || Uint16: 0x0000, < AddressHeader || src_addr: 0x0000, src_endpoint: 0x01, dest_addr: 0xFD7C, dest_endpoint: 0x01, profile: 0x0104, cluster: 0xFF01 >, < ZCLMessageBody || < ZCLHeader || frame_ctrl: 0x00, seqno: 0x00, ZCLCommandId: 0x02 >, < WriteAttribute || < AttributeRecord || attr_id: 0x0114, DataType: Enum8, data: 0x01 > > > >
2024-05-06T01:26:52.753227207Z DEBUG Zigbee Thermostat Jamer007 Ensuite Thermostat device thread event handled
2024-05-06T01:26:52.807112011Z TRACE Zigbee Thermostat Jamer007 Received event with handler zigbee
2024-05-06T01:26:52.812354298Z INFO Zigbee Thermostat Jamer007 <ZigbeeDevice: 94a6899d-48b0-4c7b-b593-f0e58235f39e [0xFD7C] (Ensuite Thermostat)> received Zigbee message: < ZigbeeMessageRx || type: 0x00, < AddressHeader || src_addr: 0xFD7C, src_endpoint: 0x01, dest_addr: 0x0000, dest_endpoint: 0x01, profile: 0x0104, cluster: 0xFF01 >, lqi: 0xFF, rssi: -51, body_length: 0x0004, < ZCLMessageBody || < ZCLHeader || frame_ctrl: 0x18, seqno: 0x49, ZCLCommandId: 0x04 >, < WriteAttributeReponse || ZclStatus: SUCCESS > > >

Anybody else experiencing this?

My father has a Sinope base. It allowed me to update the firmware of my thermostats. It is done automatically when they are connected to the terminal… but it seems to be done randomly by Sinope. In some cases, it took at least 1 week to get the latest firmware version. What a waste of time. It’s a poor way for Sinope to handle it.

1 Like

Hi! You said that you had to select “Display set temperature” to get the outside temp showing on the thermostat. Was it for your Sinope TH1300ZB ?

Yes, for my Sinope TH1300ZB.