Sinope Zigbee Thermostat (Edge Driver): Outside Temperature?

It worked, I changed each settings, and a fake value for proxy. Settings saved! I can see in the app the correct outside temperature. I cannot confirm yet that it is display on the thermostat since I am not at home, will confirm later.

Hi Ooga, it is definitely planned :slightly_smiling_face:

Hi, great work!
I got the canadian_weather_rest up and running and I can see the weather in C and F from a Internet Browser on my local network.
But I still do not see the weather on the Smarthing app nor on the Thermostat.
I have the TH1123ZB.
Can you help see what I am missing with my settings?

Hi,
In the settings, try to change the Secondary Display, refresh rate and periodic refresh values.
It is like the default settings are not really take in consideration until “playing” with them.

1 Like

Update: All of a sudden this morning, the outdoor temperature now appears on 1 of my Thermostat with your new driver pointing to the Canadian Weather running locally.

Thw weird thing is that I have the exact same settings on my 2nd Thermostat with your driver but that one still does not show the Outdoor temperature. :sweat:

I tried changing most of the settings, but none of them stuck. Still no weather and no clock.

Update: Now both of my Thermostat work! I’m still not sure what exactly make them work. The 1st one started to work this morning and the 2nd one worked 1 hour ago.

I did what you suggested and changed back and forth each settings several time yesterday and continued changing them this morning. I also power off each thermostat for 30 seconds before powering them back on.

Thank you for creating the driver and setting up the Canadian Weather Python up. It brought back to life the great function on my Sinope Thermostats.

Hello,
Your driver installs easily. I hope this questions makes sense, as I have almost no experience with Smartthings new interface. Do I have to run your Github script on my local network or can I put it on my smartthings hub…?

Hi, the driver need to fetch weather data from somewhere in your local network.
You have 2 solutions,

  • running my canadian_weather_rest docker container somewhere in a computer.
  • running the edge bridge script/docker from TAustin somewhere in a computer.
    Right now using edge bridge allow you to get US weather for free or Accuweather if you have an account. Using my canadian_weather_rest allow you to get Canadian weather for free.

Thanks for the driver, as everybody here I really hope to get back the outside temp on my Sinope tstats.

I already have a edge bridge running in order to have a virtual outside temp sensor on my Smartthings system. It gets the data from OpenWeather API and even if I am located in Canada I do get the correct OAT based on my lat/long coordinates. Would it be possible to rely on it and pass it to the Sinope tstat ?

From what I see the other option to rely on a docker container can not be easily ran on a Windows computer, in contrary to the edge bridge script.

Thanks

Update: I finally managed to get outside temp in the app thermostat’s device page. I created a Accuweather API key and managed to get Canadian weather from it. I confirm that it is displayed on the t-stats ! 3xTH1124ZB and 1 TH1123ZB. The only think I don’t understand is that I lost the clock on the TH1123ZB months ago and it never came back, even with a reset + re-add to platform. I hope it would came back with the outside temp but no.

Anyway, many thanks to you jamer007 !

Personally, I’ve been able to get the time back by removing the thermostat front panel et resettling it with the little screw underneath…

You mean by resetting the A/C power to the thermostat, right? That did the opposite for me.

I had the time displayed until I reset the A/C power by removing the thermostat from its backplate. I reset mine because it hadn’t adjusted for the end of daylight savings time.

TH1123 or TH1124 ? My 3 TH1124 shows the clock (even before adding the outside temp it was shown)
The TH1123 lost the clock with the Edge driver and it never came back. Also there no reset on my model…

Update: finally I have two TH1123 and two TH1124. The 1123 without the clock is an old revision model from 2017 (notable fact, under the outside temp there is no “Out” indicator) and the other one (with the clock) is from 2019. Seems like maybe a firmware issue.

Dear @SneakX2018

just to confirm, the accuweather settings is the “currentconditions” api option ?

I mean, removing the front of the thermostat from its backplate, fixe the time for me. I was stuck in daylight time…

1 Like

Looks like http://dataservice.accuweather.com/currentconditions/v1/xxxxxx?apikey=xxxxxxxxxxx
So yes your url seems right but replace https with http

same for me, removing it from back plate (reset power) and now there is no time at all.

1 Like

I was finally able to make the settings stick. Turns out I had not changed any of the Ambient Limit, Floor Low Limit, or Floor High Limit from their defaults. Once I did, all of my settings changes began to be saved.

Still no luck though getting the outdoor temperature to display on the app or on the device.

I’m experiencing the same issue. Although the settings are saved, I can’t retrieve temperature or power usage data on the app and display. Any thoughts on what might be causing this?

I’m already using edge bridge for weather information in SmartThings, and it’s functioning correctly. Thus, I’m fairly certain this isn’t the source of the problem.

I’m using a TH1300ZB floor heating thermostat. How about you?