SmartThings Community

SimpliSafe Alarm Integration (cloud to cloud)

dth_security
dth_alerts
project_security

(Laurie B) #692

Hello, I’m somewhat new to SmartThings and to SimpliSafe. I have SS2, and ST v2 hub. Thank you so much to those who have built the device handler for SS integration in ST! I installed the latest version, and it’s working well.

I want to also use the SS Monitor Device handler, but have been unable to get this to work. I can install and publish the DH, as well as create a new device of the SimpliSafe Monitor device type. I can see this new device in the api. However, it will not load in the SmartThings app for me.

SmartThings app finds the new device (SimpliSafe Monitor) but it just hangs and hangs when I click save. I have to quit the ST app and restart. The new device is called “Tiles Missing” and is not usable. I cannot delete it in the app, as I receive an error message “Error fetching device. Please try again.” I CAN delete the device via the api. However, numerous attempt to try to create this device (with or without the same network I’d) have failed with the same result I just outlined. I do have the ST SHM configured (didn’t at first, so thought that was the issue) but it still does not work, even when I remove and create a new device of the SS Monitor type.

I’ve searched, but haven’t found anything that has given me the assistance I need to resolve this issue. I am sure it must be some sort of configuration issue on my side, but I just don’t know what needs to be done.

Hoping someone here will be able to help me figure this one out.

Thank you all!


(Alex) #693

create a new device by clicking “my devices” then click +new device,

this is required for all devices

Name * ANY
Label * ANY DISPLAYED NAME
Device Network Id * MUST BE UNIQUE TO ALL SMARTTHINGS/ANY NETWORK
Type * SCROLL DOWN AND FIND THE DEVICE HANDLER “SIMPLISAFE” (youve installed this preeviously"
Version PUBLISHED
Location * SELECT YOUR LOCATION
Hub
SELECT HUB

then click save and click publish -> for me

click on edit next to preferences

put in your ss#/username/password

click update, then click live logging (leave it open) and get your phone

force close app on phone, load smartthings, add new device, your device should pop up. if it errors still, save the logs, edit out the personal info and well see whats going on


(Laurie B) #694

Hi Alex. Thank you for your response. My SimpliSafe device created with the SimpliSafe device type is working as expected. It’s the SimpliSafe monitor device type device that refuses to load in the ST app. I created exactly the same way as I would create any other device with a new device handler, being sure to choose the SimpliSafe Monitor device type. Thanks.


(Laurie B) #695

In the logs, this is the error message for device Simply Safe Monitoring, which is the name of the device I created with the SimpliSafe Monitor device type. This error occurs when I try to add this device to the ST app:

9:19:16 PM: error java.lang.NullPointerException: Cannot get property ‘id’ on null object @line 52 (updated)


(Alex) #696

the monitoris a smartapp. not a device handler, it syncs with smart home monitor, delete it from device handlers and install it from the smartapps section, i dont use it but it worked well. enjoy


(Laurie B) #697

Oh my goodness…how silly of me. Thank you so much. I deleted it as a DH and set it up as a smart app. It pulled into ST app with no problem after that. Thanks much, Alex. Appreciate the help!


(Epauldc29) #698

Hey all - loved this integration until like everyone else reported it stopped working a few weeks ago. I haven’t had time to drill back over all the message - how do I get it to work again?

  • Do I patch what I have already have in graph?
  • Or do I start with new code all over?

Thanks,

E


(Scott Silence) #699

Your best bet would be to delete the old Device Handler and Smartapp. You can then either add the repo from tobycth3 (https://github.com/tobycth3/SimpliSafe) for each item or you can manually create a new Device Handler and Smartapp. The code for each is below:

Device Handler: https://github.com/tobycth3/SimpliSafe/blob/master/devicetypes/tobycth3/simplisafe.src/simplisafe.groovy
SmartApp: https://github.com/tobycth3/SimpliSafe/blob/master/smartapps/tobycth3/simplisafe-monitor.src/simplisafe-monitor.groovy

After you add the Device Handler and publish it. Goto “My Devices” and add a new SimpliSafe device from that handler. Once created you will have to edit the device, and under preferences enter your Username, Password, and the type of system (ss2 or ss3).

That should get you back up and going.


(mike ricchino) #700

I noticed that my alarm did not set last night with the new code. Has anyone else had issues with this code?


(Scott Silence) #701

That’s strange, mine has been working flawlessly. I even tested it last night using the SHM portion and it all worked as it should.


(Epauldc29) #702

Ok, I must be missing something in your directions. I have added the Device Handler:

And I added the the SmartApp

When I go to my Devices on the Graph website I’m not sure what to do and the App on my phone just does this:

I’m missing something somewhere - just not sure where??

THanks,

E


(Scott Silence) #703

In the top right corner of the devices section of the API graph website should be an Add Device button. Click that and select the Simplisafe device. After adding it, edit the preferences and fill in the three fields.


(Epauldc29) #704

So I seem to need a Device ID:


(Scott Silence) #705

The device ID is not necessary for this implementation, so you can put any number there (I have the number zero for mine)


#706

Greetings,

A quick question. I would like to build a piston based on the SimpliSafe device and have it change the setting of a virtual switch back on “off” or “away”. I tried using the app to change the switch states and the results weren’t consistent.

Would I just select the Simplisafe device and “status” and then us a “if change to” for the piston?

Thank you.


(Olivier Cuny) #707

Is the new code working with Simplisafe 3?


(Scott Silence) #708

Yes it is. After adding the code for the device handler, go and add a device based on that handler. After that, edit the device and in the preferences section add your email/username, password, and the system type (for you this is ss3).


(Scott Silence) #709

I am actually working on this very thing right now. What I am doing is monitoring the Smart Home Monitor status. I am actually doing it very similar to this:


#710

I was trying to remove SHM for simplicity sake. So, I had:

When SimpliSafe Status changes to away
Virtual switch off
When SimpliSafe Status changes to off
Virtual switch turns on

The problem is the up to 5 minute delay due to the polling. When I do the same but use the SHM instead of the SimpliSafe status, it responds faster (almost instantly with a presence change and less than 2 minutes using the keypad). So I ended up changing the SImpliSafe to SHM:

When SHM Status changes to armed/away
Virtual switch off
When SHM Status changes to disarmed
Virtual switch turns on


(Scott Silence) #711

That’s really strange. I have been using SHM in WebCore since yesterday, and it vary’s greatly in refresh time (sometimes 30 seconds, sometimes 7 minutes). There really should be no difference between monitoring the Simplisafe Status and the SHM status in terms of update time. The 5 minutes can be decreased if you want, but it puts more load on Simplisafe and we are trying to avoid them detecting we are using the API (not sure if they can).

But, I am using it much like you are. If the system is Armed (Away or Stay), my outdoor cameras become active. If it is Disarmed then the cameras are inactive.