SmartThings Community

SimpliSafe Alarm Integration (cloud to cloud)

dth_security
dth_alerts
project_security

(Marc) #416

Yes, use a CORE piston to
Refresh.


(Rick S) #417

Thanks, I tried that before and never could see any difference. Will give it another go.

Seems like adding a controllable refresh option within the app would be a better option…

Thanks, Rick


(Marc) #418

You want to make sure you are using the “Poll” command, not “Refresh”. Mine works perfect. It runs every minute.

IF
● Trigger happens every minute
THEN…
Using Simplisafe Alarm…
► Poll


(Tim) #419

@tobycth3

Ok this is the first custom DTH and Smart App I am trying. I see early in the post that there was a way to specify the location ID from the simplysafe URL. I have multiple locations on my SS account and it is pulling the first one in the list, I cannot find where to enter that location ID anywhere in the smart app or device preferences?


(Tim) #420

@Mbhforum
What are the steps to setup Core to Poll for status?


(Marc) #421

I recommend you search the forums or post here:


(Olivier Cuny) #422

Is the SmartApp code on top of thread the latest? It shows dated 3/5/16, but it looks like last update was supposed to be 5/10/16? If it’s not the latest, where can I get the latest version? Thank you!


(Rick S) #423

Oliver,

The DTH is dated 5/10

  • Modifications by Toby Harris - 5/10/2016

I use Foxxyben’s SmartApp which is dated 12/31/2016

  • SimpliSafe Alarm State revision 8
  • 12-31-2016

Rick


(Olivier Cuny) #424

@Toy4Rick Thank you, that helped out a lot!!! :slight_smile:


(Rick S) #425

@tobycth3, @foxxyben
I am using WebCoRE to either Poll or Refresh tried both… with very little luck. Daily I go into the ST app, open the SimpliSafe device and usually find it on Home mode from the previous night, select refresh and it changes.

I do see the Poll/Refresh in the recent tab but the status just isn’t updating

Edit: When I select Temp in the ST app, the base unit says settings have been synchronized, and when I select Base, nothing happens

Are these expected behaviors?
Thoughts?
Rick


(Marc) #426

@ady624 mentioned that Smartthings now supports asynchronous HTTP calls and this would help stabilize constant refreshes.


(Toby Cth3) #427

By popular demand, GITHUB and auto-refresh!!! The latest update includes scheduler improvements to automatically refresh the alarm status every 5 minutes, eliminating the need for pollster. Further improvements are in the works, including a total rewrite using the new SimpliSafe API.

Owner: tobycth3
Name: SimpliSafe
Branch: master


(Albert D) #428

My Steps to get this working for others to refer to if helpful:

  1. Login to Smarthings API: https://graph.api.smartthings.com
  2. Go to My Device handlers
  3. choose Settings
  4. Under GitHub Repositories hit “Add New Repository”
  5. enter:
    . Owner: tobycth3
    . Name: SimpliSafe
    . Branch: master
  6. hit the “Save” button.
  7. Select “update from repo”
  8. Select “SimpliSafe (master)”
  9. Check box for the code under the “new” column, check publish hit “execute update”.
  10. Now shows under my “Device Handlers” screen as published.
  11. Go to “My Devices” and select: “new device”
  12. Enter:
    . Name: SimpliSafe Alarm (Note: can be anything other than “simplisafe”
    . Zigbee ID: from the “My hubs” tab in the Smarthings API website.
    . Device Network ID: The LOCATIONID in my simplisafe URL: https://simplisafe.com/account2//sid//control-panel
    . Type: Selected SimpliSafe from dropdown (near very bottom)
    . Version: Published
    . Location: select my location (only option)
    . Hub: Selected my hubs name (only option)
    . Group: blank
  13. Select the Create button
  14. On the SimpliSafe Alarm Device screen, select the “edit” link next to “preferences”
  15. Entered my Simplisafe Username and Password. Then Saved.
  16. Select “My SmartApps” tab at the top of the page.
  17. Choose Settings
  18. Under GitHub Repositories hit “Add New Repository”
  19. Enter:
    . Owner: tobycth3
    . Name: SimpliSafe
    . Branch: master
  20. Hit the “Save” button.
  21. Select “update from repo”
  22. Select “SimpliSafe (master)”
  23. Check box for the code under the “new” column, check publish hit “execute update”.
  24. Opened the Smarthings app on my phone (android), selected “My Home” then “Things” and found the “Simplisafe Alarm” item. Confirmed it opened OK (didn’t prompt for credentials since i entered previously)
  25. Went to the “Marketplace” section and chose SmartApps > My Apps > SimpliSafe Monitor >
    . Select Alarm System: tapped and chose “SimpliSafe Alarm”
    . Other Settings: review as needed. i only setup Push notifications for now. Select “Done” when complete.
  26. Should be complete. Went and set my alarm to “Home” and opened the SimpliSafe Alarm under the Things menu, and hit the “Temp” button to force refresh. It picked up my alarm was in “Home” mode.
  27. From the Smartthings > SimpliSafe Alarm “thing” set the Alarm state to “off” and confirmed it updated.

Hope this helps - it helped me just keep track of exactly what i was doing as i was reading the various posts.

Not exactly sure what I’m going to do with it, now that its connected, but at least i got the hard part done. lol


(Marc) #429

Thanks! I updated to your GitHub repo and made sure they are sync’d in my IDE. It doesn’t seem to be auto updating. There’s nothing in the IDE logs that even show anything happening. Any ideas?


(Toby Cth3) #430

Try going in to edit your savings and press save (you don’t need to make any changes). That should kick off the schedule to sync every 5 minutes or so


(Marc) #431

Thanks. Seems to be working now although I could have sworn I tired that earlier. Nice job!


(Rick S) #432

@foxxyben

Hey Ben,

Can you confirm, does your SmartApp refresh every so often? If not can you add that feature?

Thanks in advance
Rick


(Ben) #433

The latest device handler already has polling every 5 minutes built in. Because of this I have no plans to add this to my smart app as it would introduce unnecessary redundancy.

It you are experiencing issues with the latest device handler, I would either use core/web core or contact smartthings support about the scheduler.


(Kosta) #434

Just throwing in my two cents as far as installation went in case anyone else runs into this. I got everything setup and it would just not refresh or pull the current status of the system. After some trial and error I realized that although on the SimpliSafe website it asks for a full e-mail address as the user name, you don’t need to enter the whole thing, at least for my account. And as far as the SmartApp, it won’t work if you enter your entire e-mail address as the user name. So instead of "johndoe@myemail.com" just use “johndoe” as the user name it everything works great. You can even login to the SimpliSafe website that way which is kinda weird. I would imagine there are plenty of "johndoe@yahoo.com" and "johndoe@aol.com" etc. I’m guessing that when it comes to e-mail addresses like that it must use the entire email address for the login… but it doesn’t for mine. Kinda strange.


(Rick S) #435

Thanks Ben, wasn’t aware it was built into the DTH, this is good news

:slight_smile:
Rick