Simple Control (Roomie Remote) ... Great App Goes Bad. [Help Please?!]


#1

Simple Control/Simple Hub/Simple Sync is a brilliant, award-winning work of genius, which “has a library of over 250,000 codes that control thousands of AV and smart home devices,” including controlling/executing scripts on networked computers and control of IR/RF devices.

Connectivity issues have begun affecting the ability to create new Simple-Sync-Trigger apps. Instead of populating with a list of ST devices and available Simple Hub commands as it should and did, it now opens to a completely blank screen. Anyone who’s incorporated Simple Control into their workflow can understand how devastating the loss of that tremendous functionality would be. Reinstalling, reconfiguring and resetting on all ends has no affect. SmartThings support says the issue is likely old code (September, 2015) causing the issue. Simple Control support concurs (each of their comments are copied below). I created a repository with the three groovy scripts (a DTH and two SmartApps) to see if anyone might be able to take a look and either suggest what to advise Simple that needs addressing, or perhaps have an idea to figure out a workaround. Simple-Sync-Trigger is the SmartApp where the issue occurs. Many thanks!

SmartThings Support Comments:
Something may have changed on our end concerning SmartApps and code. This is something all developers have to be concerned with; official or non-official.
The screenshot from this email vs your previous one seems like it is unable to grab all the devices. If it is fairly “static” in what it can do, it shouldn’t need to poll what devices you have and then make a list. It honestly sounds like old code to me that needs to be updated.


Simple Control Support Comments:
I am seeing this same behavior as well so it is safe to say the issue is not on the user side. Existing SmartApps using the SimpleSync app seem to be working just fine which is why we’re receiving so little support traffic on this, but trying to configure a new SmartApp for the unpublished SimpleSync app fails at the blank screen indicated by Jerry. Meanwhile, the published Simple Control app that performs the reverse integration from our app to SmartThings seems to be working fine thankfully. So this affects only the unpublished app that routes from SmartThings to our Hub. However, users individually publish this app to their own accounts which makes mandatory changes to that app a global ordeal for everybody.

We haven’t received any notifications of any needed changes and we have no further information on what might cause this so we will try to follow up with a SmartThings contact to find out.

As this issue apparently requires some kind of change on our side, we won’t have much to add here until we develop support for whatever the changes on the SmartThings side were. We obviously have no ETA on that yet, but we have many SmartThings users so it’s safe to say this will generally be a priority.

If you do experience this as well from a user perspective, please email Simple Control. The more of the community that alert them to this, hopefully the more of a priority it will actually become.


Integration not working with Simple Control's Simple Sync App
#2

I’ve moved this to the developer section of the forum, since I think that will get you the help you’re looking for the quickest. (The “SmartApps” section is for discussion of the officially published smartapps.)

Since simple control (formerly roomie remote) is a subscription service and advertises their compatibility with SmartThings, I would expect them to have people from their staff working on this issue, not just leave it up to a customer, though. The note from their support does seem to indicate that they are assigning engineering resources to The problem.

I’m not familiar with the details of their offerings. Does “unpublished” mean it’s in beta status? Or is this a community – created smartapp, different from their official offerings? (edited to update: OK, that’s using the SmartThings terminology of “unpublished” to mean custom code.)

I can’t read the code (I rely on text to speech and groovy is really difficult), but hopefully some of the community developers here will know if something changed recently.

Since you mentioned 2015, there was a major change in how authorization worked in late 2015 which could result in the kind of blank screen error you are seeing, but in that case the problem would’ve been there for a long time, and it would just be that you hadn’t run into it until now because you hadn’t tried to create something new.

I’m tagging @tgauchat just in case he has anything to add. He’s very familiar with the authorization process from a custom code standpoint.


#3

Hi JD

By unpublished, he’s referring to the typical ST installation procedure of each new instance of the SmartApp per each device/command pairing. (i.e., user makes a new Simple Control command to execute an AppleScript on their Mac and then created a ST virtual switch to trigger it. You’d then go to add a new SmarttApp, select the Simple Trigger app and then connect the switch to the activity and define its parameters. This results in a list of all such instances among your installed SmartApps.

Realize, he’s speaking from the perspective of a non-SmartThings user, so it’s likely a matter of using layman’ terminology. The issue seems to have coincided with the latest ST Hub firmware update on Monday. I don’t know if it’s related.

It’s a coincidence you recommend @tgauchat – he helped me tremendously with another question I had just yesterday and was great. That very same project however is now forced to the back burner since it extensively makes use of Simple Sync. If he would be so kind as to shed some light on this issue I would be thrilled and eternally grateful.

Thanks so much for your help JD. Great initials :wink:


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

There have been a non-trivial number of changes on the platform since September 2015 (when Hub V2 was released!), and even a small change could break a SmartApp; while many changes are benign.

Who is the developer of the SmartApp & DTH?
Just glancing at the code is unlikely to reveal the answer. This requires someone familiar with SmartThings and Simple Control to debug it as if they were writing it from scratch. Narrow down the problem to a specific section of the code (i.e., certain API calls or perhaps a specific part of functionality such as “authentication”), and then general SmartThings Community Devs or SmartThings engineers around here can chime in…


#5

Fantastic news! The Support guy at Simple Control emailed me to add one line of code to the device type, “command “getAllActivities”” and like a miracle it started working again. I’m so relieved and happy. Thank you both for your support. Now I can get back to work on that project you helped me out with yesterday. Thank you so much again @tgauchat and @JDRoberts


(Daniel Siegel) #6

I am having trouble getting Simple Control to “pair” with SmartThings so that I can control SmartThings devices from my Simple Control app (I posted this info below in reply to another Simple Control question, but am hoping somebody may have some ideas as to the source of this problem).

I am new to SmartThings. Just set up the Hub and a few Leviton Decora light switches (a Switch and a Dimmer), which I am using for testing. They work fine. I am considering using SmartThings to control light switches (and create scenes invoked by pressing the light switches). So far, this appears as if it will work (may need to create a few Smart Apps for additional flexibility).

But, I use Simple Control for most of my home automation, and would like to integrate with SmartThings so that I can control the SmartThings light switches from Simple Control. But I am having difficulty getting them to “pair”. I upgraded to Version 5 (of the Simple Hub software on a Mac) and Version 5 of a Simple Control iOS client app. When I try to add the SmartThings hub (as a Cloud Service) from the Simple Control iOS app, it is clearly communicating with SmartThings, and presents me with an authentication screen. When I enter my credentials, it provides me with an Authorization screen, which lets me select the name of my “home” and which SmartThings devices I want to control from Simple Control. When I select Authorize, it appears to work.

But, it then presents an Add Device screen with a “Pair” button (as well as a Manifest and Advanced button). When I select the Pair button, nothing happens. So, I am forced to exit from the Add Device screen with no device added. I did notice that this causes the SmartThings App to show Simple Control as a SmartApp, and then to show SimpleSync as a device. But, they dont seem to do anything either.

Has anyone else experienced this problem? Simple Control tried to troubleshoot it, but said that once I get to the Add Device screen (where I try to select the Pair button), there is no further communication from SmartThings. They told me it should work, and that no other users have reported this specific problem. They thought it could be a firewall issue, but it seems clear that SmartThings is communicating with Simple Control (since it shows me the name of my “home” and devices). And I cant get tech support at SmartThings to help. They just say they dont support Simple Control, and said to try the Community.

Any ideas?


#7

Can you provide any information on where the line of code goes in the groovy file to fix this issue?