SmartThings Community

SHM video clips no longer play

(Paul Ockenden) #1

I have a custom rule in SHM which records from a Samsung HD camera whenever a SmartThings motion sensor sees movement.

It worked great for a long time.

Recently though, the clips won’t play. I can’t access them in either the Android or the iOS app.

It goes through all the right steps (generating clip, etc.), but it won’t play.

The camera is working fine - I can connect to it ‘live’ and see the image. It also works using the SmartCam app.

The only thing that’s changed recently in my SmartThings setup is I’ve added the Arlo integration (although I’m not currently using it).

Anyone got any ideas? It’s probably just me being stupid.

Can't play videos in SHM
Arlo iOS app does not show SmartThings-generated clips
Professional office set up

Other people have been reporting video clip issues since the last set of updates, but since I don’t have those, I didn’t really understand the details. I would definitely report it to support.


(Joe) #3

I emailed support over 2 weeks ago (immediately after the update and saw it was broke). Got an immediate response for screenshots ect. Sent them and haven’t hear anything since. You can download the clip. On andriod not sure about IOS. But you can’t play it. And support seems to not know or doesn’t want to deal with it!


Tagging @Aaron

(Aaron S) #5

We are aware. This has been flagged and added to the Developer queue. I don’t have a hard timeline at the moment because there was some backlog following last week’s instability.

Stay tuned for updates

(Joe) #6

Thank you. That would have went a long way on the support ticket I sent in. I sent 5 emails asking for updates and got nothing back. Thank you though for that I understand completely now.


Shouldn’t this appear on the status page?

(Steven Burton) #8

Any update on this issue? My smart home monitor is sort of pointless as a security device currently when away as I can neither view video clips or download them! Is this fix nearing any release…?

(Joe) #9

You have iOS?

(Steven Burton) #10

No Android. Galaxy s6. Happening on my partners s4 too.

(Joe) #11

You should be able to download them. That hasn’t been effected. It was how Google changed their web viewer service.

(Steven Burton) #12

Nope, I can’t download them either. When I attempt to it starts to download and immediately says failed. No other explanation. Hence SHM being pretty useless for me currently.

I have let support know this but they said it was a known issue… @Aaron is that true?

(Paul Ockenden) #13

I can confirm that this applies to both Android and iOS. And that you can’t download the clips.

(Joe) #14

Strange I can download . But I’m on Android 7. Could be why. I figure iOS you can’t download reason I got rid of iOS to restricted.

(Paul Ockenden) #15

Download icon is completely inactive here. Nothing happens when I press it. The delete icon works.

(Joe) #16

Must be a Android 6 and below issue with downloads. I can download all day long just not watch them in them I’m the app. One support person told me tk go into web services and disable it and it might play for 6 and below. In 7 it’s disabled and Google no longer uses it for what chrome does.

(Steven Burton) #17

That was exactly my workaround and it worked but has broken again now. But with the added break of downloads.

Support seem to have no answers other than “I will raise with engineering…”.

Was hoping someone on here like @Aaron, @twack or @slagle might be able to shed any light on this…? Because as I said above as a security system SHM is mainly pointless for me right now…

(Paul Ockenden) #18

Not just you!

(Joe) #19

I’m sure they are working on an updated app to address this.

(Steven Burton) #20

Possibly, would just be nice to hear that or some idea or a timescale. Either here or form support. It may be that they don’t know the cause for example.