SHM Custom Audio Notifications broken since firmware update


#1

I had 4 rules to play a custom message over my sonos speakers upon a specific door opening (Back Door Opened, Front Door Opened etc.) My hub was automatically updated yesterday and those rules have since stopped working. I tried editing a rule and found that the “Next” or “Save” options are missing on some of the screens in SHM when configuring these rules, thus preventing me to make edits and/or make changes.

I deleted one in an attempt to recreate it from scratch, but when I get to the very last configuration screen where you can edit the name of the rule, “Save” is missing. The only thing there is the back arrow. If you hit that, it completely deletes the rule and kicks you back to the screen that shows your current rules.

Anyone else experiencing this issue?

PS The SHM alarm functions seem to still be working. I also have the alarm configured to play over the sonos speakers and that still works.


(Jimmy) #2

The firmware update is tomorrow, so it wasn’t that.


(Alwas) #3

For me something has changed on the platform, they’ve definitely changed something. ALL my TTS is broken, All my notification pistons fire correctly, but no speech. As this is broken on both Samsung Speakers AND Google Homes i’m taking a guess it’s not me, user error. It’s been like this for 15 hours now, and Samsung Status page says nothing.


(Jimmy) #4

have both of you emailed support?


#5

I received a notice last week that my account would be migrated to the new Samsung sign in on Tuesday, not Thursday, I don’t know if that’s relevant or not.

@wb70


#6

I saw an email yesterday about the firmware upgrade and then noticed my hub went offline (which it never does) so I made an erroneous assumption that the firmware update was pushed. @prjct92eh2 is correct in that it seems the update has not been pushed yet.

However the problems just started yesterday. I was finally able to recreate the one rule that I deleted and I can see in the Activity Feed that the commands are being sent but I am not getting audio anymore.


(Alwas) #7

Luckily i have push notifications on the end of my TTS notifications, so i don’t miss things, but it’s strange for example, not to have a female voice in every room tell me the bath is ready, after years of hearing her. @prjct92eh2 no i haven’t emailed support, i’m still waiting for a response on my last issue, TWO weeks ago, i’ve given up on them, they seem overloaded. There’s more useful info on these forums.


(Barton.) #8

HUH? What kind of set up is this?


(Alwas) #9

Multiroom Speakers, webCoRE and water sensor.


( I hate Mondays) #10

Any errors in the IDE?


#11

Tim referred to this several times throughout the Beta tests in Centercode that their “Flagging System” might have a few kinks in it.

For a lot of folks, they received the email about migration, but never ended up seeing the banner in the application.

I’m thinking that they still may have an issue with this after they put peoples email addresses into the hopper for migration.

You can try force closing / stopping your ST Classic app as that was suggested, but more than likely they will need to put your account/email into the Flagging System again.


(Jimmy) #12

There have been TTS outages before, so make sure you email support so they can look into it.


(Alwas) #13

Hi Adrian, i’ve had this problem all day, and haven’t been able to glean any info from the IDE logs, from the main Speaker in the group i see things like
19:28:47: debug playTextAndResume(post box post box post box, you have mail, null)
The pistons perform correctly, whatever radio station is playing, stops for 30 seconds for the non existent TTS announcement, then the radio comes back…
It’s the same for Google home notifications, i hear the cast “beep” but then silence.
i did see this…
║Error while executing physical command Zzzzzz M5 Kitchen.playText([ok im just wondering if this is working now, it really should unless i’m totally confused, 47]): groovy.lang.MissingPropertyException: No such property: protocol for class: physicalgraph.device.HubMultiAction


(Borristhecat) #14

not sure if this is it but i can’t see any errors it just doesn’t play.

 40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace Returning 10 commands
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace sonosAction(SetAVTransportURI, AVTransport, /MediaRenderer/AVTransport/Control, [InstanceID:0, CurrentURI:x-sonosapi-stream:s24939?sid=254&flags=8224&sn=0, CurrentURIMetaData:<DIDL-Lite xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns:r="urn:schemas-rinconnetworks-com:metadata-1-0/" xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/"><item id="-1" parentID="-1" restricted="true"><dc:title>BBC Radio 1</dc:title><upnp:class>object.item.audioItem.audioBroadcast</upnp:class><desc id="cdudn" nameSpace="urn:schemas-rinconnetworks-com:metadata-1-0/">SA_RINCON65031_</desc></item></DIDL-Lite>])
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: info setTrack(x-sonosapi-stream:s24939?sid=254&flags=8224&sn=0, null, 470 B})
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace sonosAction(GetVolume, RenderingControl, /MediaRenderer/RenderingControl/Control, [InstanceID:0, Channel:Master])
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace setTrack(x-sonosapi-stream:s24939?sid=254&flags=8224&sn=0, 470 B)
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace Restoring track x-sonosapi-stream:s24939?sid=254&flags=8224&sn=0
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace sonosAction(SetVolume, RenderingControl, /MediaRenderer/RenderingControl/Control, [InstanceID:0, Channel:Master, DesiredVolume:56])
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace volume = 56
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace sonosAction(Stop, AVTransport, /MediaRenderer/AVTransport/Control, [InstanceID:0, Speed:1])
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace Delaying 8000 ms before resumption
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace setLocalLevel(56)
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace sonosAction(SetAVTransportURI, AVTransport, /MediaRenderer/AVTransport/Control, [InstanceID:0, CurrentURI:https://s3-eu-west-1.amazonaws.com/smartapp-media/polly-tts/salli/e398b2ad4a7bdac7ac3294658fdc107e6081d843.mp3, CurrentURIMetaData:])
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace Setting sound track: https://s3-eu-west-1.amazonaws.com/smartapp-media/polly-tts/salli/e398b2ad4a7bdac7ac3294658fdc107e6081d843.mp3
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace sonosAction(SetVolume, RenderingControl, /MediaRenderer/RenderingControl/Control, [InstanceID:0, Channel:Master, DesiredVolume:70])
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace Restoring volume to 56
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace sonosAction(Play, AVTransport, /MediaRenderer/AVTransport/Control, [InstanceID:0, Speed:1])
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: info setTrack(https://s3-eu-west-1.amazonaws.com/smartapp-media/polly-tts/salli/e398b2ad4a7bdac7ac3294658fdc107e6081d843.mp3, null, 0 B})
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace setLocalLevel(70)
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace sonosAction(GetVolume, RenderingControl, /MediaRenderer/RenderingControl/Control, [InstanceID:0, Channel:Master])
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace volume = 70
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace Stopping and setting level to 70
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: trace sonosAction(Stop, AVTransport, /MediaRenderer/AVTransport/Control, [InstanceID:0, Speed:1])
40813844-f043-48d0-9191-0b21fc47cf77  18:49:05: debug playTrackAndResume(https://s3-eu-west-1.amazonaws.com/smartapp-media/polly-tts/salli/e398b2ad4a7bdac7ac3294658fdc107e6081d843.mp3, 4, 70)
40813844-f043-48d0-9191-0b21fc47cf77  18:49:04: debug playTextAndResume(Roll out the red carpet for Steven , Steven is here., 70)
40813844-f043-48d0-9191-0b21fc47cf77  18:48:40: debug Not parsing XML message:

(Alwas) #15

And PUFF as if by magic TTS is back, whatever they’re paying you @ady624 , it’s not enough! :wink: