Setting additional parameter for zigbee command to set endpoint not working

Hi SmartThings Support Team,

I am having an issue with the zigbee.command().

zigbee.command(0x0006,0x00, [destEndpoint:0x08]);

If I execute this command I am getting an error

groovy.lang.MissingMethodException: No signature of method: physicalgraph.zigbee.Zigbee.command()

What seems to be the problem?

That’s very hard to diagnose without being able to see all the rest of your code, or a good portion of it at least.

Are you getting any errors when doing any of these?:


Hi John,

Thank you for the response. But I have figured out where the problem is and it is because I am missing a parameter.

zigbee.command(0x0006,0x00, [destEndpoint: 0x09]);

zigbee.command(0x0006,0x00, “”, [destEndpoint: 0x09]);

The quatation mark was for payload. And in this case for 0x0006 cluster it doesn’t necessarily need it but when I need to add more parameters, I have to fill this in even I have to put it blank.

1 Like