Set thermostat to come on at predetermined time


(Dave Bell) #1

Hoping for some help for a noob. I have a 2GIG CT100 Z-Wave thermostat set up and I can control it manually with my phone just fine.
What I can’t find is a simple way to have it turn on to a specific temperature at a specific time, such as 68 degrees at 7am.


(David Creed) #2

Hey Dave,

Check out Keep Me Cozy and Keep Me Cozy II

Click the + Key to Add new, then Actions, Climate

Cheers,
David


(Dave Bell) #3

Thanks David,
First, on my + key there is no Add new–Actions… just various device types.
I have found a few predefined actions (Good Morning!, etc)…
I found the Keep Me Cozy code in the developer section, and believe I published it properly (at least it says it is published) and seems to be connected to my hub.
…I’m just feeling dense like I’m missing something really simple… I just can’t find any evidence of Keep Me Cozy on the mobile app.


(David Creed) #4

Sorry, lets take a step back, do you have iPhone or Android device?


#5

When it walks you through how to set it when someone leaves just select the “At a certain time” option instead.


(Dave Bell) #6

David, thanks for your patience.
I have both and Android phone and an iPad available (but I tend to use the phone).
I WAS able to have the thermostat turn on by going through the Gear icon on the Hello, Home screen, and using the Warm Up action.

Although I’ve gotten this one thing to work… it doesn’t appear to be related to the Keep Me Cozy apps.
…and I’m REALLY curious about how to integrate apps that others have written.and published in the IDE.
I tried copying the Keep Me Cozy code and it shows as ‘published’ for my hub on the IDE web page, but I don’t see it anywhere in the mobile app.

Thanks


(Dave Bell) #7

Thanks Tyler, I was able to get Warm Up to work from the Hello, Home gear icon.
…my question is bigger than this one thing though… I’m trying learn how to take an app from the developer page and publish it for my hub.


#8

This should be a good start:
https://ryanstsupport.clarify-it.com/d/mmlpxw


(Dave Bell) #9

Thanks Tyler… the walk-through on that page was very helpful…
I have been able to get through the entire process EXCEPT for step 9: My SmartSetup does not have My Apps category.

Any thoughts on what would get My Apps to show up in SmartSetup?

Thanks!


#10

Make sure you’ve published it for yourself on the page where you pasted the code.

If you’ve done that try logging out and back in to the app.


(Dave Bell) #11

I’ve published for myself (can run it in simulated mode), I’ve logged out and in both on web and restarted app on phone, but I still don’t have the My Apps category (Android).