Set "good night" to am but shows & runs on pm?


#1

I’ve set good night routine, to switch on arm (stay) at 12:30am, but when I save it, it saves and runs at 12:30pm. If I set to 1:01am then it works.

Is this a bug? Can someone else try it please.


(Ryan Detzel) #2

Something is up with ST, I had this happen the other night and it’s just wrong.


#3

I’ve emailed ST, checked and doubled checked and even though the settings say 12:30am, it’s triggering at 12:30pm.


(Ray) #4

I just set it for testing tonight. Will let you know tomorrow.


#5

You can almost check straight away. I’m on iOS btw. Set it then go back into settings of the routine and first screen you’ll see the time, it says 12:30pm, then go to change and it shows 12:30am.

I’ve had a reply from ST and they’ve escalated it to tier 2 support…


(Ray) #6

The time stays AM on both screens for me. I guess it’s an IOS thing. I am on android and not home to test with IOS right now.


#7

Any chance you’ve tried on iOS yet please? My iPhone is set on 12 hour click if makes a difference.


(Ray) #8

Sorry for the delay. Tested on my iPad and it’s working fine. Are you using the latest ST apps? I remember a U.K member with the same problem but forgot which post.


#9

Yip fully upto date. ST said they’ve asked tier 2 support. I’ve tried changing a few times and the same problem.


#10

Still getting same bug. Asked support they told me was fixed and to delete and readd routines I did, and still the same.

Anything after 1am is fine but 12am upto 1am doesn’t work. Can anyone test and check for me please


#11

Well this is so so annoying… This is still happening. I’ve been sent a new hub, had to start again with things etc.

Well this new hub is the same, it’s a new setup of a hub, only added my location, haven’t added any things yet, inbuilt routines, it’s not working, why is it only me?

My iPhone is in 12hr setting, latest app, latest firmware. I goto the inbuilt routine, set “goodbye” to trigger at at time. Using the dial to set the time no matter if I set am or pm it shows am, it doesn’t move the dial.

I’m stumped, reset my original hub, been sent a different one, set this up, same.

Can someone try please and see what happens on the screenshots as this is so annoying.

Thanks


#12

I’d be grateful if other iOS users could try this, I’ll try and make a video to show the exact concern, but hopefully can see from the above screenshots.

Basically in 12hr on my iPhone, when editing routines for specific time, even if I go into pm it stays on am.

Thanks


#13

Well I got hold of an Android phone. Downloaded and logged into SmartThings with my account. The Android phone is in 12hr mode.

Connected on my home WiFi, I went to routines and seen the time, made a change to PM using the dial in Android and was fine.

Went back to my iPhone, and could see the time change I did on Android. My iPhone now in 12hr mode, tried to change to a different PM time and it would only do AM. Changed iPhone to 24hr mode, made a different time but still a PM time in 24hr, e.g. 23:34.

Checked in Android and was updated, again changed in Android in 12hr mode to a different PM time, e.g. 10:56pm, changed ok.

Checked on iPhone and the time had changed fine to 10:56pm again.

So does this not mean it’s an iOS app problem? If so why only me it seems? This happens on both my iPad and iPhone, both on iOS v9.3.1.

ST support have been saying it’s a hub problem etc, resetting my hub, even sending a replacement.

Anyone help? Even deleting the app, reinstalling etc doesn’t seem to work, as I never had it on my iPad before, first install and the same problem.


#14

Still no good, and now getting no reply from support to the original support contact.

It can’t just be me surely? The Android app is fine, yet my iOS on iPhone and iPad isn’t?


(Victor Sanchez) #15

I have the same issue. I’m trying to set the Good Night routine to 9pm to 6am and automatically change it to 9am its so frustrating. Hope an update for iOS works, i will test this my wife phone (note 3) to if this is an iOS bug or its my hub :frowning:


#16

No update, ST sent me a new hit, same, got me to reset everything to out of the box (a pain), same. Its still the same, I’ve had to “fix” it by using my iPhone in 24hr mode, which I really don’t want to do.

Its a ST issue, not an iPhone, must be. They just won’t fix it. Please email ST direct and ask.