Server Error - SmartWeather Station Tile Device in new ST app

Hi Folks,

Noob here, and I am have some small trouble. Got just about all my devices up and running but am having trouble with the SmartWeather Station Tile Device. The tile refuses to open on my phone. In the device ( on the PC in IDE) everything is looking great, it is getting the weather data and sending it to my ActionTiles quite nicely, it just refuses to open the tile on my phone in the new Smartthings app. So the tile actually appears on the dash board with a switch looking tile. I press the tile and it flips to the device page and tries to load, i get a circle “loading” then i get an error “A network or server error occurred. Try again later”. The tile will not open.

What am I doing wrong. I have read a ton of material on this and i fear i am missing something very basic.

Thanks in advance!

1 Like

And here is what the tile looks like


And here it is in the device

I don’t see any obvious problem with your configuration.

Mine works fine…

1 Like

Right!!! Me either. I am boggled. So just to confirm, all i do is just add the pre-configured device, in this case “SmartWeather Station Tile”, and the tile pops up on my SmartThins App.? Is this correct?

Say Terry, did you use the Classic app to load it and view or the new app?

Try to delete it and create it again. Make sure that the Device ID you assign to it isn’t being used by anything else.

1 Like

New App. (Though I’m sure Classic works too… but I only use it for ActionTiles).

Thank You RBoy!

I have done exactly this and still the same issue. I even use a new name for the device and used the Network id like you had about. Still the same network error. And i have the same error on my phone as well as my tablet, both Samsungs. Again all the data is coming in just fine, its just the tile that refuses to open. There must be something i am missing. Is there any data i can give you to help figure this out?

Also, just curious, if you see in my pics in the previous posts, my weather tile actually comes up as a switch with a button…Is yours like that? Why would a data / info tile have a button like that? Would that be a clue?

Actually now even I’m seeing it. I would report it to ST support.

Your getting the same error RBoy? So it’s not just me losing my mind??

1 Like

FYI Guys, I have emailed the support and started a ticket.

[SmartThings Support] Support request #771507: SmartWeather Station Tile Crashing


Another FYI, I just downloaded the Smartthings Classic App. Boy what a difference, everything in there makes sense to me and works. The Weather Tile is great, and now I can use the Security stuff with ActionTiles. So, why am I even using the new app?

1 Like

I am having this same issue but with a different tile. Any device to which I assign a custom handler (even one copy pasted straight from the smartthings git) is giving me this error.

Yeah, i have been have quite some trouble with the new app. Did you try your tile in the old app?

Update, this is now working. I haven’t changed anything, it just work now. Maybe they updated something in the new app?

1 Like

Does this work for you guys now? I only get

"Access Denied

We’re sorry, but you are not authorized to perform the requested operation."

Any idea? Thanks…