Sensibo integration

NOTE : This project is no longer maintained by the author. This integration required the classic SmartThing app, this is not supported under the new app.

The new Smartthing app support Sensibo but this not related to this projet. Please contact Sensibo for any issue with the new app.

The code source of my Device Handler and SmartApp are available on GitHub and it is free to use and modify if you want.

I created a Sensibo integration, this is including a Service Manager to communicate with Sensibo servers and a SmartApp to manage your Sensibo Pod at home using SmartThings.

My projects can be found here:

For donations for helping me to maintain this project up-to-date:

To install:

1- Connect to https://account.smartthings.com with your account
2- Go to “My SmartApps”
3- Click “New SmartApps” and use FROM CODE method and paste the SmartApp code and Click “Create”
4- Click “Save” and “Publish for me”
5- Go to “My Device Handlers”
6- Click “Create New Device Handler” and use FROM CODE method and paste the devicetype code and Click “Create”
7- Click “Save” and “Publish for me”
8- On your device, go in marketplace - SmartApps - My Apps and select Sensibo (Connect)
9- Get your api key from https://home.sensibo.com/me/api

DEBUGGING :

When you have trouble with my Sensibo integration, please do the following before contacting me:

Please run the following commands in a browser and send me the response IN PVT ONLY:

Replace the yourapikeyhere by your api:

https://home.sensibo.com/api/v2/users/me/pods?apiKey=youapikeyhere&fields=id,room

It will give you a list of your PodId and their room name. You need to Podid for the next command to run:

Run the following on all affected PODs:

Replace the podidhere by one of your podid and replace the apikey by yours. Send me the results of this in pv message:
https://home.sensibo.com/api/v2/pods/podidhere?apiKey=youapikeyhere&fields=remoteCapabilities,productModel

Also send me the log file from the Live logging when controlling the POD with problems.

15 Likes

Really thrilled to see this - thank you for creating it as I was looking for a way to enable my two Sensibos for ST. I will test it out and let me know if you need help testing anything - happy to help. But it is nice looking already.

Have a couple of things I have noticed during initial use - i get an “ici” notification from the smart app early often - perhaps I have not set something up in the app initial config correctly? I can send you a screen capture if needed.

Also my Sensibos are in US so set to Fahrenheit, is there a way to change the Smartthings side of things to report in F vs C - or use the hub location to default the setting if not? Just an idea going forwards - again thank

Sorry, i made some modifications and this a a debug version to debug notificatio I pushed the wrong version on GITHUB.

Please wait until tomorrow before download it again. I will fix it.

For farenheit, i do not support it for now.

Hi !

Please redownload it. The app is now fixed in Github.

Sorry again for this.

I will work on Farenheit support. This is a good idea.

I will change my original post, I will use my master branch to made to “working version” of my apps.

Hi ! My idea about unit is to read the Hub unit and use it in my Smart App.

This “feature” will come later, this is my next upgrade. This is good to have a US tester to test it when it will be ready.

Thank

@tintin, Please try again to download it from my master branch here:

Device type (Should be named Sensibo):

SmartApp:

I’m working on the Farenheit stuff. But as Sensibo is using Celcius in the backend, I will do my best to convert F to C when needed.

Hi @tintin,

The support for Farenheit is added.

Be sure you select Farenheit in My Locations. (click Edit and change the Temperature Scale).
And refresh your Pod using my SmartApps (Refresh button) and they should switch to Farenheit.

I have not made a lot of testing for Farenheit, if you can test it for me, I will appreciate.

Hi there - just confirming - I have successfully updated device and app as detailed above and following the device refresh the Sensibos (2) I have are now reporting in Fahrenheit corresponding tot the Hub location temperature setting. Well done that’s great helps keep things aligned with other temp and device sensors at the location - thanks so much for turning this around so quickly - makes it much easier to test other facets too - let me know if there are other things you’ like me to focus on for testing. Cheers.

Note after changing to Fahrenheit - when the “Recently” activity stream is viewed - those readings pre switch to F show a Green icon next to the temperature log item, and a Blue icon next to the humidity log item. After switching to F there are no icons for either log entry type int he “Recently” listing. Have a screen shot if needed

Redownload the Sensibo device type(the SmartApp is not affected), this issue is now fixed.

Download it from there:

NOTE: Sensibo team are working to have a better usage of Farenheit. I will wait for the full implementation of it and I will update my app after this.

Hi there - have followed through and this is now displaying the associated icons, when set for Fahrenheit - many thanks. Looking forwards to seeing whats next when you have time. Agreed the Fahrenheit support from Sensibo has been a little weak to date - looking forward to the next iteration.

wow thank you so much for building this. My sensibo is still in its box as I was using Tado for a while…but without logic to say only cool when we’re home and if it’s really hot over x degrees… it’s useless.

it seems i’ll be able to do that now using smartthings. :slight_smile:

EDIT: got the pods added, but the app is just showing 0 and I cannot turn anything on or off. odd.

were you able to put in smarts using smartthings for sensibo by using this app? like creating a rule i describe above?

Thanks a lot! Going to try this!

did the app work for you? I’ve reinstalled it a few times and get no control over sensibo at all via smartthings.

I have not tried it yet

let me know how you go.

Hey mate. Are you still around ?

EDIT: Brutalboy was very helpful and managed to fix the issue. Thank you very much!

For those who may have similar issues - reinstall the device type and you may need to re run setup again (delete devices and setup them up again).

@Brutalboy I am super impressed with your work on this. I added the device type/app as you instructed, and I was thrilled when I saw my pods in the app and they turned on when commanded.

My problem is once I turn it on, the status is not updating and I can’t turn it off. I am new to Smartthings and this is my first custom device. Please forgive my ignorance, I’m sure I did something wrong. I will check over my work again. Thank You!