SmartThings Community

Sensibo integration

smartapp_hvac

#486

Do you have click “Publish for Me” correctly?

You should see “Sensibo (Connect)” if you have published it correctly.

And be sure to use the updated repository for the code at


(Frank) #487

Delete the other entries and entered the updated repositories. Still no "Sensibo (Connect) in the Marketplace>My apps. I just don’t know what the issue is, any help appreciated. Thanks!


#488

Hey @Brutalboy - any change Climate React integration is in the pipeline?


#489

Are you connected to the same account on app and on web? Using samsung account?

Eric

-------- Message d’origine --------


(Frank) #490

Yes, I just double checked it letter for letter, it is the exact same email account for app and web. I also just uninstalled and reinstalled the Smartthings classic app from the playstore. Still Nothing.
After copying and pasting the code, saving it and publishing it, these are the names that appear.
My Smart app name is EricG66 : Sensibo (Connect)
My Device handers name is EricG66 : SensiboPod
These seems correct…right?


(Frank) #491

Ok, deleted and re-pasted the codes several times. Finally Sensibo (connect) appeared. YEA!!
I add the API and picked the pod. I have 3 Sensibo units, how do I add the other pods. I don’t see an option and I tried to add another API, but not letting me do that either. Sorry to be such a NOB. I’m usually good at following directions. TIA


#492

1 api key for the whole account. You should see all of the pods in the sensibo connect app if they all under the same account.

Check the following screenshots

Eric

-------- Message d’origine --------


#493

I’m really busy but I will try to find some time soon.


#494

I will add you fix in the next version. Thank for pointing it


(Frank) #496

Ok, went back and check all 3 boxes under pods. But now where do they show up on the app. I don’t see them under my home > things?


#497

You should see them yes with prefix Pod.

Have you clicked save after select them in the smartapp? When you save you should see a green bar at the top telling that the save works.

Screenshot :

Eric


#498

I have started to work on this feature. Some of them will be available inside Smartthings and webCoRE (like toggle Climate React on/off when already defined) and some will be webCoRE only (change the Climate React settings)(will be done later on).

here my first draft:

//
/* webCoRE Piston #2 */
/
/

execute
with
Pod Chambre
do
toggleClimateReact();
end with;
end execute;

or

//
/* webCoRE Piston #2 */
/
/

execute
with
Pod Chambre
do
setClimateReact(‘off’);
end with;
end execute;


#499

Awesome man! Thank you so much. So is this something I can do now?


#500

Im still testing over next week and I will share it to people after it is stable

Eric

-------- Message d’origine --------


(Dejongm) #502

Hello,
I’m having an issue in that I’m getting the following error:

9:03:15 PM: error java.lang.NullPointerException: Cannot get property ‘*****’ on null object @line 547 (pollChild)

Looking ar previous posts, you’ve asked for the following:

https://home.sensibo.com/api/v2/users/me/pods?apiKey=*******&fields=id,room

{“status”: “success”, “result”: [{“id”: “** ", “room”: {“name”: “Dining Room”, “icon”: “bedroom”}}, {“id”: " ”, “room”: {“name”: “******* Room”, “icon”: “Bedroom”}}]}

https://home.sensibo.com/api/v2/pods/*****?apiKey=*******&fields=remoteCapabilities,productModel

{“status”: “success”, “result”: {“productModel”: “inside”, “remoteCapabilities”: {“modes”: {“dry”: {“temperatures”: {“C”: {“isNative”: false, “values”: [17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30]}, “F”: {“isNative”: true, “values”: [62, 63, 64, 65, 66, 67, 68, 69, 70, 71, 72, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 85, 86]}}, “swing”: [“stopped”, “rangeFull”]}, “auto”: {“temperatures”: {“C”: {“isNative”: false, “values”: [17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30]}, “F”: {“isNative”: true, “values”: [62, 63, 64, 65, 66, 67, 68, 69, 70, 71, 72, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 85, 86]}}, “swing”: [“stopped”, “rangeFull”]}, “heat”: {“swing”: [“stopped”, “rangeFull”], “temperatures”: {“C”: {“isNative”: false, “values”: [17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30]}, “F”: {“isNative”: true, “values”: [62, 63, 64, 65, 66, 67, 68, 69, 70, 71, 72, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 85, 86]}}, “fanLevels”: [“low”, “medium”, “high”, “auto”, “strong”]}, “fan”: {“swing”: [“stopped”, “rangeFull”], “temperatures”: {}, “fanLevels”: [“low”, “medium”, “high”, “auto”]}, “cool”: {“swing”: [“stopped”, “rangeFull”], “temperatures”: {“C”: {“isNative”: false, “values”: [17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30]}, “F”: {“isNative”: true, “values”: [62, 63, 64, 65, 66, 67, 68, 69, 70, 71, 72, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 85, 86]}}, “fanLevels”: [“low”, “medium”, “high”, “auto”, “strong”]}}}}}

You’re help is greatly appreciated!!


#503

Do you still have the issue. Smartthing servers was getting problems last week.

Let me know


(Dejongm) #504

Yes I am. The tiles show, but it only reads 0 degrees. When I hit the refresh button, I get the error as noted above.

Thanks!


#505

Do this a brand new install or it was working before and stop working?

Which github repository you took the code from?

Eric

-------- Message d’origine --------


(Dejongm) #506

This is a brand new install. I used your Github repo mentioned above at


(Michael Orbon) #507

So Eric. I was updating a Sky unit to a new version. It is loaded and working in the Sensibo App. It shows as an option in the Sensibo Connect Smartapp, but then when I try to save the Smartapp, it errors out. This is surprising to me because I updated another a few months ago. Am I missing a step? Pause the app?

Thanks!