Sensibo integration



Only one API key for all of them if you are using the same account in Sensibo.

When you run the SmartApp called Sensibo (Connect), you should see them there when you click on the Pods List



I actually figured it out before you posted that picture! BUT, I can’t tell you how much I appreciate the help.

for possibly someone elses benefit: My screen only showed the original pod. There was nothing to choose from. BUT…after you click on adding, the screen changes. You don’t see it but below the screen are all of the pods which more or less have to be activated by clicking a box. After that…everything worked. thanks agaiin!


When you run the Sensibo (Connect) app again (on my screenshot). It show the current devices added/attached to Smartthing.

You have to click the POD LIST to see all the pods attached to the account and where you check select them (checkboxes).

This is basic functionnality of Smartthing, not specific to my code.


all good! appreciate your help.

(Marcos Arias) #471


the support of sensibo told me that this is due to the integration with smartthings, check out the integration with smartthings and it does not happen anymore. Is there a solution for this?

my sensibo sends the turn-on command repeatedly. You can see the video



Your message is incomplete…

From which branch you get the code? Do you have updated to the latest version?

Do this is a brand new install or it was working before and now it do this behavior?

Please send the settings you have used in Smartthing, refresh rates, etc. Send screenshots of the configuration

Also, you are using webcore or other external tools? It may because you made a mistake somewhere there.

You can send me the smarthing log to check.

(Marcos Arias) #473

I have not updated to the latest version. Before it worked fine and then started with this. I do not use WebCore. Delete your application to verify what the integration was. Tonight I go back and install it and confirm if the problem persists and I send screenshots. Thank you.


Install the latest version from the branch 635-1.

You are the first with this problem…

(Ian) #475

Hi @Brutalboy - does your app provide the functionality to activate and deactivate Sensibi’s Climate React feature?


This is on the to-do list so not yet.


-------- Message d’origine --------

(Ian) #477

Thanks @Brutalboy. That would make all the difference for me! I’ve donated to show my appreciation and hope to see this update soon if you are able.


Thank a lot. How do see this feature? Just to be able to enable and disable or more?


-------- Message d’origine --------

(Ian) #479

For a phase 1 a simple on/off would be great.

Using this feature keeps my home at the perfect temp but it can’t be toggled when I change SHM modes automatically and it stays on until manually disabled. I want to geo fence my home and have the feature turn on when I approach to heat/cool before I get home. Not having much success with Sensibo’s Geo fencing and want to do in webcore.

What do you think?


I tried searching this error but couldn’t get any helpful results. I’m working on installing the Sensibo integration using the first post of this thread but I’m getting the following error. Anyone familiar with the error: startup failed: script_app_metadata_1b456c7a_a633_4bd7_bfe7_b30b51ac9e82: 1: unexpected token: @ line 1, column 95. ps/ericg66/sensibo-connect.src ^ 1 error
I’m sure its something I’m missing or doing incorrectly. I click My SmartApps => New SmartApp. I click on From Code and paste When I click “Create” button I get that error.


n/m. Figured things out. Definitely me. Didn’t realize I had to paste the raw code in. Sorry.

(Michael Liebenow) #482

I found a bug in pollChildren() where humidity can be null and this isn’t handle properly by the SmartApp. For me the fix was to provide a 0 value when a null was encountered such as:

def stemp = stat.temperature ? stat.temperature.toDouble().round(1) : 0
def shumidify = stat.humidity ? stat.humidity.toDouble().round() : 0

I believe this only occurs with the internal Sensibo devices. These little devices aren’t as feature rich as the Sensibo Sky, and in fact it appears Sensibo is doing everything they can these days to hide the existence of these devices. I’d switch in a heartbeat except for the fact that the internal devices don’t add another box to the wall, don’t take up an outlet, and are hardwired to the A/C unit so don’t clutter the house with IR signals

(Frank) #483

Sorry if this has been asked before, I do not see a tab for “Device Type” there is one for “Device handlers” is it the same thing?

(Mark) #484

Yes, the terminology has changed over time since this smartapp and associated device handlers were released.

(Frank) #485

OK, I did enter the device type code under the device handers section, and the My Smartapps code under the My Smartapps sections, save and published both, but Sensibo is not showing up on my device in the Smarthtings classic> app>marketplace>my apps screen. What am I not getting right here? TIA