SmartThings Community

Sensibo integration

smartapp_hvac

(Ahmed) #346

@Brutalboy sorry i’ve been away from home and no PC. Just got back will try it out tomorrow and update you. many thanks.


(Fwump38) #347

Hi there

I’ve been using this DH for some time now with great success however I get a message notification several times a day when I haven’t made any changes to my thermostat. The message comes in the form of a push notification from the SmartThings app with the following details:

Pod - Temperature:
Humidity: Battery: 3000

Is there a way to turn these off? Also I have no idea why I see a battery level. I tried looking through the Device Handler code but couldn’t figure it out.

Thanks!

EDIT: Figured it out. I had to go into the installed smart app and turn off the hourly notifications.


(Kraeg) #348

I’ve got a strange bug too:

When using webcore, sending a basic on command will also click the swing button.

E.g.
If I just turn on the air con, with Alexa or ActionTiles etc
The swing mode also changes: if it’s set to high, it’ll move it to middle
Turn it off and on again and it’ll turn from middle to low
Etc etc etc

Really annoying as I always have mine set to full swing. And as the app doesn’t expose these options to webcore I can’t configure it to not do it.

Any ideas on a fix, I have a VERY basic grasp on Groovy

Kraeg


(Ahmed) #349

@Brutalboy where in the DH do I add the code for those 4 new tiles? Also, there is cool, and heat, what about maybe having auto for the thermostatMode?


#350

Let do the heat and cool tiles for now, as the 2 other are not working

You have to put somewhere before the main ([“switch”])

Example :

    standardTile("coolmode", "device.thermostatMode",  width: 1, height: 1) {
   		state "cool", action:"modeCool", backgroundColor:"#00a0dc", icon:"https://image.ibb.co/bZ56FQ/cold.png"
    }
    standardTile("heatmode", "device.thermostatMode",  width: 1, height: 1) {
   		state "heat", action:"modeHeat", backgroundColor:"#e86d13", icon:"https://image.ibb.co/c7Grh5/sun.png"
    }
    
	main (["switch"])
	details (["thermostatMulti","switch","fanLevel","mode","swing","voltage","refresh","coolmode","heatmode","powerSource","firmwareVersion","productModel"])    

ALSO, You also need to add 2 commands at the top if they are not already listed (after the last one):

    command "modeHeat"
    command "modeCool"

#351

for the full and auto fan, here the 2 tiles to add:

    standardTile("fullfan", "device.fanLevel",  width: 1, height: 1) {
   		state "high", action:"fullfan", backgroundColor:"#8C8C8D", icon:"https://image.ibb.co/fcfFaQ/fan_high_2.png"
    }
    standardTile("autofan", "device.fanLevel",  width: 1, height: 1) {
   		state "auto", action:"autofan", backgroundColor:"#8C8C8D", icon:"https://image.ibb.co/m8oq9k/fan_auto_2.png"
    }

the 2 commands to add at the top :

command “fullfan”
command “autofan”

and you need to add 2 functions(def) for these. you can put them just before the temperatureDown(temp) function:

def fullfan()
{
dfanLevel(“high”)
}

def autofan()
{
dfanLevel(“auto”)
}


#352

No idea. never seen this before…


(Markoohay) #353

Copies code to the SmartThings IDE but got the following error when I clicked create.

—Begin—

Groovy.lang.MissingMethodException: No signature of method: script_dth_metadata_6d354200_8d4a_4044_a173_74903f57f255.appSetting() is applicable for argument types: (java.lang.String) values: [apikey] Possible solutions: typeSetting(java.lang.String), typeSetting(java.util.Map), typeSetting(java.lang.String, java.lang.String), getSettings(), setSettings(java.lang.Object), typeSetting(java.lang.String, java.lang.String, java.util.List)

—end—


#354

You have missed somethings for sure. it is looking for the API Key.


(allan smith) #355

@Brutalboy - Thank you for your work and giving us another reason to enjoy more SmartThings and Sensibo. Appreciate you man.


(John G) #356

Hi Eric,

Thanks for the awesome work, one question, once I generate my api key where do I put it ?

Cheers


#357

Do you have installed the Device Handler and the Smartapp?

if yes, On your device, go in marketplace - SmartApps - My Apps and select Sensibo (Connect)

It will ask for it in the first page.


(John G) #358

Great thanks for the quick reply.


(Steve) #359

@Brutalboy - Just installed my first Sensibo - awesome job with the device integration. Thank you!


(griskait) #360

Hi, first of all thanks for your work.
I installed my 1st sensibo no problem, how do I add another?
thanks


#361

If the sensibo are added all under the same account, you go back the sensibo (connect) smart app and add the other like this photo (i have 3 pod myself):

Eric

-------- Message d’origine --------


(Bogdan Alexe) #362

I can not set sensibo to dry from webcore. Any ideas?


#363

There is no “out-of-the box” Dry mode in Smartthing, check this:
http://docs.smartthings.com/en/latest/capabilities-reference.html#id91

So for my integration, I have “by-pass” this limitation but this is not working for external app like Webcore.


#364

I will add a custom command to my DH and webcore will see it and you will be able to set to Dry mode.


#365

Here the custom commands added for exposure in webCoRE (I will post to github soon under the MSA-635-1 branch)

modeCool(), modeDry(), modeHeat(), modeFan(), modeAuto() and setAll(mode,temp,fan)

SetAll() can be used to see the mode , the temperature and the fan level on 1 call

How to use setAll in webCoRE (you have to add 3 string parameters):

To make them visible in webcore(after you install the new DH) do the following.

  • Go on webCoRE smartapp in SmartThing
  • Select “Settings”
  • Select “Available devices and contacts”
  • Select “Available devices”
  • Select “Save” (4x)

Restart the webCoRE webpage and go configure your pistons