Sensative Stripe - Config Help?

@Aaron @hyeung
I’ve been going through the DH templates and have found one for Z-Wave Door/Window sensor.
I am not a coder by any stretch but looking at the code I can see this in it.

def updated() {
def cmds = []
if (!state.MSR) {
cmds = [
command(zwave.manufacturerSpecificV2.manufacturerSpecificGet()),
“delay 1200”,
zwave.wakeUpV1.wakeUpNoMoreInformation().format()
]
} else if (!state.lastbat) {
cmds = []
} else {
cmds = [zwave.wakeUpV1.wakeUpNoMoreInformation().format()]
}
response(cmds)
}

Is the bold highlighted bit above the bit that defines the wakeup timer.
Not sure as it is 1200 and however I interpret the figure it does not give me 4 or 24hours.

Hopefully one of you coders out there will enlighten me.
Also if it is, what does the 1200 figure mean? Seconds, minutes etc.
Thanks.

EDIT: I have used the DH on my strip and it does show open/close as the door opens/closes so it does work OK. No wakeup shown in the ide though.

Yesterday my Sensative strip suddenly started to report 1% battery! So I excluded, re-added and then it went back to 100%, but it’s gone back down to 1%. No one else? I’ve emailed Sensative but no reply as of yet.

Sounds like you might have a faulty one.

You need to set the Wake Up in the configure() method:

def configure() {
	commands([
        zwave.wakeUpV1.wakeUpIntervalSet(seconds:1800, nodeid:zwaveHubNodeId)
	])
}

During the Inclusion interview, the Gateway still sends its default Wake Up Interval of 14400 seconds, but later it sends another with the configured option:

See above.

All and @Tyler

Do we have an official DTH that supports all configurable parameters for “Strips” yet ?

For the wake up time, it’s my understanding that the smartthings hub sets all devices to a wake up time of 4 hours. Whether you get an event for this is up to the DTH. I’m personally trying to figure out why the wakeup events seem to drop out on some of mine. As mentioned above, it can be configured via preferences, or it could just be hardcoded into the DTH.

There’s only 2 parameters - whether it sends binary/basic/notification report and something with the led, which I haven’t played with as their manual isn’t real clear.

The problem with all of these is that configuration parameters for wireless devices are pretty lacking in the template/basic DTH. Especially with something like this, where they intend to put it to sleep for 24 hours, the only time a battery-powered device will accept commands is when it’s awake. But even finding a DTH that has actual configurations that it will send to a device is one thing - finding one that “parks” the configs until the next wake up is a whole other ballgame.

It would be really nice if the example DTHs actually incorporated this instead of all of us having to make it ourselves.

This has been “in progress” for a while now… still nothing from Sensitive or SmartThings on this new DH?

Actually I wrote one - I just hadn’t published it yet. I originally had a parameter to invert the open/close reporting, but I took it out because I couldn’t find a use case. See if this works for you: Strips Handler

2 Likes

@doncaruana, I just switched over to your DH, and it seems to be running ok except for the “wake up time” of 24hrs. I cant get it to stick. when I pull up the sensors in the ST app and change parameters and tap done, it seems that nothing changes and the tile shows green and “synced”. Am I missing something? Even in the IDE under preferences, it shows wakeupinterval as 86400. In the events log it still shows the sensor waking up about every 3 hours.

I think SmartThings pushed some kind of changes or something. I’m seeing weird behavior and this handler was tested pretty thoroughly. I’ve noticed some stuff with some of my others - that haven’t changed - as well. I’ll take a closer look and see if I can figure what the heck is going in.

Did you get a chance to check on this handler? Also, @Aaron do we have an update on an official Sensative DH that supports configuration changes?

I’m sorry - I’ve been away for things for a bit, very busy at work. I have not gone back and checked things out since ST pushed out a fix for some stuff they broke. Not sure if this was included or not. I hope to get back to checking on this in the next few days.

Any update on an official status for the new code?

Hi,

I’ve been almost a year when I started this thread.
Just wondered if anyone has heard anything regarding an updated ST DH etc
In order to config wake periods etc?

Cheers,
Hung

I’m interested in this too as extending battery life is key (as we can’t change the batteries). I can’t find any info anywhere so shame there is still no official update here to the good question posed by @hyeung.

I don’t understand you guys, this is an open close sensor, easily the best one on the market, it works every time, it runs local, battery life expected 10 years, and you want a custom device handler to change the wake up period from 4 hours to 24 hours? Really? By the time these batteries run out battery technology will of improved 100 fold, there are many more important SmartThings battles worth fighting for than this, like a proper Samsung speaker integration.

The default wake period according to Sensative is 24hr; and they recommend it should be set to this.
Their battery claims will be based on these configurations.
However, for ST they default this to 4hr and there’s no way of configuring it back as I understand.
So naturally one would want to change this back.

1 Like

How did you get the information shown in that screenshot?

I had no idea that SmartThings overrides the device’s default wake up interval.

Sensative says the battery lasts “up to 10 years under normal usage”, but I wasn’t able to find a definition of “normal usage” on their website.

If it’s in a high traffic area I highly doubt it will last anywhere near 10 years so disabling the LED and changing the wake up interval will make a little bit of a difference.

That being said, SmartThings is not going to create a DTH for this device when there’s already one that works and I highly doubt they’ll ever build the wake up interval setting into any of their DTHs because it will effect the functionality of the Health Check feature.

If any of the users that previously mentioned they were using the zwave plus door/window sensor DTH are still using it, they should change it back to the default DTH because that zwave plus version keeps the device awake for 10 seconds every 12 hours which will definitely effect the battery life.

1 Like

I’ve had both DH setup. The zwave plus one shows a wakeup status in the IDE. When you click on it it shows the times when it wakes up (approx every 4hrs!)
The default DH doesn’t show wakeup status, instead I have a checkinterval status of 28920. Not sure what this relates to?

I have had one strip installed outdoors but never last 1yr. Turns out I had communication issues due to signal, and ended up draining the battery more than usual.
Tried power outlets near by and power switch modules which helped but in the end was still unreliable at the desired outdoor location! I.e. Backgarden gate. I presume material of house etc meant there were issues with signal causing a massive drain in continuous communications to the hub.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.