Select Triggers and Actions Disappearing


(J Steven Brooks) #1

I have been reviewing my rules daily to make sure the Triggers and Actions have not disappeared. First screenshots shows the Action is missing:

Under Send or Speak a message, no information is displayed: When selecting this action, the information I originally entered is still there: And of course, after selecting Done all the way out, the select Action is now displayed: . I have had Triggers disappear as well. When these disappear, taking my low batter notifications as an example, I constantly receive notifications about every hour because the trigger is missing; when I go through the motions of re-establishing the trigger the notifications stop. I really need some help in identifying the root cause of this.


(Bob) #2

It’s nothing you’re doing wrong. The system is hosed, and by their own admission, even they don’t know the root cause (impossible as that sounds).
http://status.smartthings.com/


(J Steven Brooks) #3

I’ve subscribed to the status updates but wasn’t sure if that was the culprit of my issues. Thank you for the confirmation! :slight_smile:


#4

Pretty sure it is. I have several custom SHM rules that I needed to go back and fix, specifically mine dropped the devices. Oddly enough, they still worked, but then again things have been really messed up right now. I’d let things settle while ST figures this out.


(Tolik) #5

Your not alone, not that makes things any bbetter, I also had a number of triggers just disappear.

:frowning:


(Bob) #6

I had an odd one last night. A conditional trigger where the conditions and actions disappeared… with no way of gaining access to the Conditions menu. I had to delete it and recreate it. Even odder, live logging showed that it successfully ran… except nothing actually happened! It was set to trigger at 9:56 pm; I checked it at 9:55 to verify, and all looked okay. When it failed to do anything, I rechecked at 9:57. It was rescheduled for 9:56 the following evening, and showed Prev Run Time as having just executed. So now we can’t even trust the IDE logs or status!


UPDATE: Recent SmartThings User Experience & Platform Performance
(J Steven Brooks) #7

I’ve been extraordinarily patient with all of this. I had a rule that would send a message when the plants needed watering sending a message on Saturday and Sunday between 7 AM and 7 PM. The trigger was applied to the sensors in the plants. The trigger was gone as well as the time frame, multiple messages were sent in the middle of the night. I’m sorry guys to say this but if they can’t get the system stabilized and stop the nonsense of losing data I’m going to have to no choice but to go to another solution. Geofencing used to work beautifully to open my garage door when I entered the neighborhood now I’m lucky if the app realizes I left. I’ve done all the troubleshooting I can; I’ve been in IT for 15+ years. Things just don’t “stop” for no reason; rules getting messed up or unstable system are reasons.