Seem to have two disconnected accounts

My smartthings account was migrated to a samsung account a while back and everything has been weird ever since. I’ve decided to get this working now and am failing at the first hurdle as it looks like I have two views of the same account.

On the smartthings app it claims to have a samsung account with my email address.
When I go to manage account on the phone, and go to linked services, then I can see Google, Alexa and IFTT - so that makes sense.

But when I log on to the smarrthings dev portal using a web browser with the same smartthings account it says I have no linked services and I can’t see any of my smartthings devices.

Both versions of the account are using the same email address - is it possible to have two smartthings accounts with the same email address, or has the migration from class smartthings messed it up?

By the ‘dev portal’, do you mean the Groovy IDE at That can look rather spartan if you log into it with e.g. and that isn’t where your account is located.

Or do you mean somewhere else?

Well, that is just bizarre…

I tried logging into the graph API URL with my samsung account and same thing - no hub, devices, etc.
Then work called…

Went back to the web page, logged out, back in again and now the graph API is showing my hub and devices. So that’s good :+1:

But still no connected services at the samsung URL. Well, I guess I can get to the hub now so the main problem is solved.

Linked services do not show in IDE or in

Reminder: IDE should cease when groovy is shut down.

1 Like