Schlage Locks no longer working

Using latest Smartthings Hub, RBoy LUM and Device Driver. 2 locks were working fine for 2 years. ~2 weeks ago, Smartthings App (newer version) showed both “Not Connected”. Tried Z-wave repair (multiple times). Tried to delete 1 of the locks from the App to re-add it, but it would not delete. Deleted the App and re-loaded it. Tried factory reset on 1 lock, (Then deleted all codes) Logged into Samsung Smartthings, updated the code for both the RBoy LUM and the Device drive (and published both), reset the lock again and deleted all codes. Now shows connected and status, but does not do anything. Cannot lock/unlock. Does not upload codes (lost all the codes from the old App!), doesnt respond to any routines (re-lock after door close). 2nd lock still shows “not connected”.

tagging @RBoy

also noticed you stated you ran z-wave repair before resetting the lock… did you run it after you added the lock back to check for any errors such as a ghost device?

Yes, multiple times.
Also, received notice that “user code upload failed for user…” (all users). Codes still dont work. App still doesnt work.
2nd lock (have not done anything on that lock) no longer shows “not connected”, but actions on APP have no effect on lock.

btw; When this started, Apps showed both devices with 1% Battery (recent battery change in lock#2) so I changed all batteries in both locks.

Just looked at lock#1 on the Web and saw the following:

  • Received Messages From Device: 15
  • Received Messages From Device (Duplicates): 0
  • Messages Transmitted to Device: 78
  • Messages Transmitted to Device (Failures): 76
  • Updated Time: 2022-01-22 6:06 PM EST


Hub is about 5 feet away from Lock#1 and path is direct. I did put the hub right next to the lock when I tried to delete it.

Mesh is having trouble causing packet loss. Exclude the lock, reboot the hub and pair it again. Also add a buffering device to the mesh.

I was able to delete the lock and re-add it. I then re-assigned the Universal Z-wave Lock with alarms and still all the send packets from the Hub are failed.

When you say exclude, do you mean delete it (as I just did)? (or something else).

is this a @rboy dth? or did you mean z-wave Lock with codes?

RBoy “Universal Enhanced Z-Wave Lock”

Just did the Z-wave repair again. This time “Front Door Lock Failed to update route”

Very Frustrated.
I bought an Aeotec repeater and put it between Lock #1 and the Hub. (Added it successfully to the Hub). Nothing changed. z-wave repair. No change. Excluded the lock, reset to factory, deleted all codes, re-added to Hub, updated the device driver (Rboy Universal Z-wave lock…) (saved, published, etc). Device shows connected directly to Hub (not via extender). No failed packets. (It shows 7 From and 20 to, with none failed, but that number has not changed in 20 min and despite multiple commands )
Still not responding to any commands. Does not show lock state. When I open the lock on the App, every section says “not supported”. Added to LUM, but unsuccessful at updating User Codes
Also had a lot of trouble Excluding the lock (Made sure not being used by LUM) and had to exclude on line (kept failing from App)

Does the lock state show using the device type handler that the device pairs with? What does the raw description show?

Type Universal Z-Wave Lock With Alarms
Raw Description zw:F type:0000 mfr:0000 prod:0000 model:0000 ver:128.22 zwv:3.42 lib:06

The more I read, the more I consider myself lucky to have not updated the app. My lock is working perfectly, albeit with less flexibility than a couple years ago. But as Covid finds us having severely reduced the influx of folks for whom codes would need dynamic assignment, that has turned out to be a non-issue.

In the meantime, it responds correctly to presence sensors and to automations that ensure it is locked when it need be and unlocked when desired. SHM still sees its keypad as a valid disarming mechanism.

Hi there. All 0’s means that the lock is losing packets while communicating with the mesh and/or hub. Since you’ve tried almost everything, the only thing I would add is to try rebooting the hub, excluding the lock (not a factory reset) and pairing it thereafter. You may also want to check for ghost zwave devices in your mesh and remove them if you find any as that could also cause communication issues in the mesh. If that still doesn’t work then possibly your locks zwave module is failing. Please see these links for more details:

1 Like

Well, since my last post, I bought 2 Aeotec Repeaters. First, Installed 1 next to the Hub (~3 feet from the hub and 5 feet from Door Lock #1). I tried multiple ways to install lock #1 with no joy. I then removed EVERYTHING from the hub, reset the hub to factory, restarted the hub and did the set up, reset every device and excluded them again. I then added the first repeater (I only bought 1 at first) and then tried to add the Schlage lock #1. It worked perfectly and responds to LUM. I then added everything back, but when I tried to add Lock #2, it brought me to the QR/PIN page (which I did not see on Lock#1) and would not add _non-secure correctly. It is visible, says connected, but is essentially in the same state as Lock #1 was. I then purchased a 2nd Aeotec repeater which I placed ~12-13 feet & 2 walls from the hub and ~5 feet from Lock#2 and added it to the Hub (after re-setting the lock to factory/excluding/removing from smartthings/rebooting the hub) and tried again. Same result. Shows connected with appropriate device handler, but not really communicating or responding to commands.
Do I have to start all over, add the 2 repeaters first, then the 2 locks and then everything else? Is the Hub just overloaded?