Schlage Lock Thinks It's A Smoke Detector


(Burke Gladding) #1

Successfully installed a Schlage Connect lock a few days ago. Changed the device handler from the generic Z-Wave Lock to @RBoy Universal Lock handler - which has a great UI and covers all the bases I’d want. Worked like a charm.

This morning, however, my app Dashboard (iOs) showed that my Smoke Detector was ‘OK’. Of course, this made me feel extra safe, until I realized: I don’t have a Z-Wave smoke detector. Looking into various SmartApps that might monitor a Smoke Detector, I soon discover that ST now thinks my Schlage lock is a smoke detector.

None of these SmartApps are installed.

By early evening, my lock stopped responding to ST commands. It also shows the lock is unlocked.

I’ve rebooted the hub (power / batteries out). Same behaviour.

I’ve excluded the lock then added it back in. Same behaviour.

I’ve change the Device handler. Same behaviour.

Anyone have some suggestions?


( I hate Mondays) #2

I would expect nothing less than your zwave coffee machine waiting for you with a steamy cup of coffee tomorrow morning! So Schlage locks smoke?

You may want to ask @slagle or @Aaron. They may be able to help. Good luck with your new blinds. Wait, that’s Monday :wink:


(www.rboyapps.com - Make your home your butler!) #4

That is by design. Since this is a unified DH it encompasses capabilities
for all locks. If you don’t want your lock to expose smoke detector
capabilities, just comment out the line in the code that says
"capability Smoke Detector".
Unfortunately ST doesn’t allow dynamic capability selection as yet.


( I hate Mondays) #5

So there is no coffee machine nor blinds capability coming up next? ;))


(Burke Gladding) #6

@RBoy I figured there would be a line in there somewhere - and that part is easily fixed. Thanks for pointing it out.

Sadly, it’s the lock being unresponsive now that’s really got me stumped. I’m beginning to think maybe my lock has gone wonky - it’s just not responding. I’ll spend today trying trace it out. So far, the best that happens is that it pairs - and un-pairs. But that’s where the excitement ends.

At least auto lock and the keypad continue to work. And I doubt I have a security issue - hopefully tomorrows firmware update address those issues (https://goo.gl/sXc7oI).

@ady624 - if K-Tel or Ronco ever get into the home automation game, you know everything will slice, dice, and brown the food. Until then, I’ll need to make my own coffee like a sucker.


( I hate Mondays) #7

With regular delays and missed events here, Lots of food would be - let’s say - overcooked ;))


(Burke Gladding) #8

OK - so here’s the thing. I did a factory reset on the lock to exclude it, again. However, this time I did not tell ST to delete the device. I did not perform a General Exclusion. I simply paired the lock again - and the lock just took the same place it previously existed in (strange, but true - and not without precedence with some Leviton appliance modules).

It worked. Just like that.

So three times lucky with the include / exclude business. It’s just finicky, I guess.

Unfortunately, I can’t point to any one thing that caused or resolved it. And the log is useless since it stopped logging yesterday and didn’t start to log again until just now.

Maybe it’s a one off. But with my one off event of a light randomly turning on in the middle of the night and this business with the lock … what’s my next one off going to be?

Thanks everyone for commenting. I’ll consider the issue closed … until the next time.


#9

A factory reset does not exclude a device. That’s why it kept its same network ID
.

A factory reset resets all of the device’s configurable parameters to their original settings. But it does not touch the network settings. For those, you have to use a directed exclude command. :sunglasses:


(Burke Gladding) #10

Following the ST instructions, the lock would simply not un-pair. Despite multiple attempts. (https://support.smartthings.com/hc/en-us/articles/201032800-Schlage-Camelot-Touchscreen-Deadbolt-BE469NX-). So I moved into the factory reset world. It worked – and it allowed me to pair again. Or, at least, it appeared as a new device in the ST App. It just took three times for things to start working again.

It was all a bit kooky. The whole thing - which is why I’m not convinced that I don’t have a wonky lock.


#11

Is it the Nexia model of the lock? There’s a known issue with pairing with that one, you have to do it a bit differently.


(www.rboyapps.com - Make your home your butler!) #12

:)) yeah IDLock has a fire alarm built into it, pretty cool huh! I really WISH ST would allow us to dynamically select capabilities as we move towards unified DH’s. So far I’ve seen locks with audio alarms, fire alarms, tamper alarms, vibration sensors, I’m pretty sure Cameras and PIR’s are next on the list.