Schlage Connect keypad not working

I had the same problem (keypad no response, ok to control via hub) after about 3month. Found out it is the connector from the keypad to inside board got loose. Reconnect solved the problem and I will keep monitoring it

Two years after the post and this is still an issue? My Schlage Connect lock is 1 month old and the keypad non responsiveness has happened twice. I do not have Smart Things at all. This is a Schlage lock issue. Unplugging the battery pack and plugging back in fixes the issue until the next time. Now I have to give keys out, what’s the point it the lock then?
Had this thread or anyone contacted Schlage yet?

I have had this issue happen numerous times with numerous locks in the past 6 months - the most recent was with a brand new replacement BE469 Firmware Ver. 10 after the previous lock did the same thing (so that was twice in 24 hrs with 2 different locks). I got the same response from Schlage: it’s a power connection issue… No, it’s not. I’ve installed 40+ of these locks over the past 5 years and I know what I’m doing. The issue of the lock face going dark/unresponsive is one thing when the lock is in the “unlocked” position, but I have had several instances when it has gone dark/unresponsive while the deadbolt is engaged. When that happens, you need a key, and really need to torque the bolt back. I spoke to Schlage about that issue and the rep didn’t understand what I was talking about. They sent me lock replacements, and ironically, the lock I recently replaced (the FW v. 10) just did it again today. Replacing it today…

Same issue here. We have had this keypad for at least 2 years, suddenly (yesterday) it stopped responding. A quick power cycle and it came back to life. Then a couple hours later, it was dead again. Tried brand new batteries (even though the last ones were at 83%), same thing, came back to life but only temporarily. Called Schlage, because we were within our warranty - they replaced the lock. Hooray!

Camelot, BE469, Firmware Ver. MAIN_7.1. Purchased 12/2017

Did anyone get return directions with their replacement lock? I just got mine yesterday, but no directions or return label. Or are they taking the Amazon approach of discard the old one. I emailed them back, but it seems like a 3-4 day wait period for a reply.

They’ve never required us to return them, especially if they’re still under warranty.

1 Like

I have 3 of these and have the same issue with just one of them. I called Schlage and they’ve sent a replacement but I have a theory of what may be causing this to happen and was hoping everyone could confirm there instances against my theory. Of the 3 locks I have installed, 2 are located behind a store door while the 3rd lock (with the problems) is mounted on a door without a storm door. I live in MI where summers get hot and winters get cold so my theory is that because this lock is exposed to the elements and not covered by a storm door the rain, snow, hot & cold is somehow effecting the function of the keypad? So I’m curious if your problem locks are exposed to the elements, covered by a storm door or under a roof such as inside of a garage/under a porch eave?

We’ve got a few test locks setup in different conditions including this one facing the morning/afternoon sun outside with limited exposure to rain and frost for the past 6 years. So far so good.

A few things to check:

  1. Is the keypad wire connected properly. You’ll have to disassemble the mounting and check it.
  2. Has the keypad has become disabled (internal setting). This is also known as privacy mode. You can change this setting directly on the lock or by using this Enhanced Z-Wave lock device handler (which also has fixes for other firmware bugs with this lock model including partial loss of notifications and well as getting access to other hidden features on this lock like the built in alarms, audio controls etc): [RELEASE] Universal Enhanced Z-Wave Lock Device Handler for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung
1 Like

So i had this issue. Locked/unlocked via phone, key worked alarm etc, but the exterior keypad looked dead. Removing/replacing the batteries didnt do anything and the wires between interior and exterior were fine and connected. I took it apart and noticed moisture on the circuit board and corrosion on the inside of interior plate. So i took it all the way apart, (removed the circuit board) and wiped it off with a clean paper towel. I Think the water droplets on the board made the keypad invisible because once i wiped it off (it had a decent amount of water buildup) it worked just fine. I live in the south and with the hurricane elsa just went through i think the difference between the 90deg 80%+ humidity outside and the cooler inside caused the condensation to happen. So maybe give the circuit board a quick wipe down and see it it work (both sides).

1 Like

I have two BE469ZPs; firmware 0.11.0. They both do it with brand new batteries. The first one about 3 days after installation, the 2nd one 27 minutes after installation. Put voltage meter on them both: 6.4V and 6.47V respectively. First one is connected to my Aeotec SmartHub and still works via the app when the keypad is dead. 2nd won’t connect to the hub/mesh even though it’s 50ft line-of-sight to the first lock; 70 ft to hub. (So much for robust z-wave meshes). Disconnecting / reconnecting batteries “solves” it…

UPDATE: Just spoke with Kim at Schlage CS and received some useful info: They recently switched chip vendors because Ford was also a customer of their older chips and post-COVID, Schlage had severe availability issues. They have a number of reports of this problem and apparently, based on the date of mfg (which is on the programming code sticker), the problem is only occurring with the new chips. FYI: My dates of mfg are: 8/3/2022 and 8/8/2022. So, they are sending me two new locks that have the old chip in them. We’ll see…

I am a Home Assistant user, but stumbled upon this thread because I am having this issue with my new BE469ZP (Z Wave). The keypad is dying, but the deadbolt can still be controlled thru Home Assistant (remotely). The keypad comes back to life for a few hours with a battery disconnect/reconnect.

I switched from the Schlage Encode (Wi-Fi). The Schlage encode never had any keypad issues, and the keypad had a much better touch screen user interface. I feel like I’ve downgraded my deadbolt. Shame on Schlage for acknowledging, but not pulling these from the shelves / recall.

For whatever it’s worth, I have the same problem and each time I complain to Schlage about this, it always comes down to them sending me another lock. I’m on my third lock. :frowning:

I’m on my third lock. Looking at this thread – it’s got to be something with the lock design or internal programming.


I was told that if you complain enough to Schlage, they’ll replace your Camelot (Z-Wave) to the Encode version.

Which is a Wi-Fi device that doesn’t integrate with ST.

Correct, but at least you have remote capability.

Mine died the same way recently, with huge zigbee lock.

I was super impressed that it took a short call and one email to get a replacement sent, hassle free

I hate to necro a thread, but this just happened to 2 of my locks. The answer: humidity. They were full of water. 102 degrees outside, 70 degrees inside. Locks dead

1 Like

Maybe consider Yale. I’ve found them more durable even in extreme weather.