Schlage BE469WK not connecting to SmartThings Even after Excluded

I currently received the SmartThings Link for NVidia Shield. I have multiple items that have successfully connect to the STLink Hub, but I have not had any luck connecting the Schlage Connect Mdl: BE469WK to the hub. I have tried multiple times to connect it and have used the Exclude function that is often suggested. I can successfully Exclude the device (the exclusion is confirmed on the phone screen when I exclude the device) but it will not connect with the STLink after being excluded. I have tried with the SmartThings Link within 6’ of the lock. The firmware on the lock is MAIN_7.1, according to the information in the Schlage Manual, but according to the Schlage website the firmware can not be updated with out a Nexia hub, is it possible there is a firmware issue, or is there something else that I can try? If it is a Firmware issue, is there anyway of updating the firmware without investing in a Nexia?

If you’re able to successfully “exclude” it, then it would have paired. A device shouldn’t exclude itself more than once without being paired thereafter. I’ve seen devices successfully pair with ST but it doesn’t show up as a successful pairing, however the device will show up in the list of devices.

@RBoy, I would fully agree that it seems like if I can “exclude” it, the lock should have paired. However, I have tried (and tried it again to confirm after getting your message. I have tried this different ways and none of them have succeeded.

These are the steps I tried:
First Try:

  1. On my Android Phone, in SmartThing App: Add a thing (wait until screen says looking for devices…)
  2. Enter Code in Schlage as required
  3. Entered 0 (required by Schlage to start Pairing)
  4. Lock flashes Red “X” indicating failure to pair.
  5. Checked list of Things in “My Home”
  6. Restarted SmartThings App to make sure Schlage was not present.

Second Try:

  1. Followed all the steps for Excluding a Z-Wave Device
  2. Received notification on Lock (green checkmark) and confirmation of device Excluded in SmartThings App.
  3. Backed out of Excluding and Home Hub screen.
  4. Followed the same steps as my first try with same results.

Third Try:

  1. Did first 3 steps from the Second Try with the same results
  2. Clicked on “Add Device Manually”
  3. Clicked on Locks
  4. Selected Schlage Camelot Touchscreen Deadbolt (matches mine)
  5. Clicked on Connect Now
  6. Immediately entered code to pair (as soon as it said looking for devices).
  7. Lock Flashed Red “X” indicating failure to pair.
  8. Backed out of Adding
  9. Confirmed Lock wasn’t part of the list, the restarted the app and checked again.

4th Try:
Everything as 3rd try except waited on Step 6 until screen said "It is taking longer than expected to find devices"
Same Result.

What is baffling me is that after every failed attempt I can run the exclude and get the Green Check confirmation and the confirmation on the phone. So it is connecting somehow, it just never shows up in the list of connected devices.
After each failure for pairing, I made sure I could still control other elements (like a lamp). I really am sincerely confused, and am unsure what to do or try, if you have any suggestions - please let me know, I am open to trying! For all 4 of these attempts I had the NVidia Shield with the SmartThings Dongle with in 4’ of the Lock, with the SmartThings Link plugged into USB Port 1 on the Shield. The Shield was less than 2’ from the Wireless router and I confirmed I had a very strong WiFi connection with both the phone and shield.

Try this:

  1. Exclude the lock
  2. Reboot SmartThings/Nvidia
  3. Open IDE Live Logging
  4. Bring the lock within 1ft of the Link
  5. Click on Add devices on your ST Mobile app
  6. Complete the pairing process on the lock

Look for any error/lock messages in the IDE Live Logging. There was a firmware bug with ST earlier for pairing Schlage locks. What’s the firmware version on your link?

I did that - unfortunately no luck, but here’s the information I have.

Multiple instances of:

Err 103: Z-Wave include failed

There were 6 instances of that error in the one attempt to include.

There were 3 times it mentioned this:

zw network:FB788FBF, node:01, suc:00

4 Instances it listed:

Z-Wave Restarting

And Finally, 4 times it listed:

Z-Wave is Ready

On the SmartThings app on the Shield it lists the following:
TV Client Version Number: 1.0.0 (121429)
Shield Hub ID: My guess is that you don’t really need the ID number :slight_smile:
Shield HubCore Version: 0.17.112

I physically removed the lock from the door and placed it directly next to the Shield when I did this attempt.

(On a side note the SmartThings Link status consistently says “Plugged In” when I used the Exclusion option through the Website for the IDE Logging, Whereas, it did always say that when I used the Phone App. When I noticed that, I tried pairing the lock again, with no luck. But I did notice that as soon as I clicked on add a thing - the status changed to “Not Plugged In”. I don’t know if that is anything I should worry about - my other Things still communicate with the SmartThings Link even when it says “Not Plugged In”)

BTW, I do thank you for your assistance, I do hope there is something that I can do with your help to make this all work, I realize that this is challenging and shouldn’t be happening so I do appreciate your patience and continued help.

I think at this stage it may be related to the firmware. Contact ST support and they can investigate the reason of the inclusion failure or if you need a firmware update. You may not have the tool to debug this much further if nothing shows up on ide Live Logging.

Maybe @duncan can tag the appropriate person looking at Link from engineering.

Thank you again for your assistance. Hopefully I can find the answer I need to get it working. I’ll try to post what the solution was when it is found.

@RBoy I didn’t get the chance to contact ST Support today, and it is definitely on the list of things I need to do. However, I thought you might like to know that a Zooz 3 Way - Z-Wave enable switch that I just got and installed today is doing the same exact thing. It is giving me the same error message in the the IDE Event Logging. So it is looking like there is something even greater that may be wrong. As I mentioned I didn’t get the chance to contact the ST Support because of work today, but will hopefully get the chance tomorrow.

I chatted with Kenneth on the Support Chat, and was able to get everything working properly. It turned out there was a minor issue with the Z-Wave module. It required a full uninstall, resetting of the SmartThings Link to get it to start working again. He was doing some things on his side to help the process. He mentioned that if anyone else has the same issue, to make sure they contact the Support Chat first before doing the full uninstall and reset, that should only be the very last resort and that it may not be what is causing the issue, he mentioned that the issue most often is an error in the exclusion step. Again thanks to @RBoy and Kenneth in the SmartThings Support staff for your help!


I will be calling tomorrow (ish)