Scenes not working

scenes

(Alex) #21

@vlad - although I am not certain on the exact date my scenes stopped working, I am no longer able to create, edit or delete scenes in the classic app. After migrating to v3 hub I created a number of scenes that worked perfectly - better than v2 where I had to hit the scene button multiple times to get it to fully work. Then, at some point it started giving me the “Something’s wrong” error when trying to load the devices. My theory was that some device I recently added (I was rebuilding my home system after tearing down v2) is breaking it but having just read about recent changes I have to wonder if the issue was introduced with those changes.


(vlad) #22

Please DM your username and I can take a look. Or contact support and send me the ticket number. It’s unlikely that what are seeing is related. The changes were with the auth side of things and they have been reverted.

@Zmarc @aruffell


(Samer Kiblawi) #23

@vlad, this issue still exists on my hub. I have a bedtime scene comprising 70 zwave devices. Is there a limit on the number of devices that can be included in a scene?
The scene fails when activated from the scene tab or through a routine. However, when I hit the “test scene” button, it functions properly.


(vlad) #24

To answer your question, there isn’t a limit on number of devices available for a scene at this time as we want users to be able to create scenes like “turn off everything”.

So for some background info -

One of the requests from our product team was to check the health status of a device when executing a scene, if the device is offline then the user should see on their phone that some devices may have failed to execute. Because of this request, we can no longer “fire and forget” the commands to the devices (command API is asynchronous - we don’t know if the device received/executed the command) , we now have to retrieve the health status of each device as well and return a list of the states to the client as part of execution to construct the list of “failed” commands. The unfortunate side effect of this (one of the main reasons I tried to resist implementation of this feature) is that execution time can be significantly longer and trigger a timeout in the client because of the increased number of calls and having to wait for them to complete. This is why you’re seeing failures (test scene works a bit differently but similar issues can occur there as well).

So that’s the issue you’re likely seeing - now how we’re going to tackle it…
I’ve talked to the team responsible for the service that provides the health status of devices and they have started working on providing a more optimal way of getting the device status for a large number of devices that doesn’t increase with the number of devices we’re requesting status for. Once this new code is made available to us, our team can then switch over, which should make the number of devices in a scene irrelevant and you’ll stop seeing errors.

I should also mention that if the devices do change their state to the setting in the scene then the above is likely what you’re seeing. If you’re getting an error and the devices don’t change state, then please submit a support ticket as its likely a different issue.


(Samer Kiblawi) #25

Vlad, thanks for the response. The scene is not executing and the devices don’t adjust to the scene levels. Fortunately, I am able to accomplish what I need through a routine, but it won’t be long before I need to create a scene with 60+ devices, so it would be nice to get to the bottom of this issue.

Thanks,

SK


(vlad) #26

There isn’t a limit, please trigger the error, create a support ticket and dm me your username, time of the error and scene name.


(Alex) #27

@vlad - For several weeks now I have been unable to create scenes as while loading devices it gives the something is wrong error. Is this issue related? Is there a fix on the horizon?


(Andrew) #28

I seem to be having the sample problem. I can’t add or edit any of my scenes.

I get: “Unable to load available devices. Please reload or try again later.”


(Alex) #29

How many devices do you have? I was told that I was suffering from a timeout due to the number of devices. The number ST mentioned included both physical, C2C and virtual devices (>200). I am able to create scenes in the new app but most of my devices do not work there so I cannot create any useful scenes… and if you create a basic one and try to edit it in the older app, it gives an error.


(Andrew) #30

More than 200, but it had worked when setting up multiple scenes. I haven’t needed to edit any of the scenes for a while and now can’t. I’m using the classic app.


(Alex) #31

Mine stopped working when I tore down my v2 hub and configured my v3 hub. The more devices I added the harder things got (issues). While scenes initially were working, they stopped at some point. I suspected a device with a bad DTH was causing trouble since scenes try to list all possible devices as a first step but ST said it was the number of devices… Maybe I should go back to check all suspect devices…


(Steven Shafer) #32

Scenes have always been a problem with my SmartThings Hub. I have about a dozen configured. As noted above, when I go to the Scenes edit, they work perfectly. No errors. However, when called from a routine, they have become less and less reliable. Six months ago they worked about 80% of the time when called from a routine. The last month the 80% has dropped to 0%. Again, they all work perfectly from the Scenes edit page. However, from the routines set-up page, they always fail, even though the ONLY thing the routine does is call the scene.

It appears that SmartThings understands why this is happening. Any chance of getting it fixed? The 0% success rate with scenes will force me to migrate to another IOT system if this can’t be addressed.