Samsung V3 hub devices stopped working

Smartthings hub V3 Stopped working.
My system had worked fine for many months. I set up my friends new hub on her completely separate account and coincidentally my hub completely stopped working. This was all done on her email and phone etc.
I don’t know if this failure has anything to do with setting up my friends location.
I called support.
They could not help.
They said a (Level 2?) tech would call me. I let them know I am not home during their open hours during the week. A tech emailed me that she was off the next Saturday but would call me the following Saturday at 6AM Pacific time. I called them on that Saturday at 6:30 AM as I had not heard from them.
The Tech called me shortly after that. She was very polite but of no help. She said she would send a note to the next layer of support. I was kind of doubting any help from them at this point.
I deleted my devices, did a factory reset and just started over. All re-installation done in about 4 hours.
I have a pretty simple setup with a Fibaro switch, 4 GE switches, some Samsung OEM devices and some Caseta switches that worked perfectly prior to this failure.
Samsung, I hope you take out a few layers from your support system.