Samsung TV Not registering in the IDE

Ok So I am in need of help and Samsung Smartthings email support has been really unhelpfull i’ve been going back and forth with them for the better part of a month and al they do is keep asking me for the exact same screenshots over and over. They literally ask me for screenshots then dont respond for over a week and when I reach out they ask me to send them the exact same screenshots I sent them. With all that being said…

I have a 2018 Samsung Q8 everything was working fine up until about a month and a half ago when Google stopped being able to communicate wit it. I check the smartthings app and saw that the TV appears offline. I remove the tv, reset the network settings on the TV and get it to connect back to ST, it shows up fine on the app I am able to control it, I can cast from my phone to the tv without issues etc. However google still can’t communicate with it, and doesn’t even see that it’s there.

I then log into the IDE and the TV is not in the ST IDE. I now reset the network and do a complete factory restore on the TV. once again I can connect to it via ST control it both inside and outside of my home, but it still not visible in the IDE. if I try to make any automations including this TV using the SmartThings app, they fail with a network connectivity error. I then factory reset the TV add it to a different ST account, and I get the exact same results, the TV not visible in the IDE and creating any automations with the TV results in a network error preventing it from being created.

Smartthings Support initially told me they dont see the TV in the backend, and asked for screenshots showing that its in the ST app. They have asked for this screenshot at least 6 times now, and ive sent it to them 6 times, plus video recordings of me using the TV via the app.

For some reason the TV does not seem like its registering with the cloud servers, even though the tV says its registered, I am able to fully control it using the app and even control it away from the house. I don’t know what else I can possibly try, and hope that someone here might have some insight or experience with something similar.

Just to confirm, when you factory reset the TV (not just reset the network settings) and add it with a different Samsung account, the TV does show in the new app? When did you most recently attempt this?

Yes I did a Smarthub Reset followed by a network reset followed by a full factory reset. I’ve done this at least 4 times now. The time that I used a different account must have been about 2 weeks ago, and yes it showed up in the app under the new account and I got the same network error when I tried building an automation with the TV and it also was not visible in the Groovy IDE.

Today about an hour and a half ago I performed the same 3 stages of reset on the TV, and removed the device from the ST app. I allowed the TV to restart and the ST app found it. I set it back up using the app on my phone verified that it was connected and even opened the ST app on the TV and was able to toggle devices. I still got the same error when trying to build an automation, and still not registering in the IDE.

Only the full factory reset should be needed. Are the below steps the ones you are following to factory reset? Are you given the option to sign in on the TV with your Samsung account or have you only added the TV via discovery in the app?

Did you previously have another location? I found logs referencing a different location for you. I attempted to delete these stale records.

Yeah that’s the reset I’ve been performing, using the PIN as you described. I’ve done the setup both ways using the TV menus and using the ST app, both methods gave me the same results.

I used to have an old location a couple of months ago before I moved. I though I had deleted the location though as I no longer see it or the hub in the IDE.

We’re looking into this. Can you create a support ticket by emailing support@smartthings.com so our CS team can track the issue?

I already have a ticket open with CS. I only decided to post in the forums because the ticket has been open with no resolution for almost a month now.