Samsung Smartcam HD Pro stopped working with Smartthings


I have a Samsung Smartcam HD Pro. It worked fine until a few days ago, but now I get the following error message on the Smarthings App: “There was a problem retrieving the livestream”.
If I use any other application, it works fine.
The Smartthings app is able to interact with the camera, changing settings or resetting the device, but the streaming is not working.

Ig I have a look at the Smartthings log I get:
70765dd2-22ec-41a7-b3dd-ccb7690418b5 16:49:00: info start, videoCoreVersion=1.5.3, dth=Samsung SmartCam, hubId=3c3f30b1-345c-43aa-9867-3a00a8a651f6, deviceId=70765dd2-22ec-41a7-b3dd-ccb7690418b5, dni=00166CBC4706, cloudStatus=on

b7264bc7-31ee-4dc5-b79e-a6b499b87884 16:49:00: debug locationHandler(json-body)= [status:error, data:[message:Unable to aquire shard info from cloud, errorcode:19]]
b7264bc7-31ee-4dc5-b79e-a6b499b87884 16:49:00: debug locationHandler(json-header)= [content-length:93, http/1.1 500 internal server error:null, connection:close, x-st-version:1.5.3, content-type:application/json, date:Sun, 12 Nov 2017 16:49:00 GMT, server:Video-Core, x-st-application:Video-Core]
b7264bc7-31ee-4dc5-b79e-a6b499b87884 16:43:07: debug locationHandler(json-body)= [status:error, data:[message:Malformed dni, errorcode:44]]
b7264bc7-31ee-4dc5-b79e-a6b499b87884 16:43:07: debug locationHandler(json-header)= [content-length:68, connection:close, http/1.1 400 bad request:null, x-st-version:1.5.3, content-type:application/json, date:Sun, 12 Nov 2017 16:43:06 GMT, server:Video-Core, x-st-application:Video-Core]

I tried resetting the camera and reconfiguring it from scratch, but nothing has changed.

Has someone any idea of the reason of it, please?

Thank you

I am too having exactly same issue, I have ST V2 with Samsung SmartCam. I am following up with Support team for almost 3 days now, no solution till now. It broke since Nov 7th 2017. Since when you are having this issue? Please keep me updated if you find any solution.


I don’t know the exact date, but approximately a date close to the 7th November.

Please, let me know if you know something from Support.

Thank you

I am also having the exact same issue with my 2 cameras. I also noticed after i removed the cameras and re added in smartthings i noticed that the icon that used to show a camera is now blank. Is yours the same? Not sure if that makes a difference but it wasn’t like that when they worked.

Not to worry anyone but the Compatible Devices list for Cameras no longer has Samsung on it, only Arlo:

Although it does still list the three Samsungs in the app. I’m hoping this isn’t a sign of even less official compatibility for cameras.

After I reinstalled it, I can still see the corret icon

When I go to the Market on the App, I can still see the Samsung camera in the list

Exactly the same for me, and no option to add/change the icon now either!

i just got a response from STs…
Jason (SmartThings)
Nov 14, 11:48 AM MST

Hey Shawn,

Thanks for reaching out to us. I am sorry to hear that you are having trouble accessing your live stream on your Samsung SmartCams. After looking at the logs, the problem is that your cameras connected, but did not populate all of the correct states to function properly. Our engineers are aware of this issue and working on a resolution and I have tagged the associated problem ticket. This means that once we have any new information or a resolution, we will follow up with you via email. However if you don’t wish to wait for a resolution, the current work around is to remove and re-add these cameras until all the correct states populate. This is not a great alternative to get your cameras working within SmartThings, but hopefully after a few attempts you will be able to access the live stream. Here is a link to our SmartCam article that explains these steps.

I hope this information helps for now, but if you do have any other questions in the meantime please don’t hesitate to let us know.

Kind Regards,

If anyone gets it to work again, please let me know.


I already removed and re-added my camera, but nothing has changed.
Do you have the link mentioned in their email?

Thank you

The Link is

I just checked my cameras again and both are working. Maybe issue has been fixed.

Does anyone know the actual fix and can publish it, I have tried everything bar throwing the camera out of the window!

I think they just fixed the problem. I did not do anything and it just
worked again.
Thanks a lot everybody for your help!




Been having the same problem with my recently purchased Samsung HD smartcams. Also with my dlink cameras that I had working prior to removing them so I could put the smartcams on smartthings. All of my cameras show inactive in smartthings but work fine in the native apps. Smartthings finds the cameras and can set them up, even reboot them yet shows them inactive and I am unable to live stream or trigger recordings by events . It’s extremely frustrating. I contacted smartthings support last week and they told me as well that it’s a known issue they are working to find a fix for. I have uninstalled all the cameras and tried reinstalling them multiple times without any luck.

Just attempted removing the cameras and adding them again, still no luck. The cameras are still showing as inactive within smartthings. Within smartthings I can find and add them, reboot the cameras, edit the settings, but still unable to get a live stream. So I currently have 4 dlink & 4 Samsung smartcam cameras and cannot get any of them receiving a live stream within smartthings. But they all work fine in the native apps.

Hi Jeromy,

mine started working again the same date I installed the latest update of
the Smartthings App on the iPhone.
But I was not sure if this solved the problem or it was something else.
Can you please double check if you have updates to be installed?

That was one of the first things I did. I fully un installed and reinstalled the app. Just to make sure I had the newest version. Unfortunately that didn’t work for me.

After the smarthub update my cameras are now working . :slight_smile: looks line the fixed the issue

Did you do anything else? my hub too was updated last night and no change for me!

Nope, they just started working after the update…