Samsung Multiroom webCoRE

I’ve yet to install WebCoRE so haven’t tried your app. I’ve found “Stop” command doesn’t work using CoRE for Samsung speakers. As this seems permanent does it make sense to incorporate into the app already a TTS message “Turning off” to stop the stream?

I’m curious how it looks in ActionTiles, I see the Music Player tile with the name of the station which is very cool, but how do you change stations? Does each station have it’s own tile? Or do have to open the SmartThings app?

You’re right about the Stop command not working for Samsung speakers. I guess it’s a Sonos command that is not implemented by Samsung. The best way I found to stop the stream with my Samsung speaker was with a TTS using Speak Text ‘Turning off’.
so that is the option I used in the piston.

I did find you could use the Play Track command with a Url like https://s3.amazonaws.com/sonos-media/bell1.mp3 and that would work too but I preferred the Speak Text.

In Action Tiles you can use the Next and Previous buttons to change to the next or previous station looping through your 8 stations.
It is not ideal as some station Url’s seem to take longer than others to resolve and rapid clicking of next or previous buttons can result in long delays whilst webCoRE catches up but I couldn’t find a better option for changing stations without going down the 8 Virtual Switches route.

(Latest Piston and DTH for my Internet Radio are in Post 24 here)

1 Like

Does anyone know how I can play an MP3 on my R3 stored on Google drive? When something happens for instance the doors open?

Thanks.

I’m using AT for this purpose :wink: added virtual buttons, and a piston similar to what @inpier has done.

My Piston

Using XX Speaker, play Track and Restore, then the path to your sound. Shouldnt that work?

This is Awesome!! Many thanks for sharing :slight_smile:

This looks great. Bit stuck with my Sonos player though and not sure if I should expect it to work in the same way as the Samsung player? Everything seems to be work and the Tile in my Dashboard suggests the selected radio stream is working but I don’t get any sound. I’ve increased the volume as but looking in the Sonos app there is not source coming through that is until I hit Stop and then the stop.mp3 plays fine.

The logs of the piston shows a few incidents of ‘Piston waited at a semaphore for 512ms’ with increasing amounts of time showing, not sure if this is a fault?

I went with the url’s already in the DH but I also used one from the Absolute site directly but still no sound.

Any thoughts?

Solved it and now this works great with my Sonos speakers, really quick to respond to button press also :smiley:

How did you get it to work? I have been having the same issue, I don’t get any sound

Play your chosen radio station on the Sonos device. Go to your IDE, browse for the Sonos device, now look for the TrackURI and this will give you the url you need.

would you please be able to help me set up a piston to increase and decrease the volume on this device?

thank you

Hi.
I am suddenly getting errors thrown when using piston from code “jkg9”:

Error while executing physical command Høytaler Bad.playTrack([http://lyd.nrk.no/nrk_radio_p13_mp3_h]): groovy.lang.MissingMethodException: No signature of method: physicalgraph.device.CommandService$_isLocalhostAction_closure4.doCall() is applicable for argument types: (physicalgraph.device.HubMultiAction) values: [physicalgraph.device.HubMultiAction@15cc1803] Possible solutions: doCall(physicalgraph.device.HubAction), call(), call(Ljava.lang.Object;), call(java.lang.Object), call(physicalgraph.device.HubAction), findAll()

(“Høytaler.Bad” is my name for a samsung speaker, name means “Speaker Bathroom”… )

Any tips or upgrades?

I need some assistance in getting webcore to tell Kodi (my DNLA) to play a playlist. Of course, I can use Play Track. But as far as I know there is not a Play Playlist command in webcore. Any thoughts?

Solved it.
It seems one of the speakers glitched out and needed a hard reset.

Trying to figure out how to change the input on my Samsung Soundbar (HW-Q70T) that’s connected to my Samsung Q65FN tv (2018)

With the default DTH, I’ve figured out that for the custom command setInputSource() the parameter string values of “digital”, “wifi”, and “bluetooth” work. However “hdmi”, “hdmi1”, “arc”, “d.in”, “din”, “tv”, “tv1”, “television” and “optical” do not work.

“digital” sets it to the D.IN/TV ARC input.
I’ve got one last input called “HDMI” on the device, but am running out of ideas of words to use to activate it.

On the same note, my tv doesn’t respond to any commands. Anyone have any luck controlling their Samsung tv inputs with webCoRE? Or even Alexa?

Long shot but have you tried “video”

No dice. I’ve don’t lots of searching but not sure if there’s some sort of list of parameters, or a way to see how the soundbar is integrated. I’m assuming since it’s Samsung it’s no longer a groovy handler. Not sure if it’s still open source.

I knew it was a long shot. I’ve seen my sony hdmi ports referred to as video1, video2, etc. So I thought I would mention it. Good luck! I have no other ideas.

Below is a list of the valid inputs:

image

The one you are looking for is ARC (HDMI out or HDMI. If the DTH is my original DTH (no longer supported since I no longer use my hub), you would need to modify the below method in the DTH as indicated below. Then run a Save Preferences. Not sure how this works any more on the IDE. The source would be Optical for TV-ARC (it is D-In and the soundbar auto-converts).

> def getSources() {
> 	def model = getDataValue("model")
> 	def sources = [:]
> 		switch(model) {
> 			case "HW-MS650":
> 			case "HW-MS6500":
> //	Add line below.  
> 			case "HW-Q70T":
> 				sources = ["wifi","bt","aux","optical","hdmi"]
> 	 			break
> 			case "HW-MS750":
> 			case "HW-MS7500":
> 				sources = ["wifi", "bt", "aux", "optical", "hdmi1", "hdmi2"]
> 				break
> 			case "HW-J8500":
> 			case "HW-J7500":
> 			case "HW-J650":
> 			case "HW-H750":
> 			case "HW-K650":
>  					sources = ["wifi", "bt", "soundshare", "aux", "optical", "usb", "hdmi"]
>  				break
> 			default:
> 				sources = ["wifi","bt","soundshare"]
> 				break
> 	}
> 	state.sources = sources
> }

Thanks. Actually I am using the default Samsung integration with the new app, and whatever handler that is. I think it’s cloud based, because I couldn’t find the code of it for the life of me. However, I got some help on facebook to the same question and was pointed in the direction of using webCoRE to identify the terms to use. (thanks @orangebucket !)

I realized that if I try to make a comparison in an if statement using the soundbar, the drop down list shows me a bunch of custom attributes, including one called supportedInputSources. I didn’t know how to utilize that, but Graham pointed me in the right direction…Write an expression somewhere (I used the Evaluation Console) so it says [Soundbar:supportedInputSources] and it just lists out exactly what I was looking for. Makes me feel silly that I spent hours of trial and error trying to guess what terms I needed to use. Anyway, here’s the output. HDMI1 is the last one I was looking for. I’m almost positive I had tried that at some point, with all caps, but I guess not.

(expression) [Soundbar:supportedInputSources] »»» (string) ["digital","HDMI1","bluetooth","wifi"]