Samsung Connect Home/SmartThings WiFi Hub Firmware Release Notes - 0.46.10

Hi @RedTx

The device event history in the app does not depend on the driver or the hub.

I think It depends on the server in your area. There are times that it is delayed by a few minutes, others by several minutes and others it is almost instantaneous. depends on the day.

If you look at the logs with the cli you will see that the driver emits the events instantly and the platform processes them to update the device states in the app instantly and sends and saves them to the history server.

1 Like

My ST Wifi Hub on f/w 46.10 completes the Zwave network repair. Loading “History” takes an excessively long time (like I can brew a coffee before it populates)

Ah, interesting. Thanks for sharing that, as I really thought it was a bug in the firmware. My Z-wave network actually seems to be working very well (I have ten or so wired Z-wave switches scattered around the house), so I’ll try to leave well-enough alone and not worry too much about what might be wrong with my system, specifically.

I e been having this issue for a few months. Youre not alone. And the location presence hasnt been working either.

Same firmware number doesn’t mean the same firmware: it just means they’ve been updated the same number of times. They are on different development tracks, have different internals, and the firmware is different between them even if it’s the exact same number.


You may want to examine your presence setup. May not be related to any firmware updates - possibly an app update or due to the start of groovy shutting down in January. Do you use virtual presence sensors? If yes, do you remember how you set them up such as simulated presence sensors through IDE?

1 Like

The last few days I have had to reboot the hub to get responses from my z-wave devices. Until reboots zigbee seems to work but with a huge delay.

All of my lighting automations have died - anyone else seeing similiar issues ?

See the following:

Smart Lighting routines disappeared (12 March 2023)

Day 26 update:
When FW 45.11 was rolled out, my Connect Home hub (ET-WV520) died (Feb 15th, 3am EST).

The hope was that the 46.10 FW would resolve the issue/s, but I don’t see it downloaded yet.

Is there anything I can do to force a FW upgrade?
I have tried a factory reset but it doesn’t seem to help.

FYI, I just learned that there is a rare issue for at least one more user, and me possibly being another one, related to this update.
The hub tries to get the update but fails because a hub property is not retrieved properly.

I’ll see if the support team can sort this one out tomorrow.

1 Like

It takes a bit longer it seems. The latest status is that support believes my hub is stuck in download mode.
Unfortunately, this also seems to prevent logs from being collected.

29 days without home automation now.

After hearing from RedTx that it completes for him, I tried again, but from an iPad, as opposed to my Android phone, and the Z-wave repair went to completion. So, at least for my setup, it appears that it may be an Android vs iOS issue and not a problem with my hub.

Loading History on my iPhone, before and after a recent 16.4 beta update, takes minutes or just times out whereas on a Samsung tablet it’s almost instantaneous. My hub is V3 on 46.10.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.