Samsung Connect Home/SmartThings WiFi Hub Firmware Release Notes - 0.46.10

I recently started having an issue where I can not get into the Smartthings Hub portion of the Wifi hub on the app. I contacted support and they are looking into it. Has anyone else had the same issues? I wonder if this will help.

iOS or Android? For me, the latest iOS app is very buggy

Thanks for considering SmartThings Wifi Hub as part of your roadmap support… since fews month you release new updates and we really appreciate it… Instead of 2021-2022 you don’t release any update for long period of times like years!!! :-(( So thanks team SmartThings to keep Wifi Hub keep up-to-date… Wifi Hub as Mesh is better then any other as Aeotec or other release… Long life for Wifi Mesh Hub (Plume).

Hope Wifi Hub will support Matter soon!

1 Like

Android. I’m not even sure how to check if the hub got updated since I can’t go into that portion of the app. Maybe somewhere in the IDE…

If the hub is shown in IDE, you can check there.

Two things to try… clear app cache and if that does not resolve… uninstall/reinstall the app.

You can use the IDE or the API Browser+ from @TAustin.

1 Like

I found it. Thanks!

That happened to me like 3 days ago, it was odd because some other samsung apps were also failing. I removed and reinstalled the app and that fixed it. Hopefully that helps

1 Like

I tried that and it didn’t help. I knew something was weird when I go into this device and it has a white background, and my phone settings and all other devices are in dark mode. It used to be fine.

And the answer to that is…no.

1 Like

Ohh :frowning: I was expecting it since both the V3 and now the WiFi hubs are running on the same firmware version… lets keep on waiting

My Wi-Fi (Plume) hub and my fridge Family Hub were both on 45.11. Fridge has Matter…Wi-Fi hub didn’t (and still doesn’t). I’m not convinced we’re going to get Matter on the Wi-Fi hubs since no one with ST will say whether it’s on the road map or not.

In addition to your the fact that the Matter Logo is not yet there, Ive just tried to add a Matter device, but wasn’t successful. Before trying I confirmed that I’ve received the firmware update.

As others have said, I’m glad to see continued support for these hubs and hoping that Matter is on the way.

I also hope that with firmware parity they’ll eventually release an easy transition mechanism to upgrade to a new hub. That is, I can accept it if they can’t / won’t bring Matter to these older hubs, but I can’t accept the time and inconvenience that would currently be involved with upgrading my hub in the event that I decide I do need Matter

The only issue I’ve been having recently is that if I try to “Repair Z-Wave network,” the process initiates, but then stops progressing, as indicated by the animated icon going static, and never reaches completion. Fortunately, I can stop the process, but I wonder if this indicates other issues with the firmware. I was hoping this latest update might fix it, but the problem persists.

1 Like

My ST Wifi Hub on f/w 46.10 completes the Zwave network repair. Loading “History” takes an excessively long time (like I can brew a coffee before it populates)

Both device and general history load extremely fast on my Galaxy Note 10+ running version of the app. Might try a phone restart or clearing the app cache.

I did phone restart and even app remove/phone restart/reload app.

The history loads marginally faster

Did a hub hard reset and that did not make a difference.

same problem. Android app reinstalled several times but no improvement. Pixel 5 running Android 13.

Hi @RedTx

The device event history in the app does not depend on the driver or the hub.

I think It depends on the server in your area. There are times that it is delayed by a few minutes, others by several minutes and others it is almost instantaneous. depends on the day.

If you look at the logs with the cli you will see that the driver emits the events instantly and the platform processes them to update the device states in the app instantly and sends and saves them to the history server.


My ST Wifi Hub on f/w 46.10 completes the Zwave network repair. Loading “History” takes an excessively long time (like I can brew a coffee before it populates)

Ah, interesting. Thanks for sharing that, as I really thought it was a bug in the firmware. My Z-wave network actually seems to be working very well (I have ten or so wired Z-wave switches scattered around the house), so I’ll try to leave well-enough alone and not worry too much about what might be wrong with my system, specifically.