Samsung ADT keyfob issue to finish test

I just signed up Samsung ADT home security service but have a very hard time at the last step of adding keyfob to the hub. Can someone with similar experience shed some light here?

For all the other adt sensors, I have to go through test mode to add them to “adt monitor” category so adt can see them by simply triggering them. So smartthings app on my iphone reminds me to do the same for keyfob but no matter how I press the buttons on keyfob in the test mode, the checkoff box will not go off in the app like other sensors does therefore the keyfob is still in “self monitor” category and that “test required” message is always showing in my smartthings app.

What is worse is that with keyfob test no finished, I can not add more sensors to adt service because whole test can not be finished. I have to remove keyfob first and then finish new sensors test then add keyfob back.

By the way, functionality-wise the keyfob works but I can not finish the test mode on it. Have someone done it successfully?

Same question/issue. Haven’t been able to get past that last step with the keyfob.

I think on mine I did the arm, disarm and panic sequences to get mine to finally pass the test. I remember it being confusing. Lol

1 Like

Thank you very much, seeharrison. The only button I did not try is panic combination. Now finally it passed test and added under “adt monitored” side. I can also see keyfob recent activity which was not available before.

The funny part is this is not mentioned anywhere in manual which says pressing any button will finish the test. I called ADT also and it was no help either. The representative on the phone even said it is not necessary to add keyfob to adt monitored category.

1 Like

Yeah, Samsung’s instructions are very useless. You have to read into things. The test procedure requires you to “trip” each sensor. Pressing the Arming or disarming buttons does not “trip” the sensor. The keyfob panic button does “trip” the sensor, since it will tell the panel to sound the alarm. The panic button is two buttons, by pressing “Stay” and “*” simultaneous for 3 seconds. Side note: it’s rather an idiotic setup for the panic buttons, since the last thing you want to do is have to use two hands or fingers to simultaneously push two of the smallest buttons on the keyfob at the same time.

Remember, anything hardware related you have to contact Samsung.

So I am having this same issue. I tried the fix here, doing the arm button, then disarm button, then panic. I have tried all combinations. I have tried having the alarm initially set to away, tried it not set at all. Nothing seems to work. Has anyone else had any luck getting these to pass the test?


So a follow up for anyone having issues. I rebooted my hub and it all seemed to work. I called ADT and asked them and they said to remove the keyfob and then add again and try. I did that and it still didn’t work until I rebooted the hub. Also one of my keyfob’s won’t pair now.

So for anyone having this issue, try rebooting your hub first, then enter test mode and just set off panic. Worked for me.