SmartThings Community

Ryobi modular smart garage door opener


(John) #83

Wow…I’m feeling like a kid on Christmas right now. My Craftsman/Chamberlain Garage Door openers have been nothing but trouble and I’ve been dying to replace them with the Ryobi openers since I’m a HUGE Ryobi fan with their One+ system but the one thing holding me back was no Smart Home integration and needing a separate app. However, you just totally made this purchase possible! Thank you @madj42 !!

Now…I just have to budget money and time on buying and installing two new garage door openers!


(Rob74lee) #84

@madj42 I ended up changing the code and removing the battery info in the device handler. I found out this morning that my backup battery doesn’t charge. I think that was why I wasn’t getting any percentages in the Smartthings app. Once I changed the code all is working wonderfully. Once I go get a new battery this weekend I will change it back and report results to this forum. I also changed the size parameters on the door open, door close and the light buttons as they were small on my phone. She is running like a new car now! Thanks again sir!


(Rob74lee) #85

@Jnick this man has worked hard at giving us this diamond in the rough. His contributions have pushed this from being a wish and a dream to a fully operation smart home device compatible with Smartthings and Homekit via Homebridge! I am truly appreciative! Shout out to @madj42!


(Justin Dybedahl) #86

Thanks guys for the kind words. :slight_smile: @rob74lee, have you tried plugging the battery in again to see if it charges? I had the same problem with mine a couple months back and once I reseated it, it started charging again.


(Rob74lee) #87

@madj42 I actually took it out and put it on the charger in the house. It is deader than a doorknob. I only have one other battery that I use for the trimmer and blower. I will pick a new one up this weekend.


(Justin Dybedahl) #88

Undocumented feature I threw in there. Something to let you know your battery was dead. Haha. Let me know how it works after the new battery and I’ll look into any issues if need be. Thanks for reporting back what it was.


(Rob74lee) #89

@madj42 good morning! I just picked up the battery this morning and installed it. Charge is at 100%. Deleted modified code and added your DTH. In the events list in smart things it shows that the battery reports 100%. On the app it does not report a percentage. Everything else seems to be fine. Door opens and closes with no problem.


(Chris) #90

Any idea if this will work for the new model GD201? Mine came with a separate wifi module and door sensor.


(Justin Dybedahl) #91

@Cbarth3 Honestly have no idea as I don’t have any way to test it. I don’t see why not as it should use the same API calls. As long as the information I’m pulling has the same values, it should be fine. Let me know if you run into any issues and I’ll try and help.

@rob74lee I misread your post and originally thought all was working. Are you still having issues? If so, add “log.debug batstatus” after the “def” on line 95. Add it again after the “}” on line 109. The first value is what’s returned from the proxy service and the second is what’s modified after the IF statements in the DTH. If it’s set in the device properties itself, it should show in the mobile app.


(Rob74lee) #92

@madj42 Great stuff here! I’m now showing percentage on both smart things and in Homekit. I thought it wasn’t working but I had to copy over your code again since I had made some changes on my end. All s well my friend. As usual thank you again!!!


(Chris) #93

Well I tried to get this installed on my Raspberry Pi and got the following


(Kyle Salewski) #94

I am JUST trying to read up on all of this because I bought the Ryobi GD201 from Home Depot today since it is back for only $148 (great deal). I’m super excited you guys have gotten this working. Looking to see if I can somehow link this through my Google Assistant - no SmartThings setup yet but I might have to set one up.


(Rob74lee) #95

@cbarth3 scroll up a bit and see I had similar issues until @madj42 had me go back and install the correct program on my pi. Try that and you should be ok.


(Rob74lee) #96

@kyle_salewski I’m not too familiar with Google assistant. It seems to be more compatible with devices and programs than either HomeKit or SmartThings. Is there a developers forum from Google? I do believe that Google does talk to SmartThings but not completely sure. I will do some research now and report back.


(Justin Dybedahl) #97

@Kyle_Salewski I may be incorrect but I don’t think the Google assistant supports garage door device types yet. The device is properly configured on the smartthings side to report to Google, if supported, that it is a garage door and also a light fixture. I’ll look more into this when I get home tonight as I’ve been wonder g the same thing. The other idea I had was to set a routine up that opens the door and call that through Google assistant.

@rob74lee @Cbarth3 rob is right, you may want to double check how your getting the code to the pi as it looks like you saved the page through your browser and then copied it to the pi. I would recommend going to the code page on github, clicking the raw button, and copying and pasting it to a new file. Then copying that to the pi. The output you got indicates there is some html in the file, this shouldn’t be and that’s what leads me to believe that it was saved.


(Justin Dybedahl) #98

@Kyle_Salewski here is the page I was referring to. It wouldn’t work without support from smartthings. https://support.smartthings.com/hc/en-us/articles/214837343-How-to-connect-Google-Assistant-with-SmartThings


(Chris) #99

Alright for some reason when I downloaded the files it messed the files up. I copied and pasted the code and it now shows server running. I went through and got the device setup and it just always shows it as open though.


(Justin Dybedahl) #100

Does the door or the light turn on? Please run the debug js that is on the github repo for within a terminal on the pi. Let me know what the output of the terminal is in a pm after sending a few commands from the smartthings app. That should help determine the issue.


(Justin Dybedahl) #101

Just a friendly reminder. This is only confirmed working for the Gdo200. With the newer GDO201 models, Ryobi changed the websocket commands for controlling the door. Since I do not have this model, someone with this model will have to use a packet sniffer (one that supports SSL decryption) to sniff the traffic between the phone and the GDO. If someone provides the commands, I’ll put it in the app.


(Benji) #102

Just keep in mind this would have to be running ON the phone, likely a rooted/jailbroken phone. You won’t be able to sniff SSL traffic anywhere in between.

Well, I mean, you’ll be able to sniff it but you won’t be able to decrypt it.