Rule Machine Version 1.9 Released

(might be my fake name?) #21

I’m thinking about using these new features to refresh my harmony activities every x minutes instead of a using a motion sensor as a trigger. I’ll finish watching Villanova crush Miami first.

(Bernie H) #22

Could you share this? I’m sure it’s simple to set up but I’m doing something wrong. Thanks.

Osram/Sylvania Lightify (it works)

Very basic conditional trigger. Been working well so far.

(Bruce) #24

I think I may expand upon this just slightly to allow two Trigger Events in one Trigger to use Periodic. Due to the design of Cron, anything that doesn’t work can often be done with two Crons.

For example, the 90 minute problem can be solved by having two Periodics each running every 3 hours, but 90 minutes apart. RM could do that if I allowed two Periodics.

Every other week, however, in the literal sense, is not possible. Doing First and Third week of a month is fine, but won’t yield every other week exactly, due to the 5th partial week in some months. This really is a limitation from Cron’s design, as it doesn’t treat week as an element of a cron expression, only day of week.

(Bernie H) #25

Thanks I did’t see the conditional trigger option for some reason but working now. :slight_smile:

(Bob) #26

Well done, Bruce! ‘Periodic’ works perfectly, and opens a new world of possibilities.

(Bruce) #27

Can you Create New Rule in RM? I cannot.

[Resolved?] Check Your Installed Parent/Child Apps
(might be my fake name?) #28

Can’t create a rule in iOS either

(James Yeo) #29

Oh man… now my wife will support me buying some colour lighting. We have dumb colour bulbs and she really likes random colour party bulbs, now I can do that in ST easily for her!!

Also, I have a aeo tech doorbell with a friggin useless button. I bought an iris smart button for it, but the btton falls asleep. So it always has to be pressed twice to work. (Why is it so hard to get a reliable doorbell?) I wonder if I can figure out something to do to keep it awake with this?

(Bruce) #30

We may be witnessing the death of Rule Machine before our eyes.

(James Yeo) #31

It’s every smart app on my end. At least every existing smart app, I can’t edit. I just added a new iteration of dim with me that worked, but I can’t do anything with ones already set up

(Bob) #32

No; get “Unfortunately, SmartThings has stopped.” But I was able to do it last night, so I don’t think it’s an RM issue. Funny thing is, it doesn’t actually crash. It just goes back to the SmartApps screen after hitting OK. This is on Android, BTW.

(Bobby) #33

Android is dead too!

(Bruce) #34

Android was working 45 minutes ago, but not now. iOS is toast.

(Bobby) #35

Yeah…and nothing in the logs. However, the active rules are running…

(Michael Hess) #36

Mine’s working fine on Android.

(Bob) #37

You can create a NEW rule?

(Bruce) #38

Can you Create New Rule?

(Bob) #39

No, that’s what generated the error.
and as @SBDOBRESCU said, it doesn’t generate an event in live logging.

We need to duplicate this in an “official” app to get Support’s attn.

(Michael Hess) #40

Oh sorry, I just tried to edit one and that worked, you are correct FC for me too.