Rule Machine Version 1.8 Released

I’m torn about this update.

I’m not sure it is the best idea.

EVERYTIME I switch screens, the ST app takes FOREVER!

I’d really rather wait for one really really slow page load than multiple really slow page loads.

Seriously, please consider timing it to see which way is faster.

Thank you!

They’re all fast now, especially the new in-between one. Seriously, it’s much faster. Try it, and if you hate it I’ll give you a way to opt out.

I figured out why some screens are fast and some are slow. Try it.

It’s not your app. It’s the ST app. I absolutely HATE the ST app. It’s just SO frickin’ slow from one screen to the next.

To be fair, I haven’t tried your tweak, I just really dread using the ST app.

I LOVE rule machine, but hate that in order to use it, I have to use the ST app.

(BTW, it took you like 12 seconds to respond here. What the heck? Did you go to the bathroom or something?) :sunglasses::sunglasses::sunglasses:

I am having trouble with an error while building a trigger. When I go into the actions area and select Run Rules, Actions, set Boolean, It goes to the next page, stays blank and gives an error. Here are a few screenshots, this is on Android.

Ah, the infamous “unexpected error”. This is a platform or Android issue. Keep trying is all I can suggest.

This error cannot be reproduced on iOS, nor could I reproduce it on Android.

Hi Bruce,

I just installed version 1.8 of Rule Machine and Rule and now I am hitting an error on one of my existing rules. I have a conditional trigger that turns on a switch if I press a particular button on my new Remotec ZRC-90. I am using a custom device type I found here -

The error that I am getting is this -

java.lang.IllegalArgumentException: Command ‘size’ is not supported by device d88355d8-8a67-482a-90cd-4c59c8f3f16b of type ‘Remotec ZRC-90 Scene Master’. Supported commands: [configure] @ line 610

Does the device type need to be updated to stop this error? Thank you in advance for your help.


Ken Fontenot

The new version has a bug. If I go into an action section but don’t use it - or if I delete the action - then I receive “an unexpected error has occurred” at every page. I am then unable to do anything further with that rule and must cancel out to main screen.

Same issue for me


I thought this may have just been me but indeed, if you go into something but then back out without doing anything, you get unexpected errors every time you try and do something and you have to basically start the rule again.


Not sure why you assume this is a Rule Machine bug. “An Unexpected Error has occurred” is a platform failure. I cannot reproduce this. I can go into Actions, and back out with no error. I can create an Action, go out to main page, go back in and delete the action, back to main page: no error.

I have never seen “An unexpected error” be anything but a platform problem. That is, real errors from Rule Machine never have that message.

It is a platform error. Have you upgraded your Android app? I am seeing the same after last update. To avoid getting many unexpected errors, I try to use ‘done’ instead of back button.

I’m not but perhaps I need to take a video of what I mean.

I know there has been the dreaded “Unexpected Error” around the SmartThings app (which I haven’t experienced in a long time but this definitely hard kills RM, I have to completely back out of a new rule and start it again if I do something wrong.

I just need to find a way to take a video directly from my phone because I’m not very good at explaining what I mean.

No video needed.

It really doesn’t matter. Unexpected Error is an error in the interface between the mobile app and the cloud. It’s a platform bug. The fact that Rule Machine may step on the bug is irrelevant, because there is nothing I can do about it. There is nothing about Rule Machine that is weird that would cause this. Obviously, it worked before (with other bugs on Android), so now a new release comes out, and SURPRISE, we fixed some bugs and broke a bunch of other things.

I can reproduce this on Android, and not on iOS. I just installed another little app on Android, not even related to RM, and I get Unexpected Error when attempting to remove it. Can’t remove it.

So, it’s very clear that once again, Android mobile app is filled with cock roaches. Complain to ST. Write to Support. Don’t complain to me… :grinning:

Ok, my bad.

20 characters.

Someone at ST should fix it so it says “An Expected Error has occurred. Sorry”.

But it would take 6 months just to get to QA.

FYI…I noticed a change in parent/child apps. Not sure if it was introduced with Android app or by other means, but the child is no longer saved if you don’t click “done” on the parent. This could potentially throw a lot of expected unexpected errors.

I currently have 4 simple rules that I’m testing with Rule Machine. These are simple time triggers (7:30am, 1:30pm, 7:30pm and 1:30am). For some reason, the 7:30am rule never causes the switch to come on. Checking the job history on the rule, I see that it is triggering correctly. However the message never gets to the switch. The other 3 times of day it works fine.

I’ve tried deleting and re-creating the rule. I’ve also tried changing it to a different time (8:00am). Still no luck. What is the recommended next step for debugging this issue? Is there another log file, perhaps on the SmartThings hub, that I can access to see what messages are being processed?

I suspect Rule Machine is working fine based on its logs, so trying to figure out where to look next. Thanks!

Update: Found the “Events list” for my Hub. I see the APP_COMMAND in the log for the rules that are working. But no APP_COMMAND ever appears for that one morning event. Strange.

That’s funny. And, it’s probably right, in fact I thought that was always the case.

But, be that as it may, I happened to make a modification today to Rule Machine, the parent, so that when you first install it in the Marketplace, you have no choice but to hit Done. Then it’s installed, and available under SmartApps as usual. I should have done that a long time ago, to avoid all of the problems with people not hitting Done. Sometimes a problem stares you in face and you just don’t see that it could be easily fixed.

BTW, I think they did fix submitOnChange: true for Android. Check it out and let me know.

1 Like

I guess this is the android app problem, but I cannot select any run rules, bolean etc. It does not matter if it is a fresh rule with nothing else entered, or an existing rule. it will error out every time it opens the screen with the rules/booleans. The page is blank with the error at the top and a remove button being the only things on it. Is it possible to go back to an older version? I did not have these issues with 1.7.

Hi Bruce

I’m getting a “Sorry, but there was an unexpected error.” but only when entering the “Run Rules, Actions, set Boolean” group under actions. Entering any other action group works fine. This has only started when I updated to v1.8. From what you’ve said above I assume its a platform problem but just seems odd its only when entering that one group?

haha sorry about doubling up with the post above, good timing 24v