Rule Machine Expert Features [deprecated]

Yea, that’s the issue I’m fighting! I’ll have a patch here in a bit.

@bamarayne , @sgoncalves
Check your pm’s for a link to an interim patch to resolve this.
This will be included in the next release, but that may be a few days.

In the meantime, the current 1.6.0 rule machine expert code has the following bug
Selecting a parameter type on the parameter page, without entering a value, and then leaving the page will cause subsequent attempts to enter the new custom commands page to fail.
So for now, enter a parameter value, or unselect the parameter type before leaving the page.

In other words, if you’re going to use a parameter, it must have a value!

I noticed that in the devices field it doesn’t show my garage door, motion sensor, or my contact sensors which some have temp.

Is this by design? I’m not sure exactly how the programming sees the devices, just curious.

For the garage opener, that’s most likely because the device type does not have capability.actuator. You could modify the device type to add this (one line) and save/publish for yourself, and edit the device’s device type to this new device type.

Also, you can’t use the Expert Features to access the temperature in those sensors, because the Expert Features are only for Actions with devices that have commands available, which sensors generally don’t have. You can access the temperature of those sensors in Rule Machine as a trigger event or condition.

1 Like

Ok, I understand about the temp sensors and the garage. I’m going to attempt the change in the device type.

I’m trying to learn the programming side and unfortunately my work has me on the road all of the time… It’s my busy season!

But in the mean time, thanks again for everything. You guys are great and really make this system into something that it should be.


The patches to resolve a few expert bugs when creating commands are now live in Rule Machine 1.6.2

Issueing TTS (text to speech) commands to speakers using expert does work btw, subject to st’s tts engine working. As of right now it appears that only previously caches commands are available.
New ones throw some pretty ugly errors, that for the most part are now captured in expert and will prevent you from saving the non cached commands.
playTextAndResume(‘Good Night’,80) will work, where as playTextAndResume(‘did smartthings fix tts yet?’,80) will not.

Here’s another tts tip.
The result of a successful tts command is a reference to an mp3 url. You can capture this url by watching the logs for your speakers.
Once you have the url, you can use that to create a playTrackAndRestore command.

Anyway of getting this to support Landroid to issue Text to Speech to Android Devices? I currently have my device setup with BigTalker, however clicking on expert mode in Rule Machines does not seem to identify the device to select and test commands on. I was hoping for a way to be able to push TTS to my Android tablet using either this or Rule Machine. - Landroid
Android as a Speech/Alarm Device released! And Updated! - Thread about Landroid

[OBSOLETE 1.1.6 5/25/16] Big Talker - Talk when events occur - Bigtalker SmartApp that uses Landroid devices to send pre-defined TTS on events.

Appreciate the help.

1 Like

In the device type definition section add: capability “actuator”, it will show up in the custom device listing after that.

1 Like

Awesome, that worked, thanks.

The ability to add arbitrary labels to the commands created would be a great benefit here.

Currently the commands I use are completely random - play(9) for example, and being able to label it with something understood by humans would be helpful for example “Door Chime”…

1 Like

I had thought about this initially, and dismissed it due to the limited UI functions available. Doesn’t mean I won’t do it, I get the value.

I have an odd error.

I’ve installed the very latest version of Rule Machine and Rule. I have set up tested and saved a few custom commands for device types that I created. However, when I go to actions for either a rule or a trigger I do not see the option at the bottom (or anywhere else) to select a device and custom command.

Any idea what is going on?

@AdamV, Interesting. You have the latest Rule and rule machine correct? And the commands that you saved are in the saved commands to test list right?
Are the custom device options available if you create a new rule?

yep - I’ve got the latest code and the saved commands are in the saved commands to test list. Unfortunately no options in the actions menus for rules and triggers for new or old rules and triggers. I’d like to avoid deleting everything and reinstalling and setting up all the rules again if possible! However, I will do if necessary as there are some really cool things I want to do with this feature.

Uninstall should not be required, I’ve tested adding commands and making sure that they were visible in both current and existing rules. Can you pm me a screen shot from the ide of one of your current rules, a small one will do.

Could you look in the IDE, My Locations, List SmartApps, find the rule in question and click on it. Scroll down to the section that shows Application State, and take a screenshot of that. Post that back here…

its for all of them (as the option is not there on any) - but this is the trigger that I wanted to start using this feature for

Yea, somethings wonky…