Rule machine - as per the app developer, this app is no longer available for new installs, distribution, or support

No. We say “Rules” because the name of the child-app is Rule. All of your automations created with Rule Machine are Rules.

That’s confusing, because the main and original automation you can create with Rule Machine is a “Rule”. And, you can create Triggers, Conditional Triggers, and Actions. Any of these can lose their Application State, and become effectively zombies. The reason I say zombies is that their event subscriptions are still intact. So events are still triggering them, usually to do nothing since they may not remember what to do. So think of them as lobotomized Rule zombies wandering around in your SmartThings account doing hopefully nothing, just like in the movies.

If that’s not bad enough, Rule Machine itself can be lobotomized. When that happens all of your Rules will disappear, or all of your Custom Commands, or both. Usually, closing Rule Machine and re-opening it will cure the first part, but not the second.

1 Like

That paints a great mental picture (ha) - thanks!
:japanese_ogre: <-- (closest I could find to a zombie)

The one bad one that I know of is that if a trigger associated with a Minimote button goes bad, the entire Minimote will malfunction. Pressing one button can be like pressing more than one button. It’s a hot mess. And that is after it becomes a zombie.

I’ve got this same situation - day mode in the middle of the night.

1 Like

IF YOU HAVE ZOMBIE RULES

Remove these Rules as soon as you discover them. They can do bad things in your system. They still have subscriptions to events intact, and may have actions attached to those. However the conditions or rule are gone, so these may fire when they should not.

There is no point in contacting Support about this. They don’t know what’s going on, but this is a known issue to ST.

7 Likes

This may have been mentioned already. If it has, just move along. This thread is monstrous and I haven’t read it all.

When some of my rules turned into zombies, I was able to tap through each section of the rule configuration (Triggers, Conditions, Rule, and Actions) and the settings were still there. I just tapped “Done” on each sub-page and the rules came back to how they had been before being lobotomized.

This is not what most of us are encountering. We can’t get past it coming up as Actions, with the right name, but nothing else. There is no way from there to step through those choices.

Bruce, et al

Here is the reply from ST from my ticket, doesn’t seem like they all got the memo that it is a ST issue…

"Sorry for the delay in response. We have been dealing with a large number of support requests.

I don’t know why the rules for Rule Machine would be losing it’s settings. I took a look at things from my end, but not seeing anything. I use Rule Machine myself, but it is a custom community SmartApp that we don’t have control of. I would check with the community page for Rule Machine.

Sorry that I don’t have any other suggestions about why this is happening."

Rick

@bravenel For what it’s worth I too have experienced what @btk has experienced.

Perhaps it’s just a matter of which part(s) of the app’s state get(s) clobbered. But where would the app get the information to repopulate it if it’s not in state?

I have a very basic rule that would send me a text when a door/window is open when in Home Mode.

It worked fine for months, yesterday it quit sending texts. Every screen was fine, nothing missing or out of place. I deleted it, recreated it and it started working fine. Today it did the same thing. This time I went into the rule, checked everything, no changes… selected done back out and it started working

Rick

1 Like

I’ve had that happen too (momentary switch lose its state). Toggling worked for me. Hopefully, you’ll be lucky too.

1 Like

We understand the symptoms and I think we are fairly close to having a fix for this. Once I can confirm the disappearing state issue is resolved, I will post here immediately. I know that issues like this are frustrating. I want to reiterate what @slagle said above about tagging me. I welcome any tagging on any issue you think needs attention. You can also PM me anytime day or night or email me at

jody@smartthings.com

10 Likes

Yesterday the system lost application state on:

  • Rule Machine - Everything was gone. Hitting DONE and going back showed all the rules again but Custom Commands was lost, meaning I had to recreate all custom commands and Edit all the Rules that were using it;
  • 3 Rules so far that I’ve noticed

Hey @Jody, can you give us any additional information on what you guys think could be causing this?
(We are really desperate and tired of babysitting ST :cry:)

I think you meant to tag @jody.albritton

There is a long list of people wondering the same thing, so please get in line…or in other words, hurry up and wait, they are ‘working on it as we speak’ to quote @slagle

I’m trying to set my dimmers to a certain level or change the color of my bulbs to a color but I don’t want the light to turn on. Is there any one action that does that? It seems all the actions I try turn the light on.

Sorry if this has been asked before. I did a few searches but couldn’t find anything.

Nope, no such thing as a dimmer or color preset without the device turning on.

This just happened to me for a few rules. But I have also previously had nothing there as others have described.

This morning, after having pretty much stayed out of the ST app for the most part over the past month or so since the Melt-Down began, I went into RM and found what I suspect is a small village of headless what’s-its (rules without their conditions, etc).

In some cases, I think they were probably still firing, but since I’ve been gone on vacation and sick for a couple weeks and had no idea what was or wasn’t working, I decided to start ushering them to the edge of town, and telling them they are no longer needed.

Not looking for a response; just wanted to vent…oh, and NOT about RM!

1 Like

Join the club, my friend!

1 Like