Routine with Zooz 4-in-1 Sensor not working as I expect

Hello. I had purchased the Zooz 4-in-1 sensor primarily for the temperature reading. I understand that it’s main purpose is motion sensor so the temperatures are updated pretty much when it feels like it.

I created a routine that says between the hours of 3PM and 10PM, and if the temperature is >87F, to turn on the fan in the garage. I’m finding that it’s just not working - the fan isn’t turning on. On the flip side, I have a routine that says if the temperature <87F, ensure the fan is off. I can’t see what I might be doing wrong.

This is what one of the routine looks like:
IF 3:00 PM - 10:00 PM
AND Zooz Multipurpose Sensor Temperature > 87
AND Garage Fan is Off
THEN
Garage Fan Turn On

If it’s the sensor and there is a better one out there, I would love to know what might work better. Maybe it’s the time functionality. I just can’t figure this out.

Thank you

If you’re expecting it to turn on at exactly 3 pm when the temperature is already above 87 then you need to use an exact time instead of a time range. The start and end times of a time range don’t act as a trigger for the automation, but an extract time does. With your current scenario the fan will only turn on if the temperature or fan condition changes during the time range.

1 Like

Thank you. My plan was to only have the fan come on during those hours if the temperature was > 87. I’ll have to read more about the time range. For now, I’ll just up an automation to turn the fan on at 3 and turn off at 10 pm. I was hoping to only do this if the temperature reached 87.

Again, much thanks!

You can. it will probably require two Routines:

  1. the one you have with time range and other conditions.
  2. Another with specific time of 3 pm and other conditions.

You can also install this Edge driver, Virtual Calendar Mc device and do this automation

Link to Channel to install driver

Let’s not complicate things with a custom calendar edge driver. IT works out of the box when properly setup.

Depends on what mean by complicate things!

If you do not use additional virtual devices, calendar or other, that act as a trigger at the beginning and end of the period, you only guarantee the execution of the automation if the temperature has a change within the specified period.

And of course use more than one automation, 2 or 3 minimum

1 Like

Thank you for all your help. I tried Edge but couldn’t figure out how to use it. I was able to Enroll and install the driver you indicated. I just couldn’t figure out what to do next. I’ll keep trying!

Hi @DZangger,
Sorry for not answering earlier, in my location it was the bedtime and I just saw it when I got up. :wink:

It’s very easy, you have to do a normal automation. Virtual Calendar in one more device in your hub.

For example, In your original automation, in the IF part:

  • remove the time period
  • click on + to add another condition
  • Find and choose the virtual calendar and mark Local Hour (0 to2359):
    • Write 1500, which is 3 p.m. and mark greater than or equal
    • Click on save

  • Click on + to add another condition
  • Find and choose the virtual calendar and mark Local Hour Two(0 to2359):
    • Write 2200, which is 10 p.m. and mark less than or equal
  • Click on save
  • Set your temperature condition
  • Save the automation and you’re done.
1 Like