Routine Director forcing me to put in a phone number

The new “Routine Director” app, which I was told I needed to update to based on my usage of the old “Hello, Home Phrase director” has what I’m pretty sure is a bug. It’s now forcing me to input my phone number during setup.

This has the effect of me getting a push notification AND a text message every time an event happens. @slagle this wasn’t intentional, was it? Can you please make text messages optional again?


1 Like

I ran into this, as well. I decided to keep the old version around instead.

Was not the design. Submitted the fix. Shouldn’t be too long.

1 Like

still hasn’t been fixed I don’t think. Had the same thing happen this morning (error saying to use routine director) but must enter mobile. I couldn’t even save it after entering number tho.

Feature request: would love it if you could set the hello day to only occur between 7am and 5am so that it doesn’t wake you up with door unlocking.

What’s the status of this fix? It’s been a month, I’m still getting duplicative text messages. When I tried to re-do setup a few days ago it still forced me to put in a phone number.

I put in 9 numbers for a phone number and it took. So I don’t get any notifications

This should be fixed now, is it not?

Nope. Just tried it, still forces me to put in a phone number. I followed @Gietlt’s lead for now, just used all 9s.

I don’t think this has been fixed yet as I just removed the app and installed it again. I just put in all 0’s. What prompted me to remove the app and reinstall was that Routine Director was working as it should by firing off routines at the right moment, however nothing would happen for that routine. On my message feed, it would say whatever routine was initiated, but no confirmation message, such as “I changed mode from Home to Away as you requested…etc, etc.” I sometimes see the same routine on my message feed coming up more than once, but never a confirmation. Has anyone else had this issue? Removing the app and re-adding it seems to fix the issue, but this inst the first time I’ve had to do this. @slagle, have you seen this before? Thanks!

This just illustrates how bad things must be at ST. They don’t even know if a problem has been fixed.

This is an issue we are working on, routine director works, the routine just doesn’t execute.

Also, for the phone issue, it works fine on my phone, but I have an iphone, maybe you have an android and that is why? I’ll test on a android later today.

Thanks for directing me to that other thread. As for the phone thing, I’m using an iPhone. It doesn’t let me not put an input. Since, I don’t want SMS alerts, just push alerts, I input the 0’s to satisfy the input requirement, not a big deal…


1 Like