SmartThings Community

Rooms Manager: Smarter Rooms: Personalized home automation with Occupancy


(the rooms manager guy) #1689

the screenshots dont seem to show the humidity rule or is the app not showing it but its there?

(Richard Bryant) #1690

Oops wrong room, updated post

(the rooms manager guy) #1691

thanks. found the issue. there is % change to trigger match on the rule that is getting hidden when using humidity value.

fixed. coming in this weekends release.

(Sylvain) #1692

Hi Bangali
I love your smartapp. Thanks for working on that.

I need your help . I want to control a light in my bathroom .
I have a probleme when i take my shower the light goes off too quickly. I need to have a rule with my humidity sensor .
So when there is more humidity in the bathroom i want a longer period of time for the light to stay on .

When i try to ad my humidity sensor to the rules , i got an error , something went wrong…
Sensor is already set in the room device . Dont know if its matter but its a xiaomi humidity sensor.

Is it possible to do that ?

Thanks you

(the rooms manager guy) #1693

thank you.

usually its better to use a contact sensor for this. humidity sensors take a certain amount of time for the humidity in the new room to buildup and they generally if they are battery driven they dont do very frequent readings. so by the time the humidity rises the room might already go from occupied to vacant.

so the sensor is specified in the room devices but you are looking to add an humidity value to the rule itself and when you do that it throws an error? if yes:

  • log in to the ST IDE
  • go to the live logging page in the IDE
  • from the app try the step which throws an error while viewing the live logging
  • is there an error shown in the logs?
  • if yes please copy and paste the error here so i can check out whats happening


(Sylvain) #1694

I agree but the xiaomi temp and humidity sensor is reacting fast , it take less then a minute to start the fan when i take my shower

No there nothing in live logging . i only get this screen in the app


I also tried another sensor and im getting the same error.

Thank you

(the rooms manager guy) #1695


so if you have the ST IDE live logging open in a browser window while updating the rule it does not show any error in those logs?

(the rooms manager guy) #1696

updated to github with the following changes:

Version: 0.99.1

DONE:   12/01/2018

1) added parent/child version check.
	- first version that checks when settings are saved
	- next version will also check at runtime
	- **in 99.9% of the cases if you see any error in the logs this is the cause. i.e. rooms code was only partially updated or settings for all apps/(DTH || driver) were not saved when updating the code resulting in these errors.**
2) added feature back for room engaged with music
	- if using this feature remember to save settings for this room if its already been setup
3) added recovery for recurring processing if those schedules get cancelled
4) changed countdown timer display to 30 second interval because some users are impatient when watching the countdown to make sure it works ;-)
5) fixed bug for contact sensor spoken announcement and hidden percentage change trigger for humidity rule value

(Richard Bryant) #1697

Can you explain the settings for Humidity please? Didn’t see it Github

(the rooms manager guy) #1698

room humidity from the device will be compared to the value specified in settings. if its 5% over or under the dehumidifier or humidifier respectively turned on. then turned off either when the humidity is back at the value and its run for at least the minimum run time. it will also be turned off if its run over the maximum run time.

(Andy Hawks) #1699

One of my room devices just disappeared from the phone app device list (SmartThings classic). It does not appear in the device listing at either. It still appears in the ‘rooms manager - 0.99.1’ app. When I resave it it does not get added back to the device list, but there are no errors in Live Logging, just a notification that the room was updated. If I try to ‘Remove Room’ in the rooms manager app I get ‘An unexpected error has occurred’ in the phone app, but no error shows up in Live Logging.

If I try and create a new room to replace the old, basically the same thing happens. The new room appears to save ok and I get the green notification that it’s activated. But it does not show up in the device listing on the phone app or the smartthings api ide. Then if I try and delete the room I get ‘unexpected error’ but nothing shows up in live logging.

How do I fix?

(the rooms manager guy) #1700


when you go to view all settings for the room does it say child device OK up top?

also logout and login to the ST IDE then go back to live logging and see if any error shows up when trying the same steps as above.

(Richard Bryant) #1701

Now if I only knew which one it is… hmmmm

Rooms Manager: 1 battery is low.

(the rooms manager guy) #1702

thats the sms … if you had setup voice announcements it would have told you which one :wink:

(Richard Bryant) #1703

Hmmm Maybe it did, I wasn’t home when I got the SMS…

(the rooms manager guy) #1704

i am adding any battery low alerts to the rooms manager settings under battery level check settings so there is a please in the app to find it.

while at it might as well add an alerts section to rooms manager so any battery or device alerts show soon as you open rooms manager app. :slight_smile:

(Andy Hawks) #1705

Yup, shows ‘Room child device * * Child device OK’.

Logged out and back in to SmartThigns IDE, SmartThings App, viewed room settings and resaved - no additional info in Live Logging, no errors, update seems to have completed successfully.

The weird thing is the missing Room doesn’t show up in my ‘Things’ list or the device list from the IDE, but it’s still present in Webcore, and if I change the name of the Room and re-save rooms, that updated room name is reflected in Webcore.

So I’m not sure if this is a Rooms Manager issue or a SmartThings device list issue. But either way it’s a huge pain in the butt to not be able to manually change the room occupancy state.

(the rooms manager guy) #1706

from the data points so far seems like this one probably is an ST issue. ST has had multiple issues in the last couple of days. lets give it a couple of days and if the device is still not showing in things may be we can dig in?

(Darren) #1707

@bangali Quick one, maybe I’m blind, but did you implement this change? Reason I’m asking is I can not see it (or I’m just looking in the wrong place).

In my case I have 4 Lux Sensors in my kitchen, that I’m using to figure out my best average to use in the app,

why not specify all 4 lux sensors in the app and save then check the rooms occupancy device page to find the average lux value at any given time?

Why am I looking for it, recently my kitchen lights are doing a disco routine when someone enters the room, on/off, on/off, on/off then eventually stay on. Funny thing is its not all the time, so trying to troubleshoot and understand whatever the condition is that’s making this happen (I have an idea (may be right, may be wrong)), but the lux setting should help.

(the rooms manager guy) #1708

support for multiple lux sensors has been there for sometime now. is that the feature you were asking about?

thats odd … did the room state change or only the lights going on and off?